ProblemO

Time Limit : 2000/1000ms (Java/Other)   MemoryLimit : 65536/32768K (Java/Other)
Total Submission(s) : 1   AcceptedSubmission(s) : 1

Problem Description

A friend of you is doing research on theTraveling Knight Problem (TKP) where you are to find the shortest closed tourof knight moves that visits each square of a given set of n squares on achessboard exactly once. He thinks that the most difficult part of the problemis determining the smallest number of knight moves between two given squaresand that, once you have accomplished this, finding the tour would beeasy.<br>Of course you know that it is vice versa. So you offer him towrite a program that solves the &quot;difficult&quot; part.<br><br>Your job is to write a program that takes two squares a andb as input and then determines the number of knight moves on a shortest routefrom a to b. <br>

 

 

Input

The input file will contain one or moretest cases. Each test case consists of one line containing two squaresseparated by one space. A square is a string consisting of a letter (a-h)representing the column and a digit (1-8) representing the row on thechessboard. <br>

 

 

Output

For each test case, print one line saying"To get from xx to yy takes n knight moves.". <br>

 

 

Sample Input

e2 e4

a1 b2

b2 c3

a1 h8

a1 h7

h8 a1

b1 c3

f6 f6

 

 

Sample Output

To get from e2 to e4 takes 2 knight moves.

To get from a1 to b2 takes 4 knight moves.

To get from b2 to c3 takes 2 knight moves.

To get from a1 to h8 takes 6 knight moves.

To get from a1 to h7 takes 5 knight moves.

To get from h8 to a1 takes 6 knight moves.

To get from b1 to c3 takes 1 knight moves.

To get from f6 to f6 takes 0 knight moves.

算法分析:

题意很难理解,上网搜才知道其实这是国际象棋,就相当于中国象棋的马走日。

很经典的一道bfs,正好拿来强化队列。

代码实现:


#include<bits/stdc++.h>
using namespace std;
struct coordinate
{
int x,y,step;
};
int dx[8]={-1,-2,-2,-1,1,2,2,1},//坐标增值
dy[8]={-2,-1,1,2,-2,-1,1,2};
int main()
{
char xy[3],x1y1[3];
coordinate a,b;
int vis[9][9];
int x1,y1,x2,y2,i=0,endx,endy,flag=1;
queue<coordinate>q;
while(scanf("%s%s",xy,x1y1)!=EOF)
{

a.x=xy[0]-96;
a.y=xy[1]-48;
//cout<<a.x<<a.y<<endl;
endx=x1y1[0]-96;
endy=x1y1[1]-48;
// cout<<endx<<endy<<endl;
if(a.x==endx&&a.y==endy)//一开始在终点
{
cout<<"To get from "<<xy<<" to "<<x1y1<<" takes "<<0<<" knight moves."<<endl;
break;
}
flag=1; //初始化工作,很重要
memset(vis,0,sizeof(vis));
while(!q.empty())//清空队列
{
q.pop();
}
a.step=0;
q.push(a);
vis[a.x][a.y]=1;


while(!q.empty())
{
if(flag==0) break;
a=q.front();
q.pop();

for(i=0;i<8;i++)
{
b.x=a.x+dx[i];
b.y=a.y+dy[i];
if(b.x>=1&&b.x<=8&&b.y>=1&&b.y<=8&&!vis[b.x][b.y])
{

b.step=a.step+1;
vis[b.x][b.y]=1;
if(b.x==endx&&b.y==endy)
{cout<<"To get from "<<xy<<" to "<<x1y1<<" takes "<<b.step<<" knight moves."<<endl;//找到
flag=0;//flag简化时间
break;
}
q.push(b);
}
}
}
if(flag==1)
cout<<"To get from "<<xy<<" to "<<x1y1<<" takes "<<0<<" knight moves."<<endl;

}

return 0;
}