Problem G
How many zeros and how many digits?
Input: standard input
Output: standard output
Given a decimal integer number you will have to find out how many trailing zeros will be there in its factorial in a given number system and also you will have to find how many digits will its factorial have in a given number system? You can assume that for a b based number system there are b different symbols to denote values ranging from 0 ... b-1.
Input
There will be several lines of input. Each line makes a block. Each line will contain a decimal number N (a 20bit unsigned number) and a decimal number B (1<B<=800), which is the base of the number system you have to consider. As for example 5! = 120 (in decimal) but it is 78 in hexadecimal number system. So in Hexadecimal 5! has no trailing zeros
Output
For each line of input output in a single line how many trailing zeros will the factorial of that number have in the given number system and also how many digits will the factorial of that number have in that given number system. Separate these two numbers with a single space. You can be sure that the number of trailing zeros or the number of digits will not be greater than 2^31-1
Sample Input:
2 10
5 16
5 10
Sample Output:
0 1
0 2
1 3
________________________________________________________________________________________
Shahriar Manzoor
16-12-2000
题意:输入两个数n,base。求n!(n的阶乘)的结果在base进制下转换的值尾0的个数和base进制下值的位数。
一道题看了一个下午,浏览了无数大牛的博客求解这个题目的方法。最后只是把0的个数的求法完全搞明白了,其他的还是迷迷糊糊。
这个博客讲解的关于求n!后0的个数比较详细,很好懂。
数学就是博大精深,有必要稍稍了解一下。
代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 1 << 20;
double get[maxn];
void len()
{
for (int i = 1; i < maxn; i++)
{
get[i] = get[i-1] + log(i);
}
}
int main()
{
len();
int n,base;
while (scanf("%d%d",&n,&base)!=EOF)
{
int nn = n, base1 = base,pbase;
int maxp = 1;
for (int i = 2; i <= base; i++)
{
pbase = 0;
while (base % i == 0)
{
maxp = i;
++pbase;
base /= i;
}
}
int pn = 0;
while (n)
{
n /= maxp;
pn += n;
}
printf("%d %d\n",pn / pbase,(int)(get[nn]/log(base1) + 1e-9) + 1);
}
return 0;
}