Untitled
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 751 Accepted Submission(s): 403
Problem Description
a and n integers b1,…,bn. After selecting some numbers from b1,…,bn in any order, say c1,…,cr, we want to make sure that a mod c1 mod c2 mod… mod cr=0 (i.e., a will become the remainder divided by ci each time, and at the end, we want a to become 0). Please determine the minimum value of r. If the goal cannot be achieved, print −1 instead.
Input
T≤5, which represents the number of testcases.
For each testcase, there are two lines:
1. The first line contains two integers
n and
a (
1≤n≤20,1≤a≤106).
2. The second line contains
n integers
b1,…,bn (
∀1≤i≤n,1≤bi≤106).
Output
T answers in T lines.
Sample Input
2
2 9
2 7
2 9
6 7
Sample Output
2 -1
Source
有中文版的题目,请自行翻译。
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
int n,m;
int num[25];
int v[25];
int minn ;
int cmp(const void *a,const void *b)
{
return *(int*)b - *(int*)a;
}
void DFS(int cnt,int aa)
{
if(aa == 0)
{
minn = min(minn,cnt);
}
if(cnt >n ||aa<num[n-1])
{
return ;
}
for(int i=0;i<n;i++)
{
if(v[i] == 0 && aa>=num[i])
{
v[i] = 1;
DFS(cnt+1,aa%num[i]);
v[i] = 0;
}
}
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
{
scanf("%d",&num[i]);
}
minn = 999999;
memset(v,0,sizeof(v));
qsort(num,n,sizeof(num[0]),cmp);
DFS(0,m);
if(minn == 999999)
{
printf("-1\n");
}
else
{
printf("%d\n",minn);
}
}
return 0;
}