Welcome to XTCPC

 

 

 

Time Limit : 1000 MS

 

Memory Limit : 65536 KB 



Problem Description

Welcome to XTCPC! XTCPC start today, you are going to choose a slogan to celebrate it, many people give you some candidate string about the slogan, but the slogan itself must have something relavant to XTCPC, a string is considered relevant to XTCPC if it become XTCPC after deleting some characters in it. For example, XTCPC, XTCCPCC, OIUXKKJATSADCASPHHC is relevant, XX,FF,GG,CPCXT,XTCP is not. Now you have to write a program to judge whether a string is relevant to XTCPC.

Input

First line an integer t(t≤100), the number of testcases. For each case, there is a string(length≤100, all are uppercase characters).

Output

For each case, output case number first, then "Yes" if the string is relevant, "No" if the string is not relevant. Quote for clarify.

Sample Input


3XTCPCCCCXXXXTTTTCCCCPPPCCC


Sample Output


Case 1: YesCase 2: NoCase 3: Yes




#include<stdio.h>
#include<string.h>
char a[10000010];
int main()
{
    char b[10];
    b[0] = 'X';
    b[1] = 'T';
    b[2] = 'C';
    b[3] = 'P';
    b[4] = 'C';
    int n = 0,i,j;
    int m;
    int T;
    int pp = 0;
    scanf("%d",&T);
    while(T--)
    {
        pp++;
        scanf("%s",a);
        n = 0;
        n = strlen(b);
        j = 0;
        for(i=0;a[i]!='\0';i++)
        {
            if(a[i] == b[j])
            {
                j++;
            }
        }
        if(j == n)
        {
            printf("Case %d: Yes\n",pp);
        }
        else
        {
            printf("Case %d: No\n",pp);
        }
    }
    return 0;
}