Black Box

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 8710

 

Accepted: 3576

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 

N Transaction i Black Box contents after transaction Answer (elements are arranged by non-descending) 1 ADD(3) 0 3 2 GET 1 3 3 3 ADD(1) 1 1, 3 4 GET 2 1, 3 3 5 ADD(-4) 2 -4, 1, 3 6 ADD(2) 2 -4, 1, 2, 3 7 ADD(8) 2 -4, 1, 2, 3, 8 8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8 9 GET 3 -1000, -4, 1, 2, 3, 8 1 10 GET 4 -1000, -4, 1, 2, 3, 8 2 11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 



Let us describe the sequence of transactions by two integer arrays: 



1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 


2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 


The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 



Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4 3 1 -4 2 8 -1000 2 1 2 6 6

Sample Output

3 3 1 2

Source

Northeastern Europe 1996

      题意:第一行输入两个正整数n,m;n表示有n个数据,m代表m次操作,第二行输入n个数据,第三行有m个整数a1,a2,a3...am,每一个整数ai都表示输入第二行数据中的前ai个数据,然后求ai个数据中第h小的数字,h的值是第三行输入的整数的顺序(例如题面上第三行的数据中 “1的h的值为1””“2的h的值为2”“6的h的值为3”  “6(第二个6)的h的值为4”)



     思路:定义两个优先队列,一个从大到小排列q2,一个从小到大排列q1,将前h大的数放在q1中,剩下的放在q2中,每次插入优先队列都要对q2的第一个数据进行比较,如果比q2大,就直接插入到q1中,否则将q2的第一个数据插入到q1中,然后把比较的数放在q2中,当然q2的size小于h的时候直接存在q2中,总之这样做的目的是让序列中的前h大的数在q2中。



点击打开链接


#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>

using namespace std;

int n,m;
int a[30011],b[30011];
int cnt;

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        priority_queue<int, vector<int>, greater<int> > q1;///从小到大排列
        priority_queue<int, vector<int>, less<int> > q2;///从大到小排列
        while(!q1.empty())
        {
            q1.pop();
        }
        while(!q2.empty())
        {
            q2.pop();
        }
        int ans = 0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d",&cnt);
            for(int j=ans+1; j<=cnt; j++)
            {
                if(q2.size()<i)
                {
                    q2.push(a[j]);
                }
                else
                {
                    if(a[j]<q2.top())
                    {
                        q1.push(q2.top());
                        q2.pop();
                        q2.push(a[j]);
                    }
                    else
                    {
                        q1.push(a[j]);
                    }
                }
            }
            if(q2.size()<i)
            {
                int num = i - q2.size();
                for(int k=1; k<num; k++)
                {
                    b[k] = q1.top();
                    q1.pop();
                }
                printf("%d\n",q1.top());
                for(int k=1; k<num; k++)
                {
                    q1.push(b[k]);
                }
            }
            else
            {
                printf("%d\n",q2.top());
            }
            ans = cnt;
            if(!q1.empty())
            {
                q2.push(q1.top());
                q1.pop();
            }

        }
    }
    return 0;
}