搜索


Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u


Submit  Status


Description



呃......变形课上Harry碰到了一点小麻烦,因为他并不像Hermione那样能够记住所有的咒语而随意的将一个棒球变成刺猬什么的,但是他发现了变形咒语的一个统一规律:如果咒语是以a开头b结尾的一个单词,那么它的作用就恰好是使A物体变成B物体. 
Harry已经将他所会的所有咒语都列成了一个表,他想让你帮忙计算一下他是否能完成老师的作业,将一个B(ball)变成一个M(Mouse),你知道,如果他自己不能完成的话,他就只好向Hermione请教,并且被迫听一大堆好好学习的道理. 



 



Input



测试数据有多组。每组有多行,每行一个单词,仅包括小写字母,是Harry所会的所有咒语.数字0表示一组输入结束. 



 



Output



如果Harry可以完成他的作业,就输出"Yes.",否则就输出"No."(不要忽略了句号) 



 



Sample Input



so soon river goes them got moon begin big 0



 



Sample Output



Yes.



Hint



Hint  Harry 可以念这个咒语:"big-got-them".







#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<queue>

using namespace std;

#define N 1086
int map[N][N],v[N];

void BFS()
{
    memset(v,0,sizeof(v));
    queue<int>q;
    q.push(2);
    v[2] = 1;
    while(!q.empty())
    {
        int t = q.front();
        q.pop();
        if(t == 13)
        {
            printf("Yes.\n");
            return ;
        }
        int i;
        for(i=1; i<=26; i++)
        {
            if(map[t][i] == 1 && v[i] == 0)
            {
                q.push(i);
                v[i] = 1;
            }
        }
    }
    printf("No.\n");
}

int main()
{
    char a[1000];
    while(scanf("%s",a)!=EOF)
    {
        if(a[0] == '0')
        {
            continue;
        }
        memset(map,0,sizeof(map));
        while(a[0]!='0')
        {
            int x,y;
            int l = strlen(a);
            x = a[0] - 'a'+1;
            y = a[l-1] - 'a'+1;
            map[x][y] = 1;
            scanf("%s",a);

        }
        BFS();
    }

    return 0;
}