所用到的工具
CiscoPacketTracer_v6.2.rar:https://www.lanzous.com/i9xkjyf
实验文件:https://www.lanzous.com/i9xkgoh
拓扑图
要求
telnet远程管理时使用密码登入实验
需求:根据拓扑的标识完成项目考核配置,使得通过PC0可以telnet远程登陆管理两台二层交换机。要求配置相关密码配置如下:
enable 密码:class
telnet 密码:cisco
Switch2配置项:
主机名称为Switch2、创建VLAN、SVI、f0/1接口mode、enable密码、line vty 0 4 密码、默认网关。
Switch3配置项:
主机名称为Switch3、创建VLAN、SVI、f0/1接口mode、enable密码、line vty 0 4 密码、默认网关。
三层交换配置项:
开启路由模式routing、创建VLAN、SVI
查看考核项如下步骤:
PT Activity窗口下方的“检查结果”--〉打开活动结果窗口中点击“评估项目”(以下项目就是要求配置的内容)
switch2
Switch>
Switch>en
Switch>en
Switch>enable
Switch#con
Switch#conf ter
Switch#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname Switch2
Switch2(config)#en
Switch2(config)#enab
Switch2(config)#enable pass
Switch2(config)#enable password class
Switch2(config)#vla
Switch2(config)#vlan 3
Switch2(config-vlan)#exit
Switch2(config)#int vla
Switch2(config)#int vlan 3
Switch2(config-if)#
%LINK-5-CHANGED: Interface Vlan3, changed state to up
Switch2(config-if)#ip add
Switch2(config-if)#ip address 192.168.3.1 255.255.255.0
Switch2(config-if)#exi
Switch2(config-if)#exit
Switch2(config)#ip de
Switch2(config)#ip default-gateway 192.168.3.1
Switch2(config)#int vlan 3
Switch2(config-if)#no ip add
Switch2(config-if)#ip add
Switch2(config-if)#ip address 192.168.3.2 255.255.255.0
Switch2(config-if)#exit
Switch2(config)#line vty 0 4
Switch2(config-line)#pass
Switch2(config-line)#password cisco
Switch2(config-line)#login
Switch2(config-line)#
Switch2(config-line)#
Switch2(config-line)#exit
Switch2(config)#do sh run
Building configuration...
Current configuration : 1107 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch2
!
enable password class
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
interface Vlan3
ip address 192.168.3.2 255.255.255.0
!
ip default-gateway 192.168.3.1
!
!
!
!
line con 0
!
line vty 0 4
password cisco
login
line vty 5 15
login
!
!
end
Switch2(config)#
Switch2(config)#int f0/1
Switch2(config-if)#sw
Switch2(config-if)#switchport mod
Switch2(config-if)#switchport mode tr
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to up
Switch2(config-if)#
Switch2#
Switch3
Switch>enable
Switch#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname
Switch(config)#hostname Switch3
Switch3(config)#vlan 4
Switch3(config-vlan)#int vlan 4
Switch3(config-if)#ip address 192.168.4.2 255.255.255.0
Switch3(config-if)#exit
Switch3(config)#enab
Switch3(config)#enable pass
Switch3(config)#enable password class
Switch3(config)#int f0/1
Switch3(config-if)#sw mo tru
Switch3(config-if)#sw mo trunk
Switch3(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan4, changed state to up
Switch3(config-if)#
Switch3(config-if)#do sh run
Building configuration...
Current configuration : 1084 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch3
!
enable password class
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
interface Vlan4
ip address 192.168.4.2 255.255.255.0
!
!
!
!
line con 0
!
line vty 0 4
no login
line vty 5 15
login
!
!
end
Switch3(config-if)# exit
Switch3(config)#ip de
Switch3(config)#ip default-gateway 192.168.4.1
Switch3(config)#line
Switch3(config)#line vty 0 4
Switch3(config-line)#pass
Switch3(config-line)#password cisco
Switch3(config-line)#login
Switch3(config-line)#do sh run
Building configuration...
Current configuration : 1130 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch3
!
enable password class
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
interface Vlan4
ip address 192.168.4.2 255.255.255.0
!
ip default-gateway 192.168.4.1
!
!
!
!
line con 0
!
line vty 0 4
password cisco
login
line vty 5 15
login
!
!
end
Switch3(config-line)#
switch0
C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(25r)SEC, RELEASE SOFTWARE (fc4)
cisco WS-C3560-24PS (PowerPC405) processor (revision P0) with 122880K/8184K bytes of memory.
3560-24PS starting...
Base ethernet MAC Address: 0002.4A02.DE8D
Xmodem file system is available.
Initializing Flash...
flashfs[0]: 4 files, 0 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 64016384
flashfs[0]: Bytes used: 8918747
flashfs[0]: Bytes available: 55097637
flashfs[0]: flashfs fsck took 1 seconds.
...done Initializing Flash.
Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4
Loading "flash:/c3560-advipservicesk9-mz.122-37.SE1.bin"...
######################### [OK]
Restricted Rights Legend
Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.
cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706
Cisco IOS Software, C3560 Software (C3560-ADVIPSERVICESK9-M), Version 12.2(37)SE1, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Thu 05-Jul-07 22:22 by pt_team
Image text-base: 0x00003000, data-base: 0x01500000
POST: CPU MIC register Tests : Begin
POST: CPU MIC register Tests : End, Status Passed
POST: PortASIC Memory Tests : Begin
POST: PortASIC Memory Tests : End, Status Passed
POST: CPU MIC interface Loopback Tests : Begin
POST: CPU MIC interface Loopback Tests : End, Status Passed
POST: PortASIC RingLoopback Tests : Begin
POST: PortASIC RingLoopback Tests : End, Status Passed
POST: Inline Power Controller Tests : Begin
POST: Inline Power Controller Tests : End, Status Passed
POST: PortASIC CAM Subsystem Tests : Begin
POST: PortASIC CAM Subsystem Tests : End, Status Passed
POST: PortASIC Port Loopback Tests : Begin
POST: PortASIC Port Loopback Tests : End, Status Passed
Waiting for Port download...Complete
--More--
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
If you require further assistance please contact us by sending email to
export@cisco.com.
cisco WS-C3560-24PS (PowerPC405) processor (revision P0) with 122880K/8184K bytes of memory.
Processor board ID CAT1037RJF7
24 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)
63488K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 0002.4A02.DE8D
Motherboard assembly number : 73-9673-09
Power supply part number : 341-0029-05
Motherboard serial number : CAT103758VY
Power supply serial number : DTH1036C7UB
Model revision number : P0
Motherboard revision number : A0
Model number : WS-C3560-24PS-E
System serial number : CAT1037RJF7
Top Assembly Part Number : 800-26380-04
Top Assembly Revision Number : B0
Version ID : V06
CLEI Code Number : COM1100ARC
Hardware Board Revision Number : 0x01
Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 26 WS-C3560-24PS 12.2(37)SE1 C3560-ADVIPSERVICESK
Cisco IOS Software, C3560 Software (C3560-ADVIPSERVICESK9-M), Version 12.2(37)SE1, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Thu 05-Jul-07 22:22 by pt_team
Press RETURN to get started!
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
%LINK-5-CHANGED: Interface FastEthernet0/2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
%LINK-5-CHANGED: Interface FastEthernet0/3, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state to up
Switch>
Switch>
Switch>
Switch>en
Switch>enable
Switch#conf
Switch#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 2
Switch(config-vlan)#vlan 3
Switch(config-vlan)#vlan 4
Switch(config-vlan)#exit
Switch(config)#int vlan 2
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up
ip
% Incomplete command.
Switch(config-if)#ip add
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#int vlan 3
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan3, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to up
Switch(config-if)#
Switch(config-if)#ip add
Switch(config-if)#ip address 192.168.3.1 255.255.255.0
Switch(config-if)#int vlan 4
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan4, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan4, changed state to up
ip add
Switch(config-if)#ip add
Switch(config-if)#ip address 192.168.4.1 255.255.255.0
Switch(config-if)#exi
Switch(config-if)#exit
Switch(config)#int f0/3
Switch(config-if)#swo
Switch(config-if)#swi
Switch(config-if)#switchport acc
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#ip ro
Switch(config)#ip rout
Switch(config)#ip routi
Switch(config)#ip routing
Switch(config)#do sh run
Switch(config)#do sh run
Building configuration...
Current configuration : 1332 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
switchport access vlan 2
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
!
interface Vlan3
ip address 192.168.3.1 255.255.255.0
!
interface Vlan4
ip address 192.168.4.1 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Switch(config)#