Problem Description

求n个数的最小公倍数。

Input

输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。

Output

为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。

Sample Input

2 4 6

3 2 5 7

Sample Output

12

70

这个题主要注意的就是怎么去求2个数的最小公倍数。

每次求2个数的最小公倍数,再用这个最小公倍数和下一个数求最小公倍数,以此类推。。。

import java.util.Scanner;

public class Main {
public static void main(String args[]){
Scanner sc = new Scanner(System.in);

while(sc.hasNext()){
int n = sc.nextInt();
int res = sc.nextInt();
while(n-->1){
int a = sc.nextInt();
res = Lcmm(res,a);
}
System.out.println(res);
}


}

private static int Lcmm(int res, int a) {
int m = res/gcd(res,a) *a;
//System.out.println("m= "+m);
return m;
}

private static int gcd(int res, int a) {
int c = res%a;
while(c!=0){
res =a;
a=c;
c=res%a;
//System.out.println("a");
}
return a;
}
}