某企业交换网络综合配置

  1. 1. 项目背景

某企业在不断发展,业务量也在不断扩大,同时对计算机网络应用的依赖程度与日俱增.为适应互联网时代的发展,目前公司正面临转型,急需成立IT部门.你作为几年前入职的网络工程师被任命为IT部门的技术经理,并担任本次网络规划的项目经理.你需要根据企业网络需要优化现有网络资源。

假设某企业有员工1000人,有销售部(300人),技术部(100人),财务部(50人),综合部(50人),研发部(500人);各部门相互隔离,完成所有网络的互联互通。 

  1. 2. 项目需求

公司项目经理已经按照上述要求对网络设备进行了相应的地址规划.要求先对网络设备进行配置使之可以实现互连互通,具体要求如下: 

  • λ 按照拓扑图完成IP地址规划表的规划;
  • λ 配置网络设备的接口IP地址;
  • λ 给交换机接口配置正确的接口模式(如access、trunk等)
  • λ 配置链路聚合;
  • λ 配置生成树协议;
  • λ 配置Vlan间路由;
  1. 3. 项目拓扑

 

ios 交换init方法 ip交换_IP

  1. 4. 项目网络地址规划

部门

设备名称

IP地址

子网掩码

描述

研发部

PC1

10.73.5.1

/22

VLAN10

销售部

PC2

10.73.10.1

/22

VLAN20

技术部

PC3

10.73.15.1

/22

VLAN30

研发部

PC4

10.73.5.2

/22

VLAN10

销售部

PC5

10.73.10.2

/22

VLAN20

技术部

PC6

10.73.15.2

/22

VLAN30

财务部

PC7

10.73.20.1

/22

VLAN40

综合部

PC8

10.73.25.1

/22

VLAN50

财务部

PC9

10.73.20.2

/22

VLAN40

综合部

PC10

10.73.25.2

/22

VLAN50

远程管理PC

PC11

192.168.73.1

/24

VLAN60

 

设备名称

接口

IP地址

子网掩码

描述

LSW11

Vlanif10

10.73.5.254

/22

Vlan10的网关

Vlanif20

10.73.10.254

/22

Vlan20的网关

 

Vlanif30

10.73.15.254

/22

Vlan30的网关

LSW9

Vlanif40

10.73.20.254

/22

Vlan40的网关

Vlanif50

10.73.25.254

/22

Vlan50的网关

 

Vlanif60

192.168.73.1

/24

Vlan60的网关

 

5项目实施要求

任务一:配置接口IP地址;

任务二:在接入交换机创建Vlan,把接口加入到规划的Vlan中;

任务三:在核心交换机配置业务Vlan的网关地址;

任务四:在核心交换机配置链路聚合;

任务五:在交换机配置生成树协议;

任务六:完成网络测试。

  1. 5. 项目实施步骤

步骤一:配置接口地址(采用基于接口的VLAN划分方式配置)

  1. (1) LSW1-LSW4交换机配置:

创建相关VLAN

指定E接口号——配置接口类型为access——将接口加入到指定VLAN

指定G接口号——配置接口类型为trunk——配置Trunk类型接口加入的VLAN

代码如下:

system-view  //进入系统视图

vlan batch 10 20 30  //在交换机中创建3个VLAN(VLAN10、VLAN20、VLAN30)

 

Access类型接口配置:

interface Ethernet 0/0/1  //进入接口0/0/1

port link-type access  //进入该接口配置,为access接口类型

port default vlan 10  //将0/0/1端口加入到vlan10中

interface Ethernet 0/0/2  //进入接口0/0/2

port link-type access  //进入该接口配置,为access接口类型

port default vlan 20  //将0/0/2端口加入到vlan20中

interface Ethernet 0/0/3   //进入接口0/0/3

port link-type access//进入接口0/0/2

port default vlan 30  //将0/0/3端口加入到vlan30中

 

 

Trunk类型接口配置:

interface GigabitEthernet 0/0/2

port link-type trunk

port trunk allow-pass vlan 10 20 30

 

其余同层交换机也如上配置

(2) LSW5-LSW8交换机配置

创建相关VLAN

指定G接口号——配置接口类型为trunk——配置Trunk类型接口加入的VLAN

链路聚合配置:

定E-Trunk

system-view

vlan batch 10 20 30

 

Trunk类型接口配置:

interface GigabitEthernet 0/0/1

port link-type trunk

port trunk allow-pass vlan 10 20 30

interface GigabitEthernet 0/0/22

port link-type trunk

port trunk allow-pass vlan 10 20 30

链路聚合:

interface Eth-Trunk 1  //创建eth-trunk1接口
mode lacp-static  //配置Eth-Trunk的工作模式为静态LACP模式

interface GigabitEthernet 0/0/24
eth-trunk 1
interface GigabitEthernet 0/0/22
eth-trunk 1

interface Eth-Trunk 1  

port link-type trunk
port trunk allow-pass vlan 10 20 30

其余同层交换机也如上配置

 

(3) LSW9-LSW10交换机配置

创建相关VLAN

指定G接口号——配置接口类型为trunk——配置Trunk类型接口加入的VLAN

链路聚合配置:

定E-Trunk

 

VLAN间配置:

创建并进入VLANIF接口——配置相应的IP地址——配置单播静态路由

STP生成树协议配置:

LSW10设置为根桥:stp priority 0.

LSW10设置为根桥:stp priority 0.

system-view

vlan batch 10 20 30

 

Trunk类型接口配置:

interface GigabitEthernet 0/0/1

port link-type trunk

port trunk allow-pass vlan 10 20 30

interface GigabitEthernet 0/0/3

port link-type trunk

port trunk allow-pass vlan 10 20 30

链路聚合:

interface Eth-Trunk 1
mode lacp-static

interface GigabitEthernet 0/0/1
eth-trunk 1
interface GigabitEthernet 0/0/2
eth-trunk 1

interface Eth-Trunk 1
port link-type trunk
port trunk allow-pass vlan 10 20 30

VLAN间路由配置:

interface vlanif 10
ip address 10.73.5.254 22  //添加一个IP地址作为网关

interface vlanif 20
ip address 10.73.10.254 22  //添加一个IP地址作为网关

interface vlanif 30
ip address 10.73.15.254 22  //添加一个IP地址作为网关

interface GigabitEthernet 0/0/4
interface vlanif 1
ip address 172.16.73.1 24  //添加一个IP地址作为网关

ip route-static 0.0.0.0 0.0.0.0 172.16.73.2

 

STP生成树协议:

stp priority 0

其余同层交换机也如上配置

 

步骤二:

  1. (1) 相同VLAN间测试连通性PC1->PC4

 

ios 交换init方法 ip交换_链路_02

  1. (2) 不同VLAN间测试连通性PC1->PC5、PC1->PC7

 

ios 交换init方法 ip交换_IP_03

 

ios 交换init方法 ip交换_ios 交换init方法_04

  1. (3) 远程管理机与其他PC间连通性PC11->PC1

 

ios 交换init方法 ip交换_链路_05

 

  1. 6. 项目总结

安装时电脑不太配合,最后在实验室完成了作业,画拓扑图时经常连错线,不过最后还是成功完成了。

  1. 7. 项目完成心得体会

这次的作业,我在网上查阅了大量资料,成功完成了本次作业。这次的作业让我对书本上的知识有了更深刻的理解,也学会了拓扑这一项新技能。对各种协议有了更全面的理解。最大的困难是一开始不知道怎么下手,后来经过Google搜索后后慢慢找到了对于的知识点,就能渐渐动手做起来。在拓扑过程中对对各种网络协议的理解解析后,我更深刻地理解到学好IP通信这门课程对于以后工作的重要性。