Lotto


Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 6610

 

Accepted: 4188


Description


In the German Lotto you have to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k > 6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34]. 

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S. 


Input


The input will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.


Output


For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.


Sample Input


7 1 2 3 4 5 6 7 8 1 2 3 5 8 13 21 34 0


Sample Output


1 2 3 4 5 6 1 2 3 4 5 7 1 2 3 4 6 7 1 2 3 5 6 7 1 2 4 5 6 7 1 3 4 5 6 7 2 3 4 5 6 7 1 2 3 5 8 13 1 2 3 5 8 21 1 2 3 5 8 34 1 2 3 5 13 21 1 2 3 5 13 34 1 2 3 5 21 34 1 2 3 8 13 21 1 2 3 8 13 34 1 2 3 8 21 34 1 2 3 13 21 34 1 2 5 8 13 21 1 2 5 8 13 34 1 2 5 8 21 34 1 2 5 13 21 34 1 2 8 13 21 34 1 3 5 8 13 21 1 3 5 8 13 34 1 3 5 8 21 34 1 3 5 13 21 34 1 3 8 13 21 34 1 5 8 13 21 34 2 3 5 8 13 21 2 3 5 8 13 34 2 3 5 8 21 34 2 3 5 13 21 34 2 3 8 13 21 34 2 5 8 13 21 34 3 5 8 13 21 34


Source




题目分析:

给你一组数  1 2 3 5 8 13 21 34  让你全排列这组数  任取六个数  但这六个数必须从小到大排列  

这个就是全排列  

这全排列的一个代码    这就是全排列模板

#include <cstdio>
#include <cstring>
int n,m,a[10],arr[10]={3,4,5,6},mark[10];
void dfs(int v){
if(v >= n){
for(int i = 0;i < n;i++)
printf("%d ",a[i]);
printf("\n");
return ;
}
for(int i = 0; i< n;i++){
if(!mark[i]){
mark[i] = 1;
a[v] = arr[i];
dfs(v+1);
mark[i] = 0;
}
}
}
int main(){
while(scanf("%d",&n)==1){
memset(mark,0,sizeof(mark));
dfs(0);
}
}




和上面的对比就多了一个控制 从小到大排列的语句

#include<cstdio>
#include<cstring>
int n,num,k;
int arr[]={1,2,3,5,8,13,21,34};
int a[10],mark[20];
void dfs(int v)
{
if(v>6)
{
for(int i=1;i<=6;i++)
printf("%d ",a[i]);
printf("\n");
}
else
{
for(int i=1;i<=n;i++)
{
if(!mark[arr[i]]&&arr[i]>a[v-1]) // 就在这里 arr[i]>a[v-1] 控制从小到大排列
{
mark[arr[i]]=1;
a[v]=arr[i];
dfs(v+1); // 这里的循环不好理解 我建议用编译器调试一下看看 每一步执行以后数据的变化 多测试几组估计就明白怎么回事了, // 我就是这样调试了几遍才理解了。
mark[arr[i]]=0;
}
}
}
}
int main()
{
while(~scanf("%d",&n)&&n)
{
for(int i=1;i<=n;i++)
scanf("%d",&arr[i]);
memset(mark,0,sizeof(mark));
dfs(1);
printf("\n");
}
}