lily的好朋友xiaoou333最近很空,他想了一件没有什么意义的事情,就是统计一篇文章里不同单词的总数。下面你的任务是帮助xiaoou333解决这个问题。

Input有多组数据,每组一行,每组就是一篇小文章。每篇小文章都是由小写字母和空格组成,没有标点符号,遇到#时表示输入结束。Output每组只输出一个整数,其单独成行,该整数代表一篇文章里不同单词的总数。Sample Input

you are my friend #

Sample Output

4


#include <iostream>
#include <string>
#include <set>

using namespace std;
const int max = 10001;

int main()
{
string line,str;
set<string> a;
while (getline(cin , line) && line != "#")
{
a.clear();
for (int i = 0; i < line.length(); i++)
{
str = "";
while (i < line.length() && line[i] >= 'a' && line[i] <= 'z')
{
str += line[i];
i++;
}
if (str!="")
a.insert(str);//set 会去重
}
cout << a.size() << endl;
}

return 0;
}
#include<bits/stdc++.h>
using namespace std;
int main()
{
string str, temp;
set<string> ss;
while(getline(cin, str))
{
if(str == "#") break;
ss.clear();
stringstream sss(str);
while(sss >> temp)
ss.insert(temp);
cout << ss.size() << endl;
}
return 0;
}