1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

是时候把PAT,java,六级提上日程了。

题意是求:从城市C1到C2最短路径相同的条数,以及最短路径中最大的救援团队的数量和。

第一种方法:dijkstra(好久没写了,dijkstra都不太会拼了 ^_^)

1.在计算最短路径的相同条数时

  • 如果经过前一个结点k后,到达v点的路径长度与原来的最长长度相同,则v点的最短路径条数为 

                                                               roadNum[v] += roadNum[k];

  • 如果经过前一个结点k后,到达v点的路径长度比原来的最长长度短,则v点的最短路径条数为 

                                                               roadNum[v] = roadNum[k];

2.在计算最多救援队的时候时

  • 如果经过前一个结点k后,到达v点的路径长度与原来的最长长度相同,则v点的救援队的数量为 

                               maxTeamNum[v]=max(maxTeamNum[k]+teamNum[v],maxTeamNum[v]);

  • 如果经过前一个结点k后,到达v点的路径长度比原来的最长长度短,则v点的救援队的数量为 

                                                maxTeamNum[v]=maxTeamNum[k]+teamNum[v];

#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
#define Max 555
using namespace std;
int n,m,s,t,u,v,c;
int dis[Max],vis[Max],mapp[Max][Max];
int teamNum[Max],roadNum[Max],maxTeamNum[Max];
/*
roadNum数组是起点到终点的最短路相同的条数
当前点的最短路径相同的条数与前一个点最短路径相同的条数有关
maxTeamNum数组是起点到终点所有最短路中最大的救援团队数量和

*/
void dijkstra(){
maxTeamNum[s]=teamNum[s];
roadNum[s]=1;
memset(dis,inf,sizeof(dis));
for(int i=0;i<n;i++)
{
dis[i]=mapp[s][i];
}
dis[s]=0;
// vis[s]=1;
for(int i=0;i<n;i++)
{
int minn=inf,k=-1;
for(int j=0;j<n;j++)
{
if(!vis[j]&&dis[j]<minn)
{
minn=dis[j];
k=j;
}
}
vis[k]=1;
for(int v=0;v<n;v++){
if((dis[v]>dis[k]+mapp[k][v])&&!vis[v])
{
dis[v]=dis[k]+mapp[k][v];
roadNum[v]=roadNum[k];
maxTeamNum[v]=maxTeamNum[k]+teamNum[v];
}else if((dis[v]==dis[k]+mapp[k][v])&&!vis[v]){
roadNum[v]+=roadNum[k];
maxTeamNum[v]=max(maxTeamNum[k]+teamNum[v],maxTeamNum[v]);
}
}
}
}
void init(){

for(int i=0;i<n;i++)
{
vis[i]=0;
for(int j=0;j<n;j++)
if(i==j) mapp[i][j]=0;
else mapp[i][j]=inf;
}
}
int main(){
ios::sync_with_stdio(false);
cin>>n>>m>>s>>t;
for(int i=0;i<n;i++) cin>>teamNum[i];
init();
for(int i=0;i<m;i++)
{
cin>>u>>v>>c;
if(mapp[u][v]>c){
mapp[u][v]=mapp[v][u]=c;
}
}
dijkstra();
cout<<roadNum[t]<<" "<<maxTeamNum[t]<<endl;
return 0;
}

第二种方法:dfs (优雅的暴力,^_^)

反正这道题数据量小,可劲搜呗

#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
#define Max 555
using namespace std;
int n,m,s,t,u,v,c;
int dis[Max],vis[Max],mapp[Max][Max];
int teamNum[Max];
int minLen=inf;//最短路径的长度
int minlenNum=1;//最短路径的个数
int maxteamNum=0;//最大救援团队数
void init(){

for(int i=0;i<n;i++)
{
vis[i]=0;
for(int j=0;j<n;j++)
if(i==j) mapp[i][j]=0;
else mapp[i][j]=inf;
}
}
void dfs(int cur,int cur_len,int cur_team){
if(cur_len>minLen) return ;
if(cur==t){
if(cur_len<minLen)
{
minLen=cur_len;
minlenNum=1;
maxteamNum=cur_team;
}else if(cur_len==minLen){
minlenNum++;
if(cur_team>maxteamNum)
{
maxteamNum=cur_team;
}
}
return ;
}
vis[cur]=1;
for(int i=0;i<n;i++)
{
if(vis[i]||mapp[cur][i]==0||mapp[cur][i]==inf) continue;
dfs(i,cur_len+mapp[cur][i],cur_team+teamNum[i]);
}
vis[cur]=0;
//回溯 以便于 从其他点出发可以访问到 cur 点
}
int main(){
ios::sync_with_stdio(false);
cin>>n>>m>>s>>t;
for(int i=0;i<n;i++)
{
cin>>teamNum[i];
}
init();
for(int i=0;i<m;i++)
{
cin>>u>>v>>c;
if(mapp[u][v]>c){
mapp[u][v]=mapp[v][u]=c;
}
}
dfs(s,0,teamNum[s]);
cout<<minlenNum<<" "<<maxteamNum<<endl;
return 0;
}