A Bug's Life

Time Limit: 10000MS

 

Memory Limit: 65536K

Total Submissions: 49717

 

Accepted: 16053

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input


2 3 3 1 2 2 3 1 3 4 2 1 2 3 4


Sample Output


Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!


Hint

Huge input,scanf is recommended.

题意是:m对虫子关系,判断有没有同性在一起

r[i] 为0 代表为 同性  1 代表为异性

其实我想说,同性才是真爱,不是bug

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <vector>
#include <queue>
#define Max 2222
using namespace std;
int n, m;
int fa[Max];
int r[Max]; // 0同性,1异性
void init() {
for(int i = 1; i <= Max; i++) {
fa[i] = i;
r[i] = 0;
}
}
int Find(int x){
while(fa[x] != fa[fa[x]]){
r[x] =(r[x] + r[fa[x]]) % 2;
fa[x] = fa[fa[x]];
}
return fa[x];
}
void mix (int x, int y) {
int fx = Find(x);
int fy = Find(y);
if(fx == fy) return ;
fa[fx] = fy;
r[fx] = (r[x] + r[y] + 1) % 2;
}
int main() {
ios::sync_with_stdio(false);
int t, u, v;
cin >> t;
for(int Case = 1; Case <= t; Case++) {
cin >> n >> m;
init();
int flag = 0;
for(int i = 0; i < m; i++) {
cin >> u >> v;
if(flag) continue;
if(Find(u) == Find(v)) {
if(r[u] == r[v]) {
flag = 1;
}
}else mix(u, v);
}
cout << "Scenario #" << Case <<":"<<endl;

if(flag) {
cout << "Suspicious bugs found!" << endl << endl;
}else {
cout << "No suspicious bugs found!" << endl << endl;
}
}
return 0;
}