题目链接:​​这里写链接内容​

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.
Input

  • Lines 1…: Same input format as “Navigation Nightmare”.
    Output
  • Line 1: An integer giving the distance between the farthest pair of farms.
    Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
Sample Output

52

求树的直径,只要dfs跑两遍就能找到树的直径。
第一遍从根节点跑最长的路径,然后第二遍从这个距根节点最远的节点再跑一遍dfs就可以求出树的直径了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const int MAXN=100001;
struct node{
int to,next,w;

}edge[MAXN];
int head[MAXN];
int num;
int n,m;
typedef long long ll;
void add_edge(int u,int v,int w){
edge[++num].next=head[u];
edge[num].to=v;
edge[num].w=w;
head[u]=num;

}
int dp[MAXN];
ll ans=0;
int ed=0;
void dfs(int u,int fa,ll now)
{
if(now>ans)
{
ans=now;
ed=u;
}
for(int i=head[u];i!=-1;i=edge[i].next)
{
if(edge[i].to!=fa)
dfs(edge[i].to,u,now+edge[i].w);
}
}
int main(){

scanf("%d%d",&n,&m);
memset(head,-1,sizeof(head));
for(int i=1;i<=m;i++)
{
int u,v,w;
char ch;
scanf("%d%d%d%c",&u,&v,&w,&ch);
getchar();
add_edge(u,v,w);
add_edge(v,u,w);
}
dfs(1,0,0);
dfs(ed,0,0);
printf("%lld",ans);
return 0;
}