题目链接

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

【PAT甲级】1130 Infix Expression(25 分)(中缀表达式)_编程题目 【PAT甲级】1130 Infix Expression(25 分)(中缀表达式)_编程题目_02
Figure 1 Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

题意:给一颗二叉树,输出中缀表达式,并且加上括号表示运算的优先级
思路:首先根据所有孩子结点编号寻找1~n中没有出现过的编号标记为root,即树的根结点~然后进行从root结点开始dfs~dfs递归拼接 “(” + 左子树 + 根 + 右子树 + “)”
递归有四种情况(有效的只有三种):
1. 左右子树都空 返回 “(” + 根 + “)”
2. 左空右不空 返回 “(” + 根 + 右子树 + “)”
3. 左不空右空 这种情况不存在
4. 左右都不空 返回 “(” + 左子树 + 根 + 右子树 + “)”

代码:

#include <bits/stdc++.h>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define drep(i,n,a) for(int i=n;i>=a;i--)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const double eps = 1e-6;
const int N = 1e5+5;

struct Node {
    int left,right;
    string data;
} ;
vector<Node>tree;
string dfs(int root) {
    if(tree[root].left==-1&&tree[root].right==-1) return tree[root].data;
    if(tree[root].left==-1&&tree[root].right!=-1) return "("+tree[root].data+dfs(tree[root].right)+")";
    if(tree[root].left!=-1&&tree[root].right!=-1) return "("+dfs(tree[root].left)+tree[root].data+dfs(tree[root].right)+")";
}
int main() {
    int n,l,r;
    cin>>n;
    tree.resize(n+1);
    vector<bool>vis(n+1,false);
    for(int i=1; i<=n; i++) {
        cin>>tree[i].data>>tree[i].left>>tree[i].right;
        if(tree[i].left!=-1) vis[tree[i].left]=true;
        if(tree[i].right!=-1) vis[tree[i].right]=true;
    }
    int root=1;
    while(vis[root]==true) root++;
//    cout<<"root="<<root<<endl;
    string ans=dfs(root);
    if(ans[0]=='(') ans=ans.substr(1,ans.size()-2);
    cout<<ans<<endl;
    return 0;
}