连连看


Problem Description


“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。


 



Input


输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!


 



Output


每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。


 



Sample Input


3 4 1 2 3 4 0 0 0 0 4 3 2 1 4 1 1 3 4 1 1 2 4 1 1 3 3 2 1 2 4 3 4 0 1 4 3 0 2 4 1 0 0 0 0 2 1 1 2 4 1 3 2 3 0 0


 



Sample Output


YES NO NO NO NO YES




#include <iostream>

#include <stdio.h>


#include <queue>


#include <limits.h>


using namespace std;


int direc[4][2] = {{0,1},{0,-1},{1,0},{-1,0}};//方向依次为右、左、下、上


int a[1005][1005],visited[1005][1005],m,n;


//a为输入的2维向量,visited记录该点是否被访问过了,同时记录有转折次数,如果


//新的转折次数小于以前访问时的转折次数那么更新,否则就不更新。


typedef struct


{


    int x,y,dir,corner;//x,y,为行数列数,dir为方向,corner为转角次数。


}node;


node start,end;//记录开始和结束


void bfs()//宽度搜索


{


    queue<node> q;


    node cur,pre;   //用来记录当前的节点和前一个进行比较


    start.dir = -1;//开始时无方向


    start.corner = 0;//开始时转角次数为0


    q.push(start);


    while(!q.empty())


    {


        pre = q.front();


        q.pop();


        if(pre.x == end.x && pre.y == end.y)


        {cout<<"YES"<<endl;return;}


        for(int i = 0; i < 4; i++)//对节点的四个方向分别进行判断


        {


            cur.x = pre.x + direc[i][0];


            cur.y = pre.y + direc[i][1];


            cur.corner = pre.corner;      //令当前转角次数和前一个相同


            cur.dir = i;                  //当前方向


            //前一个不能使开始出,且当前方向和前一个方向不一致是转折次数自增1


            if(pre.dir != cur.dir&&pre.dir != -1) cur.corner++;


            //判断是否出界,转角次数是否超过限制


            if(cur.x<1||cur.y<1||cur.x>n||cur.y>m||cur.corner>2)continue;


            //如果当前位置有数字存在,且当前位置不是终结位置,违反规则


            if(a[cur.x][cur.y]&&!(cur.x==end.x&&cur.y==end.y))continue;


            if(cur.corner<visited[cur.x][cur.y])


            {


                visited[cur.x][cur.y] = cur.corner;


                q.push(cur);


            }


        }


    }


    cout<<"NO"<<endl;


}


int main()


{


    int q;


    while(scanf("%d%d",&n,&m),n,m)


    {


        for(int i = 1; i <= n; i++)


        for(int j = 1; j <= m; j++)


        scanf("%d",&a[i][j]);


        scanf("%d",&q);


        while(q--)


        {


            scanf("%d%d%d%d",&start.x,&start.y,&end.x,&end.y);


            if(start.x==end.x&&start.y==end.y)//开始和结束在同一个位置


            {cout<<"NO"<<endl;continue;}


            //开始和结束位置没有数字或者开始和结束位置的数字不等。


            if(!a[start.x][start.y]||!a[end.x][end.y]||(a[start.x][start.y]!=a[end.x][end.y]))


            {cout<<"NO"<<endl;continue;}




            for(int i = 1; i <= n; i++)


            for(int j = 1; j <= m; j++)


            visited[i][j] = INT_MAX;


            bfs();


        }


    }


    return 0;


}