Drainage Ditches

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 92457

 

Accepted: 35864

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input


5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10


Sample Output


50


#include<iostream>
#include<string.h>
#include<queue>
#include<cmath>
using namespace std;
#define INF 0x3f3f3f3f
const int MAX = 210;
struct node
{
int c;//速率
int f;//逆流量
};
int sx, ex;//sx和ex分别代表源点和汇点
int pre[MAX];//前驱
node map[MAX][MAX];
int n, m;
bool BFS()//BFS搜索层次网络
{
memset(pre, 0, sizeof(pre));
queue<int> q;
q.push(sx);
pre[sx] = 1;
while (!q.empty())
{
int start = q.front();
q.pop();
for (int i = 1; i <= n; i++)
{
if (!pre[i] && map[start][i].c - map[start][i].f)
{
pre[i] = pre[start] + 1;
q.push(i);
}
}
}
return pre[ex] != 0;

}
int dinic(int pos, int flow)//pos是顶点号,flow是当前顶点所能得到的流量
{
int f = flow;
if (pos == ex)
return flow;
for (int i = 1; i <= n; i++)
{
if (map[pos][i].c - map[pos][i].f&&pre[pos] + 1 == pre[i])
{
int use = map[pos][i].c - map[pos][i].f;//可用水量
int t = dinic(i, min(use, flow));
map[pos][i].f += t;
map[i][pos].f -= t;
flow -= t;//此顶点得到的流量减去改变量
}
}
return f - flow;

}
int slove()
{
int sum = 0;
while (BFS())
{
sum += dinic(sx, INF);
}
return sum;
}
int main()
{
int u, v, w;
while (cin >> m >> n)
{
sx = 1;
ex = n;
memset(map, 0, sizeof(map));
for (int i = 1; i <= m; i++)
{
cin >> u >> v >> w;
map[u][v].c += w;
}
cout << slove() << endl;
}
return 0;
}