2219: A^X mod P


Time Limit: 5 Sec   Memory Limit: 128 MB

Submit: 443  

Solved: 80

[

​Submit​​][

​Status​​][

​Web Board​​]


Description


It's easy for ACMer to calculate A^X mod P. Now given seven integers n, A, K, a, b, m, P, and a function f(x) which defined as following.

f(x) = K, x = 1

f(x) = (a*f(x-1) + b)%m , x > 1


Now, Your task is to calculate

( A^(f(1)) + A^(f(2)) + A^(f(3)) + ...... + A^(f(n)) ) modular P. 


Input


In the first line there is an integer T (1 < T <= 40), which indicates the number of test cases, and then T test cases follow. A test case contains seven integers n, A, K, a, b, m, P in one line.

1 <= n <= 10^6

0 <= A, K, a, b <= 10^9

1 <= m, P <= 10^9


Output


For each case, the output format is “Case #c: ans”. 

c is the case number start from 1.

ans is the answer of this problem.


Sample Input


23 2 1 1 1 100 1003 15 123 2 3 1000 107


Sample Output


Case #1: 14Case #2: 63


HINT

Source

#include<iostream>
#include<vector>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long LL;
const int maxn = 1000005;
const int N=100000;
LL f[maxn];
LL bx[N+10];
LL ax[N+10];
int main()
{
int T,kase=0;
cin>>T;
while(T--)
{
LL n,A,K,a,b,m,P;
cin>>n>>A>>K>>a>>b>>m>>P;
A%=P;
f[1]=K;
for(int i=2;i<=n;i++)
f[i]=(a*f[i-1]+b)%m;
bx[0]=1%P;
for(int i=1;i<=N;i++)
bx[i] = bx[i-1]*A%P;
LL Ax=1%P;
for(int i=1;i<=N;i++)
Ax=(Ax*A)%P;
ax[0]=1%P;
for(int i=1;i<=N;i++)
ax[i]=ax[i-1]*Ax%P;
LL ans = 0;
for(int i=1;i <=n;i++)
{
int x = f[i]/N;
int y=f[i]%N;
LL t = ax[x]*bx[y]%P;
ans = (ans+t)%P;
}
cout<<"Case #"<<++kase<<": "<<ans<<endl;
}
return 0;
}

我只能说根本看不懂,明天再看2遍吧