n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers j and i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.
n and each cij
Input
T (T <= 100), indicating the number of test cases. Then T
n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cji, cii = 0, 1 <= i, j <= n.
Output
For each test case, if you can connect the computers together, output the method in in the following fomat:
i1j1i1j1 ......
where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.
Sample Input
2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0
Sample Output
1 2 1 3 -1
水题生成树,只要排序的时候处理下,如果权值相同,按顶点大小排,输出时也要按顶点大小排。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=110;
struct node
{
int u,v;
int weight;
}edge[maxn*maxn];
struct point
{
int x,y;
}list[maxn*maxn];
int father[maxn];
void unit(int n)
{
for(int i=0;i<=n;i++)
father[i]=i;
}
int find(int x)
{
if(x!=father[x])
father[x]=find(father[x]);
return father[x];
}
void merge(int aa,int bb)
{
if(aa!=bb)
father[aa]=bb;
}
int cmp1(node a,node b)
{
if(a.weight != b.weight)
return a.weight < b.weight;
else if(a.u != b.u)
return a.u < b.u;
else
return a.v < b.v;
}
int cmp2(point a,point b)
{
if(a.x != b.x)
return a.x<b.x;
return a.y < b.y;
}
void kruskal(int n,int v)
{
unit(v);
sort(edge,edge+n,cmp1);
int m=0,cnt=0;
for(int i=0;i<n;i++)
{
int aa=find(edge[i].u);
int bb=find(edge[i].v);
if(aa!=bb && edge[i].weight)
{
merge(aa,bb);
m++;
list[cnt].x=edge[i].u;
list[cnt++].y=edge[i].v;
if(m==v-1)
break;
}
}
if(cnt!=v-1)
printf("-1\n");
else
{
sort(list,list+cnt,cmp2);
for(int i=0;i<cnt;i++)
{
printf("%d %d",list[i].x,list[i].y);
if(i<cnt-1)
printf(" ");
}
printf("\n");
}
}
int main()
{
int t,n,cnt;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
cnt=0;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
edge[cnt].u=min(i,j);
edge[cnt].v=max(i,j);
scanf("%d",&edge[cnt++].weight);
}
}
kruskal(cnt,n);
}
return 0;
}