Count the string


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5159    Accepted Submission(s): 2425



Problem Description


It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.


 



Input


The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.


 



Output


For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.


 



Sample Input


1 4 abab


 



Sample Output


6


 



Author


foreverlin@HNU


 



Source


HDOJ Monthly Contest – 2010.03.06


 



Recommend


lcy   |   We have carefully selected several similar problems for you:   1686  1358  3341  2222  3068

这道题要用到kmp next数组的本质
next[i] 其实是以i - 1结尾的串的最大公共前缀和后缀的长度 (求出每一个串的最大公共前缀和后缀的长度 ,然后整体右移一位)
而对于:  p0p1....pk-1 == pj - k + 1 .... pj - 1 ,前面的就是一段前缀 (next[j] = k)

令 dp[i] 表示以i结尾的串含有的前缀的数目
dp[i] = dp[next[i]] + 1;
注意这里要往左移位,(上面讲了)

/*************************************************************************
    > File Name: hdu3336.cpp
    > Author: ALex

    > Created Time: 2015年01月04日 星期日 17时27分46秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
/*************************************************************************
    > File Name: hdu1011.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2015年01月03日 星期六 14时41分19秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int mod = 10007;
const int N = 200010;
int next[N];
char str[N];
int dp[N];

void get_next()
{
	int len = strlen(str);
	int k = -1;
	int j = 0;
	next[0] = -1;
	while (j < len)
	{
		if (k == -1 || str[j] == str[k])
		{
			++k;
			++j;
			next[j] = k;
		}
		else
		{
			k = next[k];
		}
	}
}

int main()
{
	int t;
	int len;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &len);
		scanf("%s", str);
		get_next();
		for (int i = 1; i <= len; ++i)
		{
			dp[i] = 1;
		}
		dp[0] = 0;
		int ans = 0;
		for (int i = 1; i <= len; ++i)
		{
			dp[i] = dp[next[i]] + 1;
			dp[i] %= mod;
			ans += dp[i];
			ans %= mod;
		}
		printf("%d\n", ans);
	}
	return 0;
}