Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤105), the total number of diamonds on the chain, and M (≤108), the amount that the customer has to pay. Then the next line contains N positive numbers D1⋯DN (Di≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print ​​i-j​​​ in a line for each pair of ​​i​​​ ≤ ​​j​​​ such that D​​i​​​ + ... + D​​j​​​ = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of ​​i​​.

If there is no solution, output ​​i-j​​​ for pairs of ​​i​​​ ≤ ​​j​​​ such that D​​i​​​ + ... + D​​j​​​ >M with (D​​i​​​ + ... + D​​j​​​ −M) minimized. Again all the solutions must be printed in increasing order of ​​i​​.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

参考代码:

#include<cstdio>

const int maxn = 100010;
int sum[maxn];

int upper_bound(int left , int right , int x){//返回[L,R)内第一个大于x的位置
int mid;
while(left < right){
mid = (left + right) / 2;
if(sum[mid] > x){
right = mid;
} else{
left = mid + 1;
}
}
return left;
}

int N, M,nearM = 100000010;
int main(){
scanf("%d%d", &N, &M); //元素个数、和值
sum[0] = 0; //初始化sum[0]
for (int i = 1; i <= N; ++i) {//sum数组是一个单调递增数组,可以用二分法处理
scanf("%d", &sum[i]);
sum[i] += sum[i - 1];
}

for (int j = 1; j <= N; ++j) { //枚举左端点
//A[i]~A[j]的和值为sum[j] - sum[i-1] = M,因此sum[j]就等于 M + sum[i -1]
int k = upper_bound(j, N + 1, sum[j - 1] + M);//求右端点
if(sum[k - 1] - sum[j -1] == M){//查阅成功,找第一个大于等于M的最接近M的nearM
nearM = M; //最接近M的值,就是M
break;
}else if(k <= N && sum[k] - sum[j -1] < nearM){//存在大于M的解,并小于nearM
nearM = sum[k] - sum[j- 1]; //更新nearM(获取最接近的)
}
}

for (int l = 1; l <= N; ++l) {
int j = upper_bound(l, N + 1, sum[l -1] + nearM);//求右端点
if(sum[j -1] - sum[l - 1] == nearM){ // 查找成功
printf("%d-%d\n", l, j - 1); //输出左右端点
}
}

return 0;
}