1、重分布默认Default Seed Metric值
Protocol | Default Seed Metric |
RIP | infinity(无限) |
EIGRP | infinity(无限) |
OSPF | 20 for all except BGP,which is 1 |
BGP | BGP metric is set to IGP metric value |
重分布进RIP,重分布static、connected时Default Seed Metrics都为1。
重分布进OSPF,重分布static时只能重分布静态路由,不能重分布默认路由。
2、重分布总结
在路由器上将A路由协议重分布进B路由协议,会将路由器上所有运行A路由协议的接口(除ISIS/ODR),以及所有学习到的A路由协议路由重分布进B路由协议中。
R1配置
interface Serial0/0
ip address 12.1.1.1 255.255.255.0
interface Serial0/1
ip address 13.1.1.1 255.255.255.0
interface Serial0/2
ip address 14.1.1.1 255.255.255.0
router eigrp 90
redistribute ospf 110 metric 1500 100 255 1 1500
network 14.1.1.0 0.0.0.255
no auto-summary
router ospf 110
router-id 1.1.1.1
log-adjacency-changes
redistribute rip subnets
network 13.1.1.0 0.0.0.255 area 0
router rip
version 2
network 12.0.0.0
no auto-summary
R2配置
interface Loopback0
ip address 2.2.2.2 255.255.255.0
interface Serial0/0
ip address 12.1.1.2 255.255.255.0
router rip
version 2
network 2.0.0.0
network 12.0.0.0
no auto-summary
R3配置
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface Serial0/0
ip address 13.1.1.3 255.255.255.0
router ospf 110
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 13.1.1.0 0.0.0.255 area 0
R4配置
interface Loopback0
ip address 4.4.4.4 255.255.255.0
interface Serial0/0
ip address 14.1.1.4 255.255.255.0
router eigrp 90
network 4.4.4.0 0.0.0.255
network 14.1.1.0 0.0.0.255
no auto-summary