实验ASA防火墙IPSEC

ASA防火墙IPSEC_IP地址

实验步骤:

1.首先在R1,R2,R3配置ip地址,R1R3配置默认路由

ASA防火墙IPSEC_IP地址_02

ASA防火墙IPSEC_IP地址_03

ASA防火墙IPSEC_address_04

2.配置ASA1 ASA 2

首先ASA1初始化

ASA防火墙IPSEC_防火墙_05

然后改下名字,在配置接口名称和IP地址以及默认路由和静态路由

首先开启ISAKMP/IKE

在配置第一个阶段安全策略(优先级别为1,注意:数字越小就越大)

定义五个要素:定义加密(encryption),定义哈希验证(hash)定义身份验证( authentcation) 定义DH加密强度(group) 定义生存周期(lifetime)

crypto isakmp key abc123 address 20.1.1.2   //预共享密钥//

access-list 110 permit ip 192.168.10.0 255.255.255.0 192.168.20.0 255.255.255.0 //在配置感兴趣流量//

crypto ipsec transform-set benet esp-aes esp-sha-hmac //在配置传输集//

然后建立会话

crypto map benetmap 1 set peer 20.1.1.2 //首先定义名字和优先级,然后进行调用//

crypto map benetmap 1 set transform-set benet //在配置传输集//

crypto map benetmap 1 match address 110  //在匹配ACL//

crypto map benetmap interface outside  //最后应用端口//

ASA防火墙IPSEC_防火墙_06

 

然后ASA2初始化

ASA防火墙IPSEC_防火墙_07

然后改下名字,在配置接口名称和IP地址以及默认路由和静态路由

首先开启ISAKMP/IKE

在配置第一个阶段安全策略(优先级别为1,注意:数字越小就越大)

定义五个要素:定义加密(encryption),定义哈希验证(hash)定义身份验证( authentcation) 定义DH加密强度(group) 定义生存周期(lifetime)

 

ASA防火墙IPSEC_address_08

crypto isakmp key abc123 address 10.1.1.2   //预共享密钥//

access-list 110 permit ip 192.168.20.0 255.255.255.0 192.168.10.0 255.255.255.0 //在配置感兴趣流量//

crypto ipsec transform-set benet esp-aes esp-sha-hmac //在配置传输集//

然后建立会话

crypto map benetmap 1 set peer 10.1.1.2 //首先定义名字和优先级,然后进行调用//

crypto map benetmap 1 set transform-set benet //在配置传输集//

crypto map benetmap 1 match address 110  //在匹配ACL//

crypto map benetmap interface outside  //最后应用端口//

 

ASA防火墙IPSEC_防火墙_09

 

最后在VPC上配置ip地址然后,C1pingC2看通不通

ASA防火墙IPSEC_address_10ASA防火墙IPSEC_防火墙_11