1071. Speech Patterns (25)

时间限制


300 ms


内存限制


65536 kB


代码长度限制


16000 B


判题程序


Standard


作者


HOU, Qiming


People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can? It can!"

Sample Output:

can 5


样例看的太扭;
简单的说就是一个句子,里面的单词由大小写和数字构成,其他标点符号甚么的都不是;要求出现次数最多的那个单词;
如果有多个出现次数一样多的,那么给出字典序最少的(PS:我这里一开始没有注意字典序,但是也可以AC,测试数据有点弱)

评测结果

时间

结果

得分

题目

语言

用时(ms)

内存(kB)

用户

8月14日

16:22

答案正确

​25​

​1071​

​C++ (g++ 4.7.2)​

135

2752

​datrilla​

测试点

测试点

结果

用时(ms)

内存(kB)

得分/满分

0

答案正确

1

180

13/13

1

答案正确

1

308

2/2

2

答案正确

135

2752

4/4

3

答案正确

126

2360

4/4

4

答案正确

1

308

2/2

#include<iostream> 
#include<string>
#include<map>
#include<algorithm>
using namespace std;
int main()
{
int index,len,maxcnt;
string line;
string word,ans;
map<string, int>words;
getline(cin, line);
len = line.size();
line[len++] = '.';/*用于处理可能123 123 e 123这样结尾的少数一个的问题*/
for (index = 0,maxcnt=0,ans="\0"; index < len;index++)
{
if (isalpha(line[index])||isdigit(line[index]))
word+= !isdigit(line[index])&& isupper(line[index]) ? line[index] - 'A' + 'a' : line[index];/*判断顺序不能换*/
else if (!word.empty())
{
words[word]++;
if (words[word] > maxcnt)
{
maxcnt = words[word];
ans = word;
}
word.erase();
}
}
cout << ans << " " << maxcnt << endl;
system("pause");
return 0;
}