1022. Digital Library (30)

时间限制

1000 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:

3 1111111 The Testing Book Yue Chen test code debug sort keywords ZUCS Print 2011 3333333 Another Testing Book Yue Chen test code sort keywords ZUCS Print2 2012 2222222 The Testing Book CYLL keywords debug book ZUCS Print2 2011 6 1: The Testing Book 2: Yue Chen 3: keywords 4: ZUCS Print 5: 2011 3: blablabla

Sample Output:

1: The Testing Book 1111111 2222222 2: Yue Chen 1111111 3333333 3: keywords 1111111 2222222 3333333 4: ZUCS Print 1111111 5: 2011 1111111 2222222 3: blablabla Not Found

看了别人的代码

直接暴力搜索也是可以通过的。但为了学下map的用法就用map了

map的使用,map<键,键值> 键first,键值second ,头文件#include<map>
①键唯一,我的感觉就是键像数组的标号一样使用,但是可以自己定义(类),键默认升序,特殊的键要自己定义小于号(符号重载);
②而键值可以是单值(int,char)或者多值(数组之类int[],char[])


我这里使用的是 map<string, vector<string>>  头文件(#include<vector>) 这里vector是可变string数组,相当于多值,这些多值需要自己排序;
vector联动


getline 读取一行字符直到换行符,包括换行符  getline(输入流,string)http://baike.baidu.com/link?url=MymHhniSY1GissGno6YQj2bbVd6AHMvKfftxPgT9Yc3_WCUkcGEgfdlZVutqfwrY89nEL6KlIQRTCZfGsWQDxa

istream& getline ( istream &is , string &str , char delim );

istream& getline ( istream& , string& );

is 进行读入操作的输入流

str 存储读入的内容

delim  ​​终结符​

评测结果

时间

结果

得分

题目

语言

用时(ms)

内存(kB)

用户

7月30日

11:42

答案正确

​30​

​1022​

​C++ (g++ 4.7.2)​

115

5532

​datrilla​

测试点

测试点

结果

用时(ms)

内存(kB)

得分/满分

0

答案正确

1

188

16/16

1

答案正确

1

436

3/3

2

答案正确

1

304

3/3

3

答案正确

1

308

3/3

4

答案正确

115

5532

5/5

#include<iostream>    
#include<map>
#include<algorithm>
#include<vector>
#include<string>
using namespace std;
int main()
{
map<string, vector<string>>BOOK[5];
map<string, vector<string>>::iterator destiNation;
string id, title, author, everykeyWord, publisher, year;
int N,index,item,i,lenth;
cin >> N;
getchar();
for (index = 0; index < N; index++)
{
getline(cin,id);
getline(cin, title);
BOOK[0][title].push_back(id);
getline(cin, author);
BOOK[1][author].push_back(id);
do
{
cin >> everykeyWord;
BOOK[2][everykeyWord].push_back(id);
} while (getchar()!='\n');
getline(cin, publisher);
BOOK[3][publisher].push_back(id);
getline(cin, year);
BOOK[4][year].push_back(id);
}
for (index = 0; index < 5; index++)
for (destiNation = BOOK[index].begin(); destiNation != BOOK[index].end(); destiNation++)
sort(destiNation->second.begin(), destiNation->second.end());
cin >> N;
getchar();
for (index = 0; index < N; index++)
{
cin >> item;
getchar();
getchar();
getline(cin, id);
cout << item << ": " << id << endl;
item--;
destiNation = BOOK[item].find(id);
if (destiNation == BOOK[item].end())
cout << "Not Found" << endl;
else
{
lenth = BOOK[item][id].size();
for (i = 0; i < lenth; i++)
{
cout << BOOK[item][id][i] << endl;
}
}
}
system("pause");
return 0;
}