工作原理:
在用户被认证之后,路由器会自动关闭telnet会话,并将一个动态访问表项置于某个访问表中,以允许源地址为认证用户工作站地址的报文通过。
代码:
R1(config)#hostname PC
PC(config)#no ip routing
PC(config)#ip default-gateway 192.168.1.1
PC(config)#interface ethernet 0/0
PC(config-if)#ip address 192.168.1.2 255.255.255.0
PC(config-if)#no shutdown
PC#
R2(config)#interface ethernet 0/0
R2(config-if)#ip add 192.168.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#interface ethernet 0/0
R2(config)#interface ethernet 0/1
R2(config-if)#ip add 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#^Z
R2(config)#username chy pa
R2(config)#username chy password 0 chy
R2(config)#username admin password 0 admin
R2(config)#line vty 0 4
R2(config-line)#login local
R2(config-line)#exit
R2(config)#access-list 100 permit tcp any 192.168.1.1 0.0.0.255 eq telnet (反掩码)
R2(config)#access-list 100 dynamic chy timeout 15 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
R2(config)#username chy autocommand access-enable host time 10(手动输入)
R2(config)#interface ethernet 0/0
R2(config-if)#ip access-group 100 in
R2(config-if)#
配置好后查看ACL列表
在pc(R1)上pingR2
用chy用户telnetR2的e0/0(192.168.1.1),运行后会秒退。
再次查看ACL列表
再次pingR2
其中admin用户为管理员帐号,可实际telnet管理R2。