Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 31425Accepted: 10633

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5

1 2 20

2 3 30

3 4 20

4 5 20

1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Source

USACO 2004 November


题目大意:给你N个点,M条双向边,现在站在结点1上,问从结点1到结点N的最短路径为多少

思路:求单源最短路径,这道题边权值范围为1~100,没有负边,直接用Dijkstra来做就可以了。

不清楚是否有重边,这里我是做了处理。



<span style="font-family:Microsoft YaHei;font-size:18px;">#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN = 1010;
const int INF = 0xffffff0;

int Map[MAXN][MAXN],Dist[MAXN],vis[MAXN];

void Dijkstra(int N,int s)
{
int Min;
for(int i = 1; i <= N; ++i)
{
vis[i] = 0;
if(i != s)
Dist[i] = Map[s][i];
}
Dist[s] = 0;
vis[s] = 1;
for(int i = 1; i <= N; ++i)
{
Min = INF;
int k = -1;
for(int j = 1; j <= N; ++j)
{
if(!vis[j] && Dist[j] < Min)
{
Min = Dist[j];
k = j;
}
}
if(k == -1)
return;
vis[k] = 1;
for(int j = 1; j <= N; ++j)
{
if(!vis[j] && Map[k][j] != INF && Dist[j] > Dist[k] + Map[k][j])
Dist[j] = Dist[k] + Map[k][j];
}
}
}

int main()
{
int N,M;
while(~scanf("%d%d",&M,&N))
{
for(int i = 1; i <= N; ++i)
for(int j = 1; j <= N; ++j)
Map[i][j] = INF;
memset(Dist,INF,sizeof(Dist));
memset(vis,0,sizeof(vis));
for(int i = 0; i < M; ++i)
{
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
if(w < Map[u][v]) //处理重边
Map[u][v] = Map[v][u] = w;
}
Dijkstra(N,1);
printf("%d\n",Dist[N]);
}

return 0;
}
</span>