1.确保ESXi主机已启用ssh
2.从VMware官网获取补丁包u1 u2 u3
https://my.vmware.com/group/vmware/patch#search
使用VMware vSphere Client上传补丁包到存储上,执行df –h查看路径
VMware ESXI6.0 升级u2 u3失败问题解决,并开启web控制

VMware ESXI6.0 升级u2 u3失败问题解决,并开启web控制

升级命令:
esxcli software vib update -d=/vmfs/volumes/datastore1/update-from-esxi6.0-6.0_update01.zip

升级u1包直接成功。
升级u2错误提示
VMware ESXI6.0 升级u2 u3失败问题解决,并开启web控制

官方解决升级方法,命令一样。多检查下载的更新包有没有损坏。
查看发行说明的“安装问题”部分。许多安装问题也会影响升级过程。
新问题:尝试使用 esxcli software vib update 命令从 ESXi 6.x 升级到 6.0 Update 2 失败
尝试使用 esxcli software vib update 命令从 ESXi 6.x 升级到 6.0 Update 2 失败,并显示类似以下内容的错误消息:

"[DependencyError]
VIB VMware_bootbank_esx-base_6.0.0-2.34.xxxxxxx requires vsan << 6.0.0-2.35, but the requirement cannot be satisfied within the ImageProfile.
VIB VMware_bootbank_esx-base_6.0.0-2.34.xxxxxxx requires vsan >= 6.0.0-2.34, but the requirement cannot be satisfied within the ImageProfile."

此问题是由于引入与 esx-base VIB 相互依赖的新 Virtual SAN VIB 而导致的,esxcli software vib update 命令只能更新系统上安装的 VIB。

解决办法:要解决此问题,请按下例所示运行 esxcli software profile update:

esxcli software profile update -d /vmfs/volumes/datastore1/update-from-esxi6.0-6.0_update02.zip -p ESXi-6.0.0-20160302001-standard

并通过升级打补丁方式开通web控制功能
VMware ESXI6.0 升级u2 u3失败问题解决,并开启web控制
VMware ESXI6.0 升级u2 u3失败问题解决,并开启web控制

VMware ESXI6.0 升级u2 u3失败问题解决,并开启web控制

参考https://blog.51cto.com/1191997818/2358857
https://docs.vmware.com/cn/VMware-vSphere/6.0/rn/vsphere-esxi-60u2-release-notes.html
http://www.gabesvirtualworld.com/vib-requires-vsan-6-0-0-2-34-but-the-requirement-cannot-be-satisfied-within-the-imageprofile/