1.多lan端口路由器获取IP地址

网络拓扑图如下:

cisco路由交换中DHCP的配置方案_CCNA

路由器的配置:

router>enable

router#conf t

router(config)#interface fastethernet 0/0

router(config-if)#ip address 192.168.0.1 255.255.255.0

router(config-if)#no shutdown

router(config-if)#exit

router(config)#interface fastethernet 1/0

router(config-if)#ip address 172.16.1.1 255.255.255.0

router(config-if)#no shutdown

router(config-if)#exit

router(config)#ip dhcp pool 192    /地址池名为192

router(dhcp-config)#network 192.168.0.0 255.255.255.0  /分配的ip地址段

router(dhcp-config)#default-router 192.168.0.1        /分配的默认路由

router(dhcp-config)#dns-server 192.168.0.1           /分配的DNS地址

router(dhcp-config)#exit

router(config)#ip dhcp excluded-address 192.168.0.1 192.168.0.5 /排除分配的ip地址


router(config)#ip dhcp pool 172       /地址池名为172

router(dhcp-config)#network 172.16.1.0 255.255.255.0    /分配的ip地址段

router(dhcp-config)#default-router 172.16.1.1          /分配的默认路由

router(dhcp-config)#dns-server 172.16.1.1              /分配的DNS地址

router(dhcp-config)#exit

router(config)#ip dhcp excluded-address 172.16.1.1 172.16.1.5  /排除分配的ip地址


客户机开启自动获取ip地址后就可以自动获取ip地址了


2.单个LAN口为不通vlan的主机分配IP地址(单臂路由)

即把一个LAN划分为多个LAN端口,这样就容易理解了

网络拓扑图如下:

cisco路由交换中DHCP的配置方案_CCNA_02

路由器配置;(命令就简写吧)

router>enable

router#conf t

router(config)#int fa 0/0

router(config-if)#no ip address

router(config-if)#no shut

router(config-if)#int fa 0/0.1

router(config-subif)#encapsulation dot1q 1

router(config-subif)#ip address 192.168.0.1 255.255.255.0

router(config-subif)#int fa 0/0.2

router(config-subif)#encapsulation dot1q 2

router(config-subif)#ip address 172.16.1.1 255.255.255.0

router(config-subif)#int fa 0/0.3

router(config-subif)#encapsulation dot1q 3

router(config-subif)#ip address 10.10.10.1 255.255.255.0

router(config-subif)#exit

router(config)#ip dhcp pool 192    /地址池名为192

router(dhcp-config)#network 192.168.0.0 255.255.255.0  /分配的ip地址段

router(dhcp-config)#default-router 192.168.0.1        /分配的默认路由

router(dhcp-config)#dns-server 192.168.0.1           /分配的DNS地址

router(dhcp-config)#exit

router(config)#ip dhcp excluded-address 192.168.0.1 192.168.0.5 /排除分配的ip地址


router(config)#ip dhcp pool 172       /地址池名为172

router(dhcp-config)#network 122.16.1.0 255.255.255.0    /分配的ip地址段

router(dhcp-config)#default-router 172.16.1.1          /分配的默认路由

router(dhcp-config)#dns-server 172.16.1.1              /分配的DNS地址

router(dhcp-config)#exit

router(config)#ip dhcp excluded-address 172.16.1.1 172.16.1.5  /排除分配的ip地址


router(config)#ip dhcp pool 10       /地址池名为10

router(dhcp-config)#network 10.10.10.0 255.255.255.0    /分配的ip地址段

router(dhcp-config)#default-router 10.10.10.1          /分配的默认路由

router(dhcp-config)#dns-server 10.10.10.1              /分配的DNS地址

router(dhcp-config)#exit

router(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.5  /排除分配的ip地址


交换机的划分为三个vlan,即vlan1,vlan2,vlan3,与路由器相连的端口设置为TRUNK后,不同vlan中的主机既可以获取相应的ip地址并进行通信了。


3.主机跨路由从DHCP服务端获取ip地址(dhcp中继)

网络拓扑图如下:

cisco路由交换中DHCP的配置方案_CCNA_03

路由器配置:

router>enable

router#conf t

router(config)#int fa 0/0

router(config-if)#no ip address

router(config-if)#no shut

router(config-if)#int fa 0/0.1

router(config-subif)#encapsulation dot1q 1

router(config-subif)#ip address 192.168.0.1 255.255.255.0

router(config-subif)#ip helper-address 10.10.10.1

router(config-subif)#int fa 0/0.2

router(config-subif)#encapsulation dot1q 2

router(config-subif)#ip address 172.16.1.1 255.255.255.0

router(config-subif)#ip helper-address 10.10.10.1


交换机划分为两个vlan,vlan1和vlan2,其他配置略...


4.三层交换机提供DHCP服务

网络拓扑图如下:

cisco路由交换中DHCP的配置方案_CCNA_04

三层交换机的配置:

switch>enable

switch#conf t

switch(config)#vlan 2

switch(config-vlan)#exit

switch(config)#vlan 3

switch(config-vlan)#exit

switch(config)#int vlan 1

switch(config-if)#ip add 192.168.0.1 255.255.255.0

switch(config-if)#no shut

switch(config)#exit


switch(config)#int vlan 2

switch(config-if)#ip add 172.16.1.1 255.255.255.0

switch(config-if)#no shut

switch(config)#exit


switch(config)#int vlan 3

switch(config-if)#ip add 10.10.10.1255.255.255.0

switch(config-if)#no shut

switch(config)#exit


switch(config)#ip dhcp pool 192    /地址池名为192

switch(dhcp-config)#network 192.168.0.0 255.255.255.0  /分配的ip地址段

switch(dhcp-config)#default-router 192.168.0.1        /分配的默认路由

switch(dhcp-config)#dns-server 192.168.0.1           /分配的DNS地址

switch(dhcp-config)#exit

switch(config)#ip dhcp excluded-address 192.168.0.1 192.168.0.5 /排除分配的ip地址


switch(config)#ip dhcp pool 172       /地址池名为172

switch(dhcp-config)#network 122.16.1.0 255.255.255.0    /分配的ip地址段

switch(dhcp-config)#default-router 172.16.1.1          /分配的默认路由

switch(dhcp-config)#dns-server 172.16.1.1              /分配的DNS地址

switch(dhcp-config)#exit

swithc(config)#ip dhcp excluded-address 172.16.1.1 172.16.1.5  /排除分配的ip地址


switch(config)#ip dhcp pool 10       /地址池名为10

switch(dhcp-config)#network 10.10.10.0 255.255.255.0    /分配的ip地址段

switch(dhcp-config)#default-router 10.10.10.1          /分配的默认路由

switch(dhcp-config)#dns-server 10.10.10.1              /分配的DNS地址

switch(dhcp-config)#exit


二层交换机与三层连接要把相应的端口设置为TRUNK,这样是在vlan1-vlan3中的客户端都可以自动获取ip地址了