一、搭建如下拓扑图
动态路由协议BGP反射器的配置
二、设计思路:三个路由器配置属于AS100
AR1与AR3,AR2与AR3通过loopbck口建立BGP内部邻居
在AR3上配置反射器服务器,配置AR1和AR2为AR3的客户端
三、配置步骤:
1、配置各位路由器的IP,因为建立BGP邻居的条件是邻居之间要能互通,所以每个AS内部运行动态协议OSPF
配置命令如下:
AR1:<Huawei>system //进入系统视图
[Huawei]sysname R1 //将路由器命名为R1
[R1]interface GigabitEthernet0/0/0 //进入路由器接口GigabitEthernet0/0/0
[R1-GigabitEthernet0/0/0]undo shutdown //开启端口
[R1-GigabitEthernet0/0/0]ip address 192.168.13.1 24 //在该端口配置IP地址
AR2:<Huawei>system //进入系统视图
[Huawei]sysname R2 //将路由器命名为R2
[R1]interface GigabitEthernet0/0/0 //进入路由器接口GigabitEthernet0/0/0
[R1-GigabitEthernet0/0/0]undo shutdown //开启端口
[R1-GigabitEthernet0/0/0]ip address 192.168.23.1 24 //在该端口配置IP地址
AR3:<Huawei>system-view //进入系统视图
[Huawei]sysname R3 //将路由器命名为R3
[R3]interface GigabitEthernet 0/0/1 //进入路由器接口GigabitEthernet 0/0/1 [R3-GigabitEthernet0/0/1]undo shutdown //开启端口
[R3-GigabitEthernet0/0/1]ip address 192.168.13.2 24 //给接口配置IP地址
[R3-GigabitEthernet0/0/1]interface GigabitEthernet 0/0/0 //进入路由器接口GigabitEthernet 0/0 [R3-GigabitEthernet0/0/0]undo shutdown //开启端口
[R3-GigabitEthernet0/0/0]ip address 192.168.23.2 24 //给接口配置IP地址
在AR1、AR2、AR3上运行OSPF
AR1: [R1]ospf 1 //启用进程ospf 1
[R1-ospf-1]area 0 //建立区域area 0 [R1-ospf-1-area-0.0.0.0]network 192.168.12.1 0.0.0.0 //在area 0宣告路由器的网络
AR2: [R2]ospf 1 //启用进程ospf 1
[R2-ospf-1]area 0 //建立区域area 0 [R2-ospf-1-area-0.0.0.0]network 192.168.23.1 0.0.0.0 //在area 0宣告
AR3:[R3]ospf 1 //启用进程ospf 1
[R3-ospf-1]area 0 //建立区域area 0 [R3-ospf-1-area-0.0.0.0]network 192.168.13.1 0.0.0.0 //在area 0宣告
[R3-ospf-1-area-0.0.0.0]network 192.168.23.1 0.0.0.0 //在area 0宣告
测试AR1、AR2、AR3是否能够互通
动态路由协议BGP反射器的配置
2、在每个路由器上建立loopback口,并配置IP地址,配置命令如下:
AR1:[R1]interface LoopBack 0
[R1-LoopBack0]ip address 192.168.11.1 24
AR2:[R2]interface LoopBack 0
[R2-LoopBack0]ip address 192.168.22.1 24
AR3:[R3]interface LoopBack 0
[R3-LoopBack0]ip address 192.168.33.1 24
3、在每个BGP内部邻居建立邻居关系,用物理接口建立邻居
AR1:[R1]bgp 100 //启用BGP并指定AS号为100
[R1-bgp]peer 192.168.13.2 as-number 100 //与属于AS100的192.168.13.2建立邻居关系
AR2:[R1]bgp 100 //启用BGP并指定AS号为100
[R1-bgp]peer 192.168.23.2 as-number 100 //与属于AS100的192.168.23.2建立邻居关系
AR2:[R1]bgp 100 //启用BGP并指定AS号为100
[R1-bgp]peer 192.168.13.1 as-number 100 //与属于AS100的192.168.13.1建立邻居关系
[R1-bgp]peer 192.168.23.1 as-number 100 //与属于AS100的192.168.23.1建立邻居关系
验证查看BGP邻居关系
动态路由协议BGP反射器的配置
4、将AR1、AR2、AR3的回环口IP宣告到BGP,命令如下:
AR1:[R1-bgp]network 192.168.11.1 255.255.255.0
AR2:[R2-bgp]network 192.168.22.1 255.255.255.0
AR3:[R3-bgp]network 192.168.33.1 255.255.255.0
5、查看每个路由器的BGP路由和路由表,并用互相ping邻居的回环端口
动态路由协议BGP反射器的配置动态路由协议BGP反射器的配置动态路由协议BGP反射器的配置
由上图可知,每个路由器上的BGP路由表的路由都是最佳路由,但是AR1、AR2没有对方的回环口路由,因为在IBGP内部邻居之间传递路由时,BGP启用水平分割防止路由环路,即路由器在接收到邻居传输的路由,不会再传输给属于同一AS的邻居。
6、我们在AR3上配置路由反射器,命令如下:
[R3-bgp]peer 192.168.13.1 reflect-client //配置路由反射器并设置邻居192.168.13.1为客户端
[R3-bgp]peer 192.168.23.1 reflect-client //配置路由反射器并设置邻居192.168.23.1为客户端
测试查看每个路由器的BGP路由表以及路由表,并互相ping回环口
动态路由协议BGP反射器的配置动态路由协议BGP反射器的配置动态路由协议BGP反射器的配置

综上,在IBGP邻居之间传输路由,BGP启动水平分割防止路由环路发生,即使在BGP路由表中的路由是最佳路由,也不会传输给同一AS号的邻居,采用路由反射器技术,将邻居配置成客户端,这样在配置条件反射器的路由器,会关闭水平分割机制,使该路由可以将同一AS邻居传输的路由,传输给另一个同AS邻居。