一、搭建如下拓扑图
思科模拟器实现HSRP以及NAT的端口复用综合运用
二、配置内网
1、先将在swichi2创建vlan10、vlan20并将连接PC机的接口设为access
连接交换机的接口设为trunk,注意:三层交换机设置trunk口的时候,先要定义封装协议dot1q ,命令如下:
swichi2:Switch(config)#vlan 10 //创建vlan10
Switch(config-vlan)#vlan 20 //创建vlan20
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#interface fastEthernet 0/3
Switch(config-if)#switchport trunk encapsulation dot1q //定义接口封装协议(三层交换机创建trunk必须定义封装协议)
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
Switch(config)#interface fastEthernet 0/4
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
2、在swichi1上创建vlan10、vlan20,并将交换机与交换机的接口设为trunk,为vlan10、vlan20配置ip地址,并配置HSRP,设置switchi1为vlan10的主网关,vlan20的备份网关命令如下:
swichi1: Switch(config)#vlan 10
Switch(config-vlan)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#interface vlan 10
Switch(config-if)#ip address 192.168.10.254 255.255.255.0
Switch(config-if)#standby 10 ip 192.168.10.250 //配置虚拟网关
Switch(config-if)#standby 10 preempt //开启抢占功能
Switch(config-if)#standby 10 priority 105 //设置虚拟网关的优先级
Switch(config-if)#standby 10 track fastEthernet 0/2 //跟踪接口技术,当接口断开,自动降低优先级
Switch(config-if)#interface vlan 20
Switch(config-if)#ip address 192.168.20.254 255.255.255.0
Switch(config-if)#standby 20 ip 192.168.20.250
3、在swichi0上创建vlan10、vlan20,并将交换机与交换机的接口设为trunk,为vlan10、vlan20配置ip地址,并配置HSRP,设置switchi1为vlan20的主网关,vlan10的备份网关命令如下:
swichi0: Switch(config)#vlan 10
Switch(config-vlan)#vlan 10
Switch(config-vlan)#vlan 20
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#interface vlan 20
Switch(config-if)#ip address 192.168.20.253 255.255.255.0
Switch(config-if)#standby 20 ip 192.168.20.250
Switch(config-if)#standby 20 preempt
Switch(config-if)#standby 20 priority 105
Switch(config-if)#standby 20 track fastEthernet 0/2
Switch(config-if)#interface vlan 10
Switch(config-if)#ip address 192.168.10.253 255.255.255.0
Switch(config-if)#standby 10 ip 192.168.10.250
4、测试各PC机能否ping通自己的网关
思科模拟器实现HSRP以及NAT的端口复用综合运用
思科模拟器实现HSRP以及NAT的端口复用综合运用

三、配置外网
swichi3: Switch(config)#interface fastEthernet 0/2
Switch(config-if)#no shutdown
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.100.1 255.255.255.0
swichi1:Switch(config)#interface fastEthernet 0/2
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.200.1 255.255.255.0
router0:Router(config)#interface gigabitEthernet 0/0
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.100.2 255.255.255.0
Router(config-if)#interface gigabitEthernet 0/1
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.200.2 255.255.255.0
Router(config-if)#interface gigabitEthernet 0/2
Router(config-if)#no shutdown
Router(config-if)#ip address 192.168.88.254 255.255.255.0
四、配置NAT端口复用
swichi0: Switch(config)#interface vlan 10
Switch(config-if)#ip nat inside //配置该接口为内网
Switch(config-if)#interface vlan 20
Switch(config-if)#ip nat inside //配置该接口为内网
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#ip nat outside //配置该接口为外网
Switch(config)#access-list 10 permit 192.168.10.0 0.0.0.255 //配置ACL
Switch(config)#access-list 20 permit 192.168.20.0 0.0.0.255 //配置ACL
Switch(config)#ip nat inside source list 20 interface fastEthernet 0/2 overload //配置NAT端口复用
Switch(config)#ip nat inside source list 10 interface fastEthernet 0/2 overload //配置端口复用
swichi1:Switch(config)#interface vlan 10
Switch(config-if)#ip nat inside
Switch(config-if)#interface vlan 20
Switch(config-if)#ip nat inside
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#ip nat outside
Switch(config)#access-list 10 permit 192.168.10.0 0.0.0.255
Switch(config)#access-list 20 permit 192.168.20.0 0.0.0.255
Switch(config)#ip nat inside source list 20 interface fastEthernet 0/2 overload
Switch(config)#ip nat inside source list 10 interface fastEthernet 0/2 overload
五、配置交换机与路由器之间的ip,并配置默认路由
swichi0:Switch(config)#interface fastEthernet 0/2
Switch(config-if)#no shutdown
Switch(config-if)#no switchport //三层交换机物理接口配置IP地址之前,必须先关闭二层功能
Switch(config-if)#ip address 192.168.100.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.100.2
Switch(config)#ip routing //开启交换机路由功能
swichi1:Switch(config)#interface fastEthernet 0/2
Switch(config-if)#no shutdown
Switch(config-if)#no switchport
Switch(config-if)#ip address 192.168.200.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.200.2
Switch(config)#ip routing
六、测试1:查看两个交换机上的standy,然后测试两PC机能否ping通外网PC
思科模拟器实现HSRP以及NAT的端口复用综合运用思科模拟器实现HSRP以及NAT的端口复用综合运用
思科模拟器实现HSRP以及NAT的端口复用综合运用
思科模拟器实现HSRP以及NAT的端口复用综合运用
测试2:断开一跟交换机与路由器的连线,查看两个交换机上的standy,然后测试两PC机能否ping通外网PC
思科模拟器实现HSRP以及NAT的端口复用综合运用
思科模拟器实现HSRP以及NAT的端口复用综合运用
思科模拟器实现HSRP以及NAT的端口复用综合运用
思科模拟器实现HSRP以及NAT的端口复用综合运用

综上:测试完成。以上配置实现网关的备份,同时可以经过NAT可以访问外网