网络拓扑图:
思科三层交换机配置
思路:添加设备之后,先将PC机对应的IP和子网掩码配置好,然后Switch 1下面只连接了两个VLAN,所以只需要设置vlan 2和vlan 3,同样的Switch 2也只需要配置vlan 3和vlan 4。所有的vlan都不在一个网段,所以要实现互通需要通过路由器,这里的Switch 3扮演的其实就是个路由器的角色,不同网段互通,每个网段都需要有一个网关,所以Switch 3上需要包含所有的VLAN,并为每一个VLAN设置IP地址。另外Switch 1和Switch 2上的Fa 0/3端口需要设置为trunk模式。否则两个vlan的数据找不到发出端口。

1)先添加所需的设备并连线。如图:
思科三层交换机配置
2)配置PC机的ip、子网掩码、网关,并标识出对应的vlan、ip、网关。如图:
思科三层交换机配置
3)为了方便,将交换机按1,2,3编号如图:
思科三层交换机配置
4)进入交换机Switch 1进行vlan配置,命令如下:
enable //进入特权模式
configure terminal //进入全局配置模式
vlan 2 //创建vlan 2
vlan 3 //创建vlan 3
interface fastEthernet 0/1 //进入端口 Fa 0/1
no shutdown //开启端口
switchport mode access //配置端口为access端口
switchport access vlan 2 //将端口添加到vlan 2中
interface fastEthernet 0/2 //进入端口 Fa 0/2
no shutdown //开启端口
switchport mode access //配置端口为access端口
switchport access vlan 3 //将端口添加到vlan 3中
interface fastEthernet 0/3 //进入端口 Fa 0/3
no shutdown //开启端口
switchport mode trunk //配置端口为trunk端口
输入以上命令后,标识出每个端口的类型,如图
思科三层交换机配置

5)按照步骤4的方法配置Switch 2上的vlan 3和vlan 4以及trunk端口,标识端口类型如下图:
思科三层交换机配置
6)进入Switch 3配置vlan以及vlan的ip地址,命令如下:
enable //进入特权模式
configure terminal //进入全局配置模式
ip routing //启动交换机的路由功能
vlan 2 //创建vlan 2
vlan 3 //创建vlan 3
vlan 4 //创建vlan 4
vlan 5 //创建vlan 5
然后在全局配置模式下,为vlan配置ip地址,配置IP命令如下:
interface vlan 2 //进入vlan 2
ip address 192.168.1.254 255.255.255.0 //配置vlan 2的ip地址
no shutdown //开启虚拟端口
按照以上命令依次配置vlan 3,vlan 4,vlan 5的ip地址
6)验证:PC0 与PC1互相能否ping通
PC0 与PC2互相能否ping通
思科三层交换机配置思科三层交换机配置思科三层交换机配置思科三层交换机配置
以上结果证明:不同的VLAN通过三层交换机可以实现互通。