一、首先看一下要构建的拓扑图
思科拓扑----小型网络架构练习


二、实验目的
1、实现pc0、pc1、pc2、pc3以及服务器server-PT的相互ping通。
2、在二层交换机中使用vlan划分vlan10、vlan20、vlan30、vlan40,四个虚拟以太网。
3、实现二层交换机不同vlan间的互通。
4、实现三层交换机vlan的路由功能。
5、实现配置路由器的路由功能。
6、了解二层交换机和三层交换机的区别。
7、了解三层交换机VLAN接口的作用。


三、所需要使用的知识点
1、vlan是什么?
VLAN,是英文Virtual Local Area Network的缩写,中文名为虚拟局域网,
VLAN是一种将局域网(LAN)设备从逻辑上划分(注意,不是从物理上划分)
成一个个网段(或者说是更小的局域网LAN),从而实现虚拟工作组(单元)的
数据交换技术。

2、vlan的优点
(1)端口的分隔。即便在同一个交换机上,处于不同VLAN的端口也是不能通信的。这样一个物理的交换机可以当 作多个逻辑的交换机使用。
(2)网络的安全。不同VLAN不能直接通信,杜绝了广播信息的不安全性。
(3)灵活的管理。更改用户所属的网络不必换端口和连线,只更改软件配置就可以了。

3、交换机之间的多vlan通信
使用到的是交换机的多端口模式,总共分三种:分别是access模式(接入)、trunk模式(中继)、multi模式(在一个线路中承载多个vlan,但不像trunk,它不对承载的数据打标签。主要用于接入支持多vlan的服务器或者一些网络分析设备。现在基本不使用此类接口,在cisco的网络设备中,也基本不支持此类接口了。)华为设备上还有个hybrid(混合端口,通过标签来标识)

4、三层交换机可以实现vlan的路由功能

5、什么是路由器?
所谓路由就是指通过相互连接的网络把信息从源地点移动到目标地点的活动。一般来说,在路由过程中,信息至少会经过一个或多个中间节点


四、所使用设备和线路
4台pc机、一台服务器、4台二层交换机、一台三层交换机、一台路由器、5根直通线、8根交叉线。
1、pc机配置要求:

设备 ip地址/子网掩码 网关 所属vlan
pc0 192.168.1.1/24 192.168.1.254 vlan10
pc1 192.168.2.1/24 192.168.2.254 vlan20
pc2 192.168.3.1/24 192.168.3.254 vlan30
pc3 192.168.4.1/24 192.168.4.254 vlan40
server-PT 192.168.6.1/24 192.168.6.254

2、路由器配置

设备 网关ip/子网掩码 所用端口
R1 192.168.6.254/24 Gig0/0
R1 192.168.5.2/24 Gig0/1

3、三层交换机vlan的网关设置和接口的ip设置

所属vlan 网关ip/子网掩码
vlan10 192.168.1.254/24
vlan20 192.168.2.254/24
vlan30 192.168.3.254/24
vlan40 192.168.4.254/24
接口 ip/子网掩码
Gig0/1 192.168.5.1/24

4、二层四台交换机配置

设备 接口模式划分
SW1 fa0/1 acc vlan10; fa0/2 acc vlan20; fa0/3-5 trunk
SW2 fa0/1 acc vlan30; fa0/2 acc vlan40; fa0/3-5 trunk
SW3 fa0/3 fa0/5 fa0/2 trunk
SW4 fa0/3 fa0/5 fa0/1 trunk

五、详细步骤

1、SW1配置:
a、设置vlan10,20,30,40(因为存在4个vlan因此所有交换都需要有相应的vlan)
b、进入接口fa0/1和fa0/2 添加vlan10和20
c、设置fa0/3-5接口为 trunk模式


Switch>enable   //进入配置模式
Switch#config terminal //进入全局配置模式

Switch(config)#vlan 10 //添加vlan10
Switch(config-vlan)#exit  //退出
Switch(config)#vlan 20  //添加vlan20
Switch(config-vlan)#exit //退出
Switch(config)#vlan 30  //添加vlan30
Switch(config-vlan)#exit //退出
Switch(config)#vlan 40  //添加vlan40
Switch(config-vlan)#exit //退出

Switch(config)#interface fastethernet 0/1 //进入接口fa0/1
Switch(config-if)#switchport mode access //设置接口模式为接入模式
Switch(config-if)#switchport access vlan 10 //把vlan10划分过去
Switch(config-if)#exit  //退出

Switch(config)#interface fastethernet 0/2 //进入接口fa0/2
Switch(config-if)#switchport mode access //设置接口模式为接入模式
Switch(config-if)#switchport access vlan 20 //把vlan20划分过去
Switch(config-if)#exit  //退出

Switch(config)#interface range fastEthernet 0/3-5 //进入接口fa0/3-5
Switch(config-if-range)#switchport mode trunk //设置接口模式为中继模式
Switch(config-if-range)#exit //退出

2、SW2配置:
a、设置vlan10,20,30,40(因为存在4个vlan因此所有交换都需要有相应的vlan)
b、进入接口fa0/1和fa0/2 添加vlan30和40
c、设置fa0/3-5接口为 trunk模式

Switch>enable   //进入配置模式
Switch#config terminal //进入全局配置模式

Switch(config)#vlan 10 //添加vlan10
Switch(config-vlan)#exit  //退出
Switch(config)#vlan 20  //添加vlan20
Switch(config-vlan)#exit //退出
Switch(config)#vlan 30  //添加vlan30
Switch(config-vlan)#exit //退出
Switch(config)#vlan 40  //添加vlan40
Switch(config-vlan)#exit //退出

Switch(config)#interface fastethernet 0/1 //进入接口fa0/1
Switch(config-if)#switchport mode access //设置接口模式为接入模式
Switch(config-if)#switchport access vlan 30 //把vlan30划分过去
Switch(config-if)#exit  //退出

Switch(config)#interface fastethernet 0/2 //进入接口fa0/2
Switch(config-if)#switchport mode access //设置接口模式为接入模式
Switch(config-if)#switchport access vlan 40 //把vlan40划分过去
Switch(config-if)#exit  //退出

Switch(config)#interface range fastEthernet 0/3-5 //进入接口fa0/3-5
Switch(config-if-range)#switchport mode trunk //设置接口模式为中继模式
Switch(config-if-range)#exit //退出

3、SW3配置:
a、设置vlan10,20,30,40(因为存在4个vlan因此所有交换都需要有相应的vlan)
b、设置 fa0/3 fa0/5 fa0/2接口为 trunk模式

Switch>enable   //进入配置模式
Switch#config terminal //进入全局配置模式

Switch(config)#vlan 10 //添加vlan10
Switch(config-vlan)#exit  //退出
Switch(config)#vlan 20  //添加vlan20
Switch(config-vlan)#exit //退出
Switch(config)#vlan 30  //添加vlan30
Switch(config-vlan)#exit //退出
Switch(config)#vlan 40  //添加vlan40
Switch(config-vlan)#exit //退出

Switch(config)#interface range fastEthernet 0/3, fastEthernet0/5, fastEthernet0/2 //进入接口fa0/2 fa0/3 fa0/5
Switch(config-if-range)#switchport mode trunk //设置接口模式为中继模式
Switch(config-if-range)#exit //退出

4、SW4配置:
a、设置vlan10,20,30,40(因为存在4个vlan因此所有交换都需要有相应的vlan)
b、设置fa0/3 fa0/5 fa0/1接口为 trunk模式

Switch>enable   //进入配置模式
Switch#config terminal //进入全局配置模式

Switch(config)#vlan 10 //添加vlan10
Switch(config-vlan)#exit  //退出
Switch(config)#vlan 20  //添加vlan20
Switch(config-vlan)#exit //退出
Switch(config)#vlan 30  //添加vlan30
Switch(config-vlan)#exit //退出
Switch(config)#vlan 40  //添加vlan40
Switch(config-vlan)#exit //退出

Switch(config)#interface range fastEthernet 0/3, fastEthernet0/5, fastEthernet0/1 //进入接口fa0/3 fa0/5 fa0/1
Switch(config-if-range)#switchport mode trunk //设置接口模式为中继模式
Switch(config-if-range)#exit //退出

5、SWP配置:
a、开启三层路由器的路由功能,华为默认是开启的,思科需要手动开启
b、设置vlan10,20,30,40(因为存在4个vlan因此所有交换都需要有相应的vlan)
c、进入vlan设置四个vlan的ip路由地址
d、取消Gig0/1端口的二层交换机功能,为端口设置路由ip。
e、设置静态路由


Switch>enable  //进入配置模式
Switch#configure  terminal  //进入全局配置模式

Switch(config)#ip routing //开启三层交换机路由功能

Switch(config)#vlan 10 //添加vlan10
Switch(config-vlan)#exit  //退出
Switch(config)#vlan 20  //添加vlan20
Switch(config-vlan)#exit //退出
Switch(config)#vlan 30  //添加vlan30
Switch(config-vlan)#exit //退出
Switch(config)#vlan 40  //添加vlan40
Switch(config-vlan)#exit //退出

Switch(config)#interface  vlan 10 //进入vlan10
Switch(config-if)#ip address 192.168.1.254  255.255.255.0 //设置vlan10的路由ip
Switch(config-vlan)#exit //退出
Switch(config)#interface  vlan 20 //进入vlan20
Switch(config-if)#ip address 192.168.2.254  255.255.255.0 //设置vlan20的路由ip
Switch(config-vlan)#exit //退出
Switch(config)#interface  vlan 30 //进入vlan30
Switch(config-if)#ip address 192.168.3.254  255.255.255.0 //设置vlan30的路由ip
Switch(config-vlan)#exit //退出
Switch(config)#interface  vlan 40 //进入vlan40
Switch(config-if)#ip address 192.168.4.254  255.255.255.0 //设置vlan40的路由ip
Switch(config-vlan)#exit //退出

Switch(config)#interface gigabitEthernet 0/1 //进入Gig 0/1端口
Switch(config-if)#no switchport //关闭二层功能
Switch(config-if)#ip address 192.168.5.1 255.255.255.0 //设置端口网段ip
Switch(config-vlan)#exit //退出

Switch(config)#ip route 192.168.6.0 255.255.255.0 192.168.5.2 //设置静态路由

6、路由器R1配置:
a、配置端口Gig0/0和Gig0/1 网关ip,并开启端口(思科路由器端口默认是关闭的)
b、设置静态路由(这里可以设置默认路由 0.0.0.0 0.0.0.0 )

Switch>enable  //进入配置模式
Switch#configure  terminal  //进入全局配置模式

Switch(config)#interface gigabitEthernet 0/1 //进入Gig 0/1端口
Router(config-if)#no shutdown //开启端口
Router(config-if)#ip address 192.168.5.2 255.255.255.0 //设置端口网段ip
Switch(config-vlan)#exit //退出

Switch(config)#interface gigabitEthernet 0/0 //进入Gig 0/0端口
Router(config-if)#no shutdown //开启端口
Router(config-if)#ip address 192.168.6.254  255.255.255.0 //设置端口网段ip
Switch(config-vlan)#exit //退出

Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.5.1 //设置静态路由

六、实验结果
SW1配置结果
思科拓扑----小型网络架构练习
思科拓扑----小型网络架构练习
SW2配置结果
思科拓扑----小型网络架构练习
思科拓扑----小型网络架构练习
SW3配置结果
思科拓扑----小型网络架构练习
思科拓扑----小型网络架构练习
SW4配置结果
思科拓扑----小型网络架构练习
思科拓扑----小型网络架构练习
SWP配置结果
思科拓扑----小型网络架构练习
Switch#show running-config //查看所有配置

思科拓扑----小型网络架构练习
R1配置结果
Switch#show running-config //查看所有配置

思科拓扑----小型网络架构练习
pc台式机ping通结果
思科拓扑----小型网络架构练习