背景

目前处于FastAPI学习初期,使用环境是:

  • Win7 64 bits SP1
  • PyCharm 2016.3
  • Python 3.8.4
  • FastAPI 0.60.1

问题截图

Python version 3.5 does not support variable...

错误提示

如图所示,错误是“Python version 3.5 does not support variable annotations"。

...

目前有关此错误的解答国内网站上几乎没有。国外仅发现——没有***+GOOGLE,stackoverflow上个别提到,不符合我的情况。

我的情况是,前不久刚安装了系统WINDOWS 7 SP1 64bits+Python 3.8.4+PyCharm 2016.3。系统中根本没有Python 3.5相关内容。

但是,上面这种介绍FastAPI的代码,在国外网站上经常见到,但都没有提到类似于我的错误。

我的PyCharm设置1如下图:

Python version 3.5 does not support variable...

在”Default settings“下,也作了上面设置。
但是,都无济于事!

目前,此案件正在调查中......

答案来了

问题在于PyCharm版本太低了。无奈下,我启动了VPN技术,使用GOOGLE最终从JetBrains官网上找到如下图所示提示:

Python version 3.5 does not support variable...

无奈下,我果断地卸载了原来的PyCharm 2016.1,从网络上找了一个最新的PyCharm 2020.1,然后安装了最新的FastAPI,一试,果然一切顺利!

费话少说,下图为证:

Python version 3.5 does not support variable...