帧中继基本配置:


Target:

   帧中继基本配置


实验设备:

路由器(带串口) 2台

V.35线缆(DTE/DCE) 1对


实验原理:

帧中继的标准可以为帧中继网络中可配置和管理的永久虚电路(PVC)进行编址,帧中继永久虚电路由数据链路连接标识符(DLCI)来标识。

当帧中继为多个逻辑数据会话提供多路复用时,ISP的交换设备首先要建立一个表,该表用来将不同的DLCI值映射到出站端口,其次,当接收到一个数据帧时,交换设备分析其连接标识符,并将该数据帧发送到相应的端口。最后,在第一个数据帧发送之前,将建立一条通往目的地的完全路径。


实验拓扑图:

Step:

   

步骤1 路由器基本配置。

Router A(config)#interface serial 4/0

Router A(config-if)#ip address 1.1.1.1 255.255.255.0

Router A(config-if)#exit

Router A(config)#interface Fast Ethernet 1/0

Router A(config-if)#ip address 192.168.1.1 255.255.255.0

Router A(config-if)#exit

Router B(config)#interface serial 4/0

Router B(config-if)#ip address 1.1.1.2 255.255.255.0

Router B(config-if)#exit

Router B(config)#interface Fast Ethernet 1/0

Router B(config-if)#ip address 192.168.2.1 255.255.255.0

Router B(config-if)#exit

步骤2 配置帧中继。

Router A(config)#interface serial 4/0

Router A(config-if)# encapsulation frame-relay ietf

Router A(config-if)# frame-relay map ip 1.1.1.2 16

Router A(config-if)# frame-relay lmi-type ansi

Router B(config)#interface serial 4/0

Router B(config-if)# encapsulation frame-relay ietf

Router B(config-if)# frame-relay map ip 1.1.1.1 17

Router B(config-if)# frame-relay lmi-type ansi

步骤3 验证帧中继配置。

Router B#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

Active Inactive Deleted Static

Local 1 0 0 0

Switched 0 0 0 0

Unused 0 0 0 0

DLCI = 17, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 5 output pkts 5 in bytes 520

out bytes 520 dropped pkts 0 in pkts dropped 0

out pkts dropped 0 out bytes dropped 0

in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

out BECN pkts 0 in DE pkts 0 out DE pkts 0

out bcast pkts 0 out bcast bytes 0

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

pvc create time 00:01:14, last time pvc status changed 00:00:48

RouterB#show frame-relay map

Serial1/0 (up): ip 1.1.1.1 dlci 17(0x11,0x410), static,

broadcast,

IETF, status defined, active

Router B#show frame-relay lmi 实验 35 帧中继基本配置 ·59·

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI

Invalid Unnumbered info 0 Invalid Prot Disc 0

Invalid dummy Call Ref 0 Invalid Msg Type 0

Invalid Status Message 0 Invalid Lock Shift 0

Invalid Information ID 0 Invalid Report IE Len 0

Invalid Report Request 0 Invalid Keep IE Len 0

Num Status Enq. Sent 13 Num Status msgs Rcvd 13

Num Update Status Rcvd 0 Num Status Timeouts 0

Last Full Status Req 00:00:05 Last Full Status Rcvd 00:00:05

【注意事项】

封装广域网协议时,要求V.35线缆的两个端口封装协议一致,否则无法建立链路。

【参考配置】

Router A#show running-config

Building configuration...

Current configuration : 574 bytes

!

version RGNOS 10.1.00(4), Release(18443)(Tue Jul 17 21:16:17 CST 2007 -ubu1server)

hostname Router A

!

interface serial 4/0

encapsulation frame-relay ietf

frame-relay map ip 1.1.1.2 16

ip address 1.1.1.1 255.255.255.0

clock rate 64000

!

interface serial 4/1

clock rate 64000

!

interface GigabitEthernet 0/0

duplex auto

speed auto

!

interface FastEthernet 1/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

line con 0

line aux 0

line vty 0 4

login

!

end

Router B#show running-config

Building configuration...

Current configuration : 581 bytes

!

version RGNOS 10.1.00(4), Release(18443)(Tue Jul 17 21:16:17 CST 2007 -ubu1server)

hostname Router B

!

interface serial 4/0

encapsulation frame-relay ietf

frame-relay map ip 1.1.1.1 17

ip address 1.1.1.2 255.255.255.0

clock rate 64000

!

interface serial 4/1

clock rate 64000

!

interface GigabitEthernet 0/0

duplex auto

speed auto

!

interface FastEthernet 1/0

ip address 192.168.2.1 255.255.255.0

duplex auto

speed auto

!

line con 0

line aux 0

line vty 0 4

login

!

end