自己的测试服务器一直装的是pve5版本,为了测试及适应后面的pve新功能,乘2021国庆期间有空,做一下升级,升级到pve6版本,这里做一个记录。

此次操作参考以下网址的指导文档:

​https://blog.51cto.com/tasnrh/2423364​​​


由于是测试环境,不存在什么选择停机时间,将重要的镜像和虚拟机转移到非系统盘所在的存储池,所以数据方面没有什么特别考虑,如果升级出问题,最后大不了重装新版本就行了,数据还在数据盘。

PVE5升级到PVE6升级记录(单机)_升级


从pve5.x升级到6.x

官方操作手册如下:

​https://pve.proxmox.com/wiki/Upgrade_from_5.x_to_6.0​

首先由于我们身处墙国,先将相关的源设置为国内源,由于我之前就设置过了,略过。下面是我的软件源配置:

root@pve1:/etc/apt# more pve-no-subscription.list


deb https://mirrors.ustc.edu.cn/proxmox/debian/pve stretch pve-no-subscription


root@pve1:/etc/apt# more sources.list


deb http://mirrors.163.com/debian/ stretch main contrib non-free

deb-src http://mirrors.163.com/debian/ stretch main contrib non-free


deb http://mirrors.163.com/debian/ stretch-updates main contrib non-free

deb-src http://mirrors.163.com/debian/ stretch-updates main contrib non-free

deb http://mirrors.163.com/debian-security/ stretch/updates main contrib non-free

deb-src http://mirrors.163.com/debian-security/ stretch/updates main contrib non-free

之后,更新源,升级:

apt update && apt dist-upgrade

2、升级Corosync到Corosync 3

由于我的是单机,可以略过,但是为了练手,还是做一下。

​ 

systemctl stop pve-ha-lrm


systemctl stop pve-ha-crm


添加Proxmox Corosync 3 Stretch存储库


echo "deb http://mirrors.ustc.edu.cn/proxmox/debian/corosync-3/ stretch main"> /etc/apt/sources.list.d/corosync3.list


运行命令更新


apt update


根据官方手册支持执行:


apt list --upgradeable


apt dist-upgrade --download-only


apt dist-upgrade


如果关闭了高可用服务的在更新完毕后需要重新启动高可用服务


systemctl start pve-ha-lrm

systemctl start pve-ha-crm

 

3、升级到Proxmox 6.0

​执行镜像源更新命令,将Debian的镜像源更换为升级源

sed -i ‘s/stretch/buster/g’ /etc/apt/sources.list

添加Proxmox VE 6的镜像存储库地址

echo "deb  http://mirrors.ustc.edu.cn/proxmox/debian/pve buster pve-no-subscription " > /etc/apt/sources.list.d/pve-no-sub.list

执行升级命令:

apt update

apt dist-upgrade

​apt dist-upgrade 碰到一个报错:


root@pve1:/etc/apt# apt dist-upgrade

Reading package lists... Done

Building dependency tree

Reading state information... Done

You might want to run 'apt --fix-broken install' to correct these.

The following packages have unmet dependencies:

libncursesw6 : Depends: libtinfo6 (= 6.2-1) but 6.1+20181013-2+deb10u2 is installed

E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


最后参考这个帖子解决了:

​https://www.rants.org/2019/07/solved-apt-get-dist-upgrade-error-when-going-from-debian-9-x-stretch-to-10-0-buster/​

思路就是手动下载libncursesw6 安装包,注意,软件包有stable、oldstable,选择oldstable因为版本跟libtinfo6相配套,下载地址:

​http://ftp.cn.debian.org/debian/pool/main/n/ncurses/libncursesw6_6.1+20181013-2+deb10u2_amd64.deb​

下载下来之后,使用下面的命令手动安装:

dpkg -i ​​libncursesw6_6.1+20181013-2+deb10u2_amd64.deb​

以后碰到类似问题,可以在下面这个地址查找软件debian软件包手动安装:

​https://packages.debian.org/​


安装过程有一些交互,根据提示进行交互就行,如果英文差看不懂,就按照默认选项按回车,嘿嘿。视网络情况,安装过程大概半小时。最后升级成功,哈哈!

另外,升级过程若正常,正在运行的虚拟机不会受到影响。

PVE5升级到PVE6升级记录(单机)_proxmox_02