一、VRRP的原理及配置方案  (配置环境:华为设备)

1、VRRP的简介

      中文名称:虚拟路由器冗余协议

      英文名称:Virtual Router Redundancy Protocol

      简称:VRRP

是一种LAN接入设备备份协议。一个局域网络内的所有主机都设置缺省网关,这样主机发出的目的地址不在本网段的报文将被通过缺省网关发往三层交换机,从而实现了主机和外部网络的通信。

虚拟路由器冗余协议(VRRP)是一种选择协议,它可以把一个虚拟路由器的责任动态分配到局域网上的 VRRP 路由器中的一台。控制虚拟路由器 IP 地址的 VRRP 路由器称为主路由器,它负责转发数据包到这些虚拟 IP 地址。一旦主路由器不可用,这种选择过程就提供了动态的故障转移机制,这就允许虚拟路由器的 IP 地址可以作为终端主机的默认第一跳路由器。使用 VRRP 的好处是有更高的默认路径的可用性而无需在每个终端主机上配置动态路由或路由发现协议。 VRRP 包封装在 IP 包中发送。

2、详细参数 VRRP(Virtual Router Redundancy Protocol,虚拟路由冗余协议)是一种容错协议。通常,一个网络内的所有主机都设置一条缺省路由,这样,主机发出的目的地址不在本网段的报文将被通过缺省路由发往路由器RouterA,从而实现了主机与外部网络的通信。当路由器RouterA 坏掉时,本网段内所有以RouterA 为缺省路由下一跳的主机将断掉与外部的通信。VRRP 就是为解决上述问题而提出的,它为具有多播或广播能力的局域网(如:以太网)设计。VRRP 将局域网的一组路由器(包括一个Master 即活动路由器和若干个Backup 即备份路由器)组织成一个虚拟路由器,称之为一个备份组。这个虚拟的路由器拥有自己的IP 地址10.100.10.1(这个IP 地址可以和备份组内的某个路由器的接口地址相同),备份组内的路由器也有自己的IP 地址(如Master的IP 地址为10.100.10.2,Backup 的IP 地址为10.100.10.3)。局域网内的主机仅仅知道这个虚拟路由器的IP 地址10.100.10.1,而并不知道具体的Master 路由器的IP 地址10.100.10.2 以及Backup 路由器的IP 地址10.100.10.3,它们将自己的缺省路由下一跳地址设置为该虚拟路由器的IP 地址10.100.10.1。于是,网络内的主机就通过这个虚拟的路由器来与其它网络进行通信。如果备份组内的Master 路由器坏掉,Backup 路由器将会通过选举策略选出一个新的Master 路由器,继续向网络内的主机提供路由服务。从而实现网络内的主机不间断地与外部网络进行通信。关于VRRP 协议的详细信息,可以参考RFC 2338。 2、互相区别 VRRP协议的工作机理与CISCO公司的HSRP(Hot Standby Routing Protocol)有许多相似之处。但二者主要的区别是在CISCO的HSRP中,需要单独配置一个IP地址作为虚拟路由器对外体现的地址,这个地址不能是组中任何一个成员的接口地址。

使用VRRP协议,不用改造目前的网络结构,最大限度保护了当前投资,只需最少的管理费用,却大大提升了网络性能,具有重大的应用价值。

3、工作原理 vrrp只定义了一种报文——vrrp报文,这是一种组播报文,由主三层交换机定时发出来通告他的存在。使用这些报文可以检测虚拟三层交换机各种参数,还可以用于主三层交换机的选举。

VRRP中定义了三种状态模型,初始状态Initialize,活动状态Master和备份状态Backup,其中只有活动状态的交换机可以为到虚拟IP地址的的转发请求提供服务。

vrrp报文是封装在IP报文上的,支持各种上层协议,同时VRRP还支持将真实接口IP地址设置为虚拟IP地址。

那么如何从备份组的多台交换机中选举Master?这项工作由我们在备份组内每台交换机上配置的相同IP地址的虚拟交换机完成。

虚拟交换机根据配置的优先级的大小选择主交换机,优先级最大的作为主交换机,状态为Master,若优先级相同(如果交换机没有配置优先级,就采用默认值100),则比较接口的主IP地址,主IP地址大的就成为主交换机,由它提供实际的路由服务。其他交换机作为备份交换机,随时监测主交换机的状态。当主交换机正常工作时,它会每隔一段时间发送一个VRRP组播报文,以通知组内的备份交换机,主交换机处于正常工作状态。如果组内的备份交换机长时间没有接收到来自主交换机的VRRP组播报文,则将自己状态转换为Master。当组内有多台备份交换机,将有可能产生多个主交换机。这时每一个主交换机就会比较VRRP报文中的优先级和自己本地的优先级,如果本地的优先级小于VRRP中的优先级,则将自己的状态转换为Backup,否则保持自己的状态不变。通过这样一个过程,就会将优先级最大的交换机选成新的主交换机,完成VRRP的备份功能。

4、应用实例

最典型的VRRP应用:RTA、RTB组成一个VRRP路由器组,假设RTB的处理能力高于RTA,则将RTB配置成IP地址所有者,H1、H2、H3的默认网关设定为RTB。则RTB成为主控路由器,负责ICMP重定向、ARP应答和IP报文的转发;一旦RTB失败,RTA立即启动切换,成为主控,从而保证了对客户透明的安全切换。

在VRRP应用中,RTB在线时RTA只是作为后备,不参与转发工作,闲置了路由器RTA和链路L1。通过合理的网络设计,可以达到备份和负载分担双重效果。让RTA、RTB同时属于互为备份的两个VRRP组:在组1中RTA为IP地址所有者;组2中RTB为IP地址所有者。将H1的默认网关设定为RTA;H2、H3的默认网关设定为RTB。这样,既分担了设备负载和网络流量,又提高了网络可靠性。

VRRP协议的工作机理与CISCO公司的HSRP(Hot Standby Routing Protocol)有许多相似之处。但二者主要的区别是在CISCO的HSRP中,需要单独配置一个IP地址作为虚拟路由器对外体现的地址,这个地址不能是组中任何一个成员的接口地址。

使用VRRP协议,不用改造目前的网络结构,最大限度保护了当前投资,只需最少的管理费用,却大大提升了网络性能,具有重大的应用价值。

5、大多数使用的锐捷设备配置方式

spanning-tree 开启生成树(默认为mstp)

spanning-tree mst configuration 进入mst配置模式

revision 1 指定MST revision number 为1

name region1 指定mst配置名称

instance 0 vlan 1-9, 11-19, 21-4094 缺省情况下vlan都属于实例0

instance 1 vlan 10 手工指定vlan10属于实例1

instance 2 vlan 20 手工指定vlan20属于实例2

spanning-tree mst 1 priority 0 指定实例1的优先级为0(为根桥)

spanning-tree mst 2 priority 4096 指定实例2的优先级为4096

interface GigabitEthernet 0/1

switchport access vlan 10 配置g0/1属于vlan10

!

interface GigabitEthernet 0/2

switchport access vlan 20 配置g0/2属于vlan 20

!

interface GigabitEthernet 0/3

!

.

.

interface GigabitEthernet 0/24 设置g0/24为trunk接口且允许vlan10/20通过

switchport mode trunk

!

interface VLAN 10 创建vlan 10 svi接口

ip address 192.168.10.1 255.255.255.0 配置ip地址

vrrp 1 priority 120 配置vrrp组1 优先级为120

vrrp 1 ip 192.168.10.254 配置vrrp组 1虚拟ip地址为 192.168.10.254

!

interface VLAN 20 创建vlan 20 svi接口

ip address 192.168.20.1 255.255.255.0 配置ip地址

vrrp 2 ip 192.168.20.254 配置vrrp组 2虚拟ip地址为 192.168.20.254

默认vrrp组的优先级为100默认不显示

!

line con 0

line vty 0 4

login

验证配置:

s1#show vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

---

1 VLAN0001 STATIC Gi0/3, Gi0/4, Gi0/5, Gi0/6

Gi0/7, Gi0/8, Gi0/9, Gi0/10

Gi0/11, Gi0/12, Gi0/13, Gi0/14

Gi0/15, Gi0/16, Gi0/17, Gi0/18

Gi0/19, Gi0/20, Gi0/21, Gi0/22

Gi0/23, Gi0/24

10 VLAN0010 STATIC Gi0/1, Gi0/24

20 VLAN0020 STATIC Gi0/2, Gi0/24

接下来的同级设备照上面大体框架配置既可

 

实验拓扑图

 

image

 

实验配置步骤

R1的配置步骤

[R1]int ethernet1.10
[R1-Ethernet1.10]vlan-type dot1q vid 10
[R1-Ethernet1.10]ip add 192.168.10.1 24
[R1-Ethernet1.10]
%01:07:45: Line protocol ip on the interface Ethernet1.10 is UP
[R1-Ethernet1.10]int ethernet1.20            
[R1-Ethernet1.20]vlan-type dot1q vid 20
[R1-Ethernet1.20]ip add 192.168.20.1 24
[R1-Ethernet1.20]
%01:08:28: Line protocol ip on the interface Ethernet1.20 is UP   //将接口ethernet1分成两个子接口并配置ip地址

 

[R1]display ip rout  //查看R1的路由表

 

image

 R1的配置步骤

[R2]int etherne1.10
[R2-Ethernet1.10]vlan-type dot1q vid 10
[R2-Ethernet1.10]ip add 192.168.10.2 24
[R2-Ethernet1.10]
%01:03:50: Line protocol ip on the interface Ethernet1.10 is UP
[R2-Ethernet1.10]int etherne1.20            
[R2-Ethernet1.20]vlan-type dot1q vid 20
[R2-Ethernet1.20]ip add 192.168.20.2 24
[R2-Ethernet1.20]
%01:04:18: Line protocol ip on the interface Ethernet1.20 is UP //将接口ethernet1分成两个子接口并配置ip地址

[R2]dis ip rout  //查看R2的路由表

 

image

 SW-1的配置步骤

[SW-1]int etherne0/24
[SW-1-Ethernet0/24]port link-type trunk  
[SW-1-Ethernet0/24]port trunk permit vlan all
Please wait........................................... Done.   //将etherne0/24 定义为trunk口并允许所有vlan通过
[SW-1-Ethernet0/24]int e0/1                  
[SW-1-Ethernet0/1]port link-type trunk      
[SW-1-Ethernet0/1]port trunk permit vlan all
Please wait........................................... Done. //将etherne0/1 定义为trunk口并允许所有vlan通过


[SW-1-Ethernet0/1]qu
[SW-1]vlan 10
[SW-1-vlan10]port e0/5 to e0/10  //将port e0/5 to e0/10 划分到vlan10中

[SW-1-vlan10]vlan 20          
[SW-1-vlan20]port e0/15 to e0/20  //将port e0/15 to e0/20 划分到vlan20中
[SW-1-vlan20]qu

 

[SW-1]dis vlan 10  //查看vlan10的配置情况

 

image

[SW-1]dis vlan 20  //查看vlan20的配置情况

 

image

 

 SW-1的配置步骤

[SW-2]int ethernet0/24  
[SW-2-Ethernet0/24]port link-type trunk
[SW-2-Ethernet0/24]port trunk permit vlan all  //将etherne0/24 定义为trunk口并允许所有vlan通过


Please wait........................................... Done.
[SW-2-Ethernet0/24]int ethernet0/1                 
[SW-2-Ethernet0/1]port link-type trunk     
[SW-2-Ethernet0/1]port trunk permit vlan all
Please wait........................................... Done.
[SW-2-Ethernet0/1]vlan 10
[SW-2-vlan10]port e0/5 to e0/10   //将port e0/5 to e0/10 划分到vlan10中
[SW-2-vlan10]vlan 20          
[SW-2-vlan20]port e0/15 to e0/20  //将port e0/15 to e0/20 划分到vlan20中
[SW-2-vlan20]qu

 

[SW-2]dis vlan 10  //查看vlan10的配置情况

 

image

 

[SW-2]dis vlan 20  //查看vlan20的配置情况

 

image

测试:在R1上pingR2的子接口

[R1]ping 192.168.10.2

image

[R1]ping 192.168.20.2

image

[R1]vrrp ping-enable
  ping vrrp  enable

[R1]int e1.10
[R1-Ethernet1.10]vrrp ?
    authentication-mode Set the authentication type and key
    vrid                Virtual router ID

[R1-Ethernet1.10]vrrp vrid 10 virtual-ip 192.168.10.254
[R1-Ethernet1.10]vrrp vrid 10 priority 120            
[R1-Ethernet1.10]int e1.20                            
[R1-Ethernet1.20]vrrp vrid 20 virtual-ip 192.168.20.254
[R1-Ethernet1.20]qu

[R2]vrrp ping-enable
  ping vrrp  enable
[R2]int e1.10
[R2-Ethernet1.10]vrrp vrid 10 virtual-ip 192.168.10.254
[R2-Ethernet1.10]int e1.20                            
[R2-Ethernet1.20]vrrp vrid 20 virtual-ip 192.168.20.254
[R2-Ethernet1.20]vrrp vrid 20 priority 120            
[R2-Ethernet1.20]qu

image

 

 

测试结果:

主机1的ip配置

image

 

主机2的ip配置

image

在主机1上ping所有接口    //结果都能ping通

C:\Users\Administrator>ping 192.168.10.254

正在 Ping 192.168.10.254 具有 32 字节的数据:
来自 192.168.10.254 的回复: 字节=32 时间<1ms TTL=255
来自 192.168.10.254 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.10.254 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.10.254 的回复: 字节=32 时间&lt;1ms TTL=255

192.168.10.254 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 0ms,平均 = 0ms

C:\Users\Administrator>ping 192.168.20.254

正在 Ping 192.168.20.254 具有 32 字节的数据:
来自 192.168.20.254 的回复: 字节=32 时间=9ms TTL=255
来自 192.168.20.254 的回复: 字节=32 时间<1ms TTL=255
来自 192.168.20.254 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.20.254 的回复: 字节=32 时间=2ms TTL=255

192.168.20.254 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 9ms,平均 = 2ms

C:\Users\Administrator>ping 192.168.20.1

正在 Ping 192.168.20.1 具有 32 字节的数据:
来自 192.168.20.1 的回复: 字节=32 时间<1ms TTL=255
来自 192.168.20.1 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.20.1 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.20.1 的回复: 字节=32 时间&lt;1ms TTL=255

192.168.20.1 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 0ms,平均 = 0ms

C:\Users\Administrator>ping 192.168.20.2

正在 Ping 192.168.20.2 具有 32 字节的数据:
来自 192.168.20.2 的回复: 字节=32 时间=1ms TTL=255
来自 192.168.20.2 的回复: 字节=32 时间<1ms TTL=255
来自 192.168.20.2 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.20.2 的回复: 字节=32 时间&lt;1ms TTL=255

192.168.20.2 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 1ms,平均 = 0ms

 

C:\Users\Administrator>ping 192.168.10.2

正在 Ping 192.168.10.2 具有 32 字节的数据:
来自 192.168.10.2 的回复: 字节=32 时间<1ms TTL=255
来自 192.168.10.2 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.10.2 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.10.2 的回复: 字节=32 时间&lt;1ms TTL=255

192.168.10.2 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 0ms,平均 = 0ms

 

  C:\Users\Administrator>ping 192.168.20.1

正在 Ping 192.168.20.1 具有 32 字节的数据:
来自 192.168.20.1 的回复: 字节=32 时间<1ms TTL=255
来自 192.168.20.1 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.20.1 的回复: 字节=32 时间&lt;1ms TTL=255
来自 192.168.20.1 的回复: 字节=32 时间=1ms TTL=255

192.168.20.1 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 1ms,平均 = 0ms

C:\Users\Administrator>ping 192.168.20.100    //主机1ping主机2能ping通

正在 Ping 192.168.20.100 具有 32 字节的数据:
来自 192.168.20.100 的回复: 字节=32 时间=1ms TTL=63
来自 192.168.20.100 的回复: 字节=32 时间&lt;1ms TTL=63
来自 192.168.20.100 的回复: 字节=32 时间&lt;1ms TTL=63
来自 192.168.20.100 的回复: 字节=32 时间&lt;1ms TTL=63

192.168.20.100 的 Ping 统计信息:
    数据包: 已发送 = 4,已接收 = 4,丢失 = 0 (0% 丢失),
往返行程的估计时间(以毫秒为单位):
    最短 = 0ms,最长 = 1ms,平均 = 0ms

 

 、HSRP的原理及配置方案 (配置环境:思科---小贩模拟器)

1、HSRP工作原理

      HSRP:热备份路由器协议(HSRP:Hot Standby Router Protocol)
热备份路由器协议(HSRP)的设计目标是支持特定情况下 IP 流量失败转移不会引起混乱、并允许主机使用单路由器,以及即使在实际第一跳路由器使用失败的情形下仍能维护路由器间的连通性。换句话说,当源主机不能动态知道第一跳路由器的 IP 地址时,HSRP 协议能够保护第一跳路由器不出故障。该协议中含有多种路由器,对应一个虚拟路由器。HSRP 协议只支持一个路由器代表虚拟路由器实现数据包转发过程。终端主机将它们各自的数据包转发到该虚拟路由器上。
负责转发数据包的路由器称之为主动路由器(Active Router)。一旦主动路由器出现故障,HSRP 将激活备份路由器(Standby Routers)取代主动路由器。HSRP 协议提供了一种决定使用主动路由器还是备份路由器的机制,并指定一个虚拟的 IP 地址作为网络系统的缺省网关地址。如果主动路由器出现故障,备份路由器(Standby Routers)承接主动路由器的所有任务,并且不会导致主机连通中断现象。
HSRP 运行在 UDP 上,采用端口号1985。路由器转发协议数据包的源地址使用的是实际 IP 地址,而并非虚拟地址,正是基于这一点,HSRP 路由器间能相互识别.HSRP技术在网络中的应用 随着Internet的日益普及,人们对网络的依赖性也越来越强。这同时对网络的稳定性提出了更高的要求,人们自然想到了基于设备的备份结构,就像在服务器中为提高数据的安全性而采用双硬盘结构一样。路由器是整个网络的核心和心脏,如果路由器发生致命性的故障,将导致本地网络的瘫痪,如果是骨干路由器,影响的范围将更大,所造成的损失也是难以估计的。因此,对路由器采用热备份是提高网络可靠性的必然选择。在一个路由器完全不能工作的情况下,它的全部功能便被系统中的另一个备份路由器完全接管,直至出现问题的路由器恢复正常,这就是热备份路由协议(HotStandbyRouterProtocal),HSR PRFC2281技术要解决的问题。
2、HSRP协议概述
实现HSRP的条件是系统中有多台路由器,它们组成一个“热备份组”,这个组形成一个虚拟路由器。在任一时刻,一个组内只有一个路由器是活动的,并由它来转发数据包,如果活动路由器发生了故障,将选择一个备份路由器来替代活动路由器,但是在本网络内的主机看来,虚拟路由器没有改变。所以主机仍然保持连接,没有受到故障的影响,这样就较好地解决了路由器切换的问题。
为了减少网络的数据流量,在设置完活动路由器和备份路由器之后,只有活动路由器和备份路由器定时发送HSRP报文。如果活动路由器失效,备份路由器将接管成为活动路由器。如果备份路由器失效或者变成了活跃路由器,将由另外的路由器被选为备份路由器。
在实际的一个特定的局域网中,可能有多个热备份组并存或重叠。每个热备份组模仿一个虚拟路由器工作,它有一个Well-known-MAC地址和一个IP地址。该IP地址、组内路由器的接口地址、主机在同一个子网内,但是不能一样。当在一个局域网上有多个热备份组存在时,把主机分布到不同的热备份组,可以使负载得到分担。
3、HSRP的工作原理
HSRP协议利用一个优先级方案来决定哪个配置了HSRP协议的路由器成为默认的主动路由器。如果一个路由器的优先级设置的比所有其他路由器的优先级高,则该路由器成为主动路由器。路由器的缺省优先级是100,所以如果只设置一个路由器的优先级高于100,则该路由器将成为主动路由器。
通过在设置了HSRP协议的路由器之间广播HSRP优先级,HSRP协议选出当前的主动路由器。当在预先设定的一段时间内主动路由器不能发送hello消息时,优先级最高的备用路由器变为主动路由器。路由器之间的包传输对网络上的所有主机来说都是透明的。
配置了HSRP协议的路由器交换以下三种多点广播消息:
Hello———hello消息通知其他路由器发送路由器的HSRP优先级和状态信息,HSRP路由器默认为每3秒钟发送一个hello消息;
Coup———当一个备用路由器变为一个主动路由器时发送一个coup消息;
Resign———当主动路由器要宕机或者当有优先级更高的路由器发送hello消息时,主动路由器发送一个resign消息。在任一时刻,配置了HSRP协议的路由器都将处于以下六种状态之一:
Initial———HSRP启动时的状态,HSRP还没有运行,一般是在改变配置或端口刚刚启动时进入该状态。
learn———路由器已经得到了虚拟IP地址,但是它既不是活动路由器也不是等待路由器。它一直监听从活动路由器和等待路由器发来的HELLO报文。
Listen———路由器正在监听hello消息。
Speak———在该状态下,路由器定期发送HELLO报文,并且积极参加活动路由器或等待路由器的竞选。
Standby———当主动路由器失效时路由器准备接管包传输功能。
Active———路由器执行包传输功能。
4、本方案的特点:
1.高度的可靠性,两台路由器之间采用HSRP(热备份冗余协议)协议,来保证两台路由器中的任意一台down掉,或路由器的广域网口down,都会迅速切换到另外一台。如果两条线路均出现问题,就采用路由策略停掉邮政子网业务,启用拨号线路。
2.有效的实现了负载均衡,在STAR-S1924F+上划分出各自的VLAN,储蓄子网VLAN在左侧路由器上的HSRP的优先级较高,默认使用网通的FR线路;邮政系统(办公、报刊、EMS、VOIP等等)子网VLAN在右侧路由器上的HSRP的优先级较高,默认使用联通的FR线路。充分利用了带宽资源,而且实现了负载均衡。
3.充分利用了多以太口路由器在划分多业务网段上的功能,也只有多以太口路由器在HSRP应用中才能实现两个路由器间的负载分担,这是具有四个以太口路由器的极大的优点。
4.在右侧路由器上启用QoS策略,VoIP业务需要较低的延时,所以将VoIP业务设置成较高的优先级。
5.通过在交换机上设置VLAN,有效的控制了两个子网间的安全。
6.不存在单点故障问题。

实验拓扑图

 

 

 image

R1的配置

R1(config)#int f0/0
R1(config-if)#no shut   //一定要激活接口f0/0 这步不能少
R1(config-if)#
*Mar 1 00:09:11.427: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:09:12.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#int f0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip add 192.168.10.1 255.255.255.0
R1(config-subif)#int f0/0.20                     
R1(config-subif)#encapsulation dot1Q 20          
R1(config-subif)#ip add 192.168.20.1 255.255.255.0 //将接口f0/0分成两个子接口并配置ip地址

R1#show ip route   //查看R1路由表
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, FastEthernet0/0.10
C    192.168.20.0/24 is directly connected, FastEthernet0/0.20  
//R1路由表有两条直连路由

R2的配置

R2(config)#int f0/0
R2(config-if)#no shut    //一定要激活接口f0/0 这步不能少

R2(config-if)#
*Mar  1 00:09:11.427: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:09:12.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#int f0/0.10
R2(config-subif)#encapsulation dot1Q 10
R2(config-subif)#ip add 192.168.10.2 255.255.255.0
R2(config-subif)#int f0/0.20                     
R2(config-subif)#encapsulation dot1Q 20          
R2(config-subif)#ip add 192.168.20.2 255.255.255.0   //将接口f0/0分成两个子接口并配置ip地址

R2#show ip route   //查看R2路由表
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, FastEthernet0/0.10
C    192.168.20.0/24 is directly connected, FastEthernet0/0.20   
//R2路由表有两条直连路由


SW1的配置

SW1(config)#no ip routing   //一定要取消路由功能 这步不能少
SW1(config)#int f0/0

SW1(config-if)#switchport mode trunk   //将f0/0设为trunk口
SW1(config-if)#
*Mar  1 00:08:43.299: %DTP-5-TRUNKPORTON: Port Fa0/0 has become dot1q trunk
SW1(config-if)#exit
SW1(config)#int range f0/1 - 2
SW1(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel1
SW1(config-if-range)#
*Mar  1 00:11:08.059: %EC-5-BUNDLE: Interface Fa0/1 joined port-channel Po1
*Mar  1 00:11:08.263: %EC-5-BUNDLE: Interface Fa0/2 joined port-channel Po1
SW1(config-if-range)#
*Mar  1 00:11:10.931: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
SW1(config-if-range)#exit
SW1(config)#interface port-channel 1
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#
*Mar  1 00:12:27.147: %EC-5-UNBUNDLE: Interface Fa0/1 left the port-channel Po1
*Mar  1 00:12:27.215: %EC-5-UNBUNDLE: Interface Fa0/2 left the port-channel Po1
*Mar  1 00:12:27.259: %EC-5-BUNDLE: Interface Fa0/2 joined port-channel Po1
*Mar  1 00:12:27.291: %EC-5-BUNDLE: Interface Fa0/1 joined port-channel Po1
*Mar  1 00:12:27.695: %DTP-5-TRUNKPORTON: Port Fa0/1-2 has become dot1q trunk   //将f0/1与f0/2捆绑设为以太网通道

SW1#vlan database  //创建vlan数据库
SW1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010   //创建vlan10
SW1(vlan)#vlan 20
VLAN 20 added:
    Name: VLAN0020   //创建vlan20

SW1(vlan)#exit
APPLY completed.
Exiting....
SW1(config)#int range f0/3 - 10
SW1(config-if-range)#switchport access vlan 10  //将f0/3-10划分到vlan10中
SW1(config)#int range f0/11 - 15     
SW1(config-if-range)#switchport access vlan 20   //将f0/11-15划分到vlan10中

SW2的配置

SW2(config)#no ip routing  //一定要取消路由功能 这步不能少

SW2(config)#int f0/0
SW2(config-if)#switchport mode trunk   //将f0/0设为trunk口
SW2(config-if)#

*Mar  1 00:13:36.779: %DTP-5-TRUNKPORTON: Port Fa0/0 has become dot1q trunk
SW2(config)#int range f0/1 - 2
SW2(config-if-range)#channel-group 1 mode on
Creating a port-channel interface Port-channel1
SW2(config-if-range)#
*Mar  1 00:14:47.587: %EC-5-BUNDLE: Interface Fa0/1 joined port-channel Po1
*Mar  1 00:14:47.731: %EC-5-BUNDLE: Interface Fa0/2 joined port-channel Po1

SW2(config-if-range)#
*Mar  1 00:14:50.419: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
SW2(config-if-range)#exit
SW2(config)#interface port-channel 1
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport mode trunk
SW2(config-if)#
*Mar  1 00:15:26.947: %EC-5-UNBUNDLE: Interface Fa0/1 left the port-channel Po1
*Mar  1 00:15:27.027: %EC-5-UNBUNDLE: Interface Fa0/2 left the port-channel Po1
*Mar  1 00:15:27.059: %EC-5-BUNDLE: Interface Fa0/2 joined port-channel Po1
*Mar  1 00:15:27.075: %EC-5-BUNDLE: Interface Fa0/1 joined port-channel Po1
*Mar  1 00:15:27.511: %DTP-5-TRUNKPORTON: Port Fa0/1-2 has become dot1q trunk  
//将f0/1与f0/2捆绑设为以太网通道

SW2#vlan database   /创建vlan数据库
SW2(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010   //创建vlan10

SW2(vlan)#vlan 20
VLAN 20 added:
    Name: VLAN0020   //创建vlan20

SW2(vlan)#exit
APPLY completed.
Exiting....
SW2(config)#int range f0/3 - 10
SW2(config-if-range)#switchport access vlan 10   //将f0/3-10划分到vlan10中
SW2(config-if-range)#exit
SW2(config)#int range f0/11 - 15    
SW2(config-if-range)#switchport access vlan 20   //将f0/11-15划分到vlan10中

在R1中pingR2的子接口 

R1#ping 192.168.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 28/43/80 ms
R1#ping 192.168.20.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 32/71/112 ms
R1#

 

R2#ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/46/84 ms
R2#ping 192.168.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/52/92 ms    //均能ping通

 

R1(config)#int f0/0.10
R1(config-subif)#standby 10 ip 192.168.10.254
R1(config-subif)#exit
R1(config)#int f0/0.10                
R1(config-subif)#st
R1(config-subif)#standby 10 priority 120
R1(config-subif)#int f0/0.20           
R1(config-subif)#standby 20 ip 192.168.20.254  //在R1子接口里配置相应备份路由并将f0/0.10的优先级设为120

R1#show standby     //查看R1的备份路由
FastEthernet0/0.10 - Group 10
  State is Active
    2 state changes, last state change 00:04:44
  Virtual IP address is 192.168.10.254
  Active virtual MAC address is 0000.0c07.ac0a
    Local virtual MAC address is 0000.0c07.ac0a (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.756 secs
  Preemption disabled
  Active router is local
  Standby router is 192.168.10.2, priority 100 (expires in 7.196 sec)
  Priority 120 (configured 120)
  IP redundancy name is "hsrp-Fa0/0.10-10" (default)
FastEthernet0/0.20 - Group 20
  State is Active
    2 state changes, last state change 00:02:40
  Virtual IP address is 192.168.20.254
  Active virtual MAC address is 0000.0c07.ac14
    Local virtual MAC address is 0000.0c07.ac14 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.884 secs
  Preemption disabled
  Active router is local
  Standby router is 192.168.20.2, priority 120 (expires in 9.652 sec)
  Priority 100 (default 100)
  IP redundancy name is "hsrp-Fa0/0.20-20" (default)

R2(config)#int f0/0.10
R2(config-subif)#st
R2(config-subif)#standby 10 ip 192.168.10.254
R2(config-subif)#int f0/0.20                
R2(config-subif)#standby 20 ip 192.168.20.254   
R2(config-subif)#standby 20 priority 120       //在R1子接口里配置相应备份路由并将f0/0.20的优先级设为120

R2#show standby    //查看R1的备份路由
FastEthernet0/0.10 - Group 10
  State is Standby
    1 state change, last state change 00:02:08
  Virtual IP address is 192.168.10.254
  Active virtual MAC address is 0000.0c07.ac0a
    Local virtual MAC address is 0000.0c07.ac0a (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.588 secs
  Preemption disabled
  Active router is 192.168.10.1, priority 120 (expires in 8.168 sec)
  Standby router is local
  Priority 100 (default 100)
  IP redundancy name is "hsrp-Fa0/0.10-10" (default)
FastEthernet0/0.20 - Group 20
  State is Standby
    1 state change, last state change 00:01:37
  Virtual IP address is 192.168.20.254
  Active virtual MAC address is 0000.0c07.ac14
    Local virtual MAC address is 0000.0c07.ac14 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.004 secs
  Preemption disabled
  Active router is 192.168.20.1, priority 100 (expires in 9.364 sec)
  Standby router is local
  Priority 120 (configured 120)
  IP redundancy name is "hsrp-Fa0/0.20-20" (default)

PC1的配置  注:将PC1的f0/0与SW1的f0/3相连接

PC1(config)#int f0/0
PC1(config-if)#ip add 192.168.10.100 255.255.255.0   //给f0/0配置ip地址
PC1(config-if)#no  shut
PC1(config-if)#
*Mar  1 00:01:33.767: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
PC1(config-if)#exit
*Mar  1 00:01:34.767: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
PC1(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.254 //在PC1上配置一条默认路由,使其下一跳指向192.168.10.254

PC1#show ip route   //查看PC1的路由表


Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.10.254 to network 0.0.0.0

C    192.168.10.0/24 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.10.254  
//一条直连路由一条默认路由

PC2的配置 注:将PC2的f0/0与SW2的f0/15相连接

PC2(config-line)#int f0/0
PC2(config-if)#ip add 192.168.20.100 255.255.255.0
PC2(config-if)#no shut   //给f0/0配置ip地址


PC2(config-if)#
*Mar 1 00:03:23.239: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:03:24.239: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
PC2(config-if)#exit
PC2(config)#ip route 0.0.0.0 0.0.0.0 192.168.20.254   //在PC1上配置一条默认路由,使其下一跳指向192.168.10.254


PC2#show ip route   //查看PC1的路由表
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.20.254 to network 0.0.0.0

C 192.168.20.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 192.168.20.254   //一条直连路由一条默认路由

测试结果:

PC1#ping 192.168.10.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 16/46/72 ms
PC1#ping 192.168.10.1 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 44/58/76 ms
PC1#ping 192.168.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 44/77/120 ms
PC1#ping 192.168.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/56/96 ms
PC1#ping 192.168.20.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/75/128 ms
PC1#ping 192.168.20.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/65/128 ms
PC1#ping 192.168.20.100   //ping PC2能ping通

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.100, timeout is 2 seconds:
..!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 72/108/144 ms 

 

 

PC2#ping 192.168.20.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/79/108 ms
PC2#ping 192.168.10.1 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/46/80 ms
PC2#ping 192.168.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 28/54/80 ms
PC2#ping 192.168.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/59/96 ms
PC2#ping 192.168.20.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/51/100 ms
PC2#ping 192.168.10.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/61/80 ms
PC2#ping 192.168.10.100    //ping PC1能ping通

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/109/160 ms