VLAN配置
1.VLAN的划分与配置
2.广播域的划分
3.跨交换机的VLAN配置
4.配置VTP
二、 实验内容
1.将同一交换机上连接的PC机划分为两个VLAN。通过Ping命令检查其正确性。
2.通过配置交换机的VTP协议,交换机1为服务器模式,交换机2为客户模式,配置两个交换机间的VLAN trunk线路,划分三个VLAN。检查其正确性。
三、相关知识
冲突域:以集线器为核心构建的共享式以太网,其所有节点同处于一个共同的冲突域,一个冲突域内的不同设备发出的以太网帧会互相冲突;同时冲突域内的一台主机发送数据,同处于一个冲突域的其他主机都可以接收到。可见一个冲突域内主机会导致每台主机可用带宽降底,网上冲突可能成倍增加,信息安全得不到保证。
广播域:广播域是网上一组设备的集合,当这些设备中的一个发出广播帧时,所有其他设备都能接收到该帧。广播域和冲突域是两个比较容易混淆的概念,在这里一定要注意区分这两个概念;连接在一个HUB上的所有设备构成一个冲突域,同时也构成一个广播域;连接在每个交换机上的每个设备都分别属于不同冲突域,交换机每个端口构成一个冲突域,而属于同一个VLAN主机都属于一个广播域。
建议本实验每组八人进行,每组需要设备如下:
两台交换机、八台PC机、八根RJ45连线、一条交叉双绞线(用以连接TRUNK线路)、两条Console控制台电缆(一端接交换机Console口,一端接PC机串口)
(一)单交换机VLAN基本配置
按下图所示在一个交换机上连接四台计算机
3.1
PC1连接在交换机的1#端口,PC2连接在3#端口,PC3连接在5#端口,PC4连接在7#端口
创建VLANVLAN信息可以在服务器模式或透明模式交换机上创建。
Switch>enable                    (进入特权模式)
Switch#vlan database              (进入VLAN配置子模式)
Switch(vlan)#vlan 2 name VLAN2   (创建一个VLAN2,由系统自动命名)
Switch(vlan)#vlan 3 name VLAN3   (创建一个VLAN3,并命名为vlan3)
Switch(vlan)#end
1.将端口35按图1-4a所示加入到 VLAN2
Switch#config t
Switch(config)#interface f0/3              (进入端口3的配置模式)
Switch(config-if)#switchport mode access   (设置端口为静态VLAN访问模式)
Switch(config-if)#switchport access vlan 2   (把端口3分配给相应的VLAN2)
Switch(config-if)#exit
Switch(config)#interface f0/5            (进入端口5的配置模式)
Switch(config-if)#switchport mode access    (设置端口为静态VLAN访问模式)
Switch(config-if)#switchport access vlan 2    (把端口5分配给相应的VLAN2)
Switch(config-if)#exit
Switch(config)show vlan                   (查看VLAN配置信息)
(结果省略)
2.将端口1820按图1-4a所示加入到VLAN3
Switch#config t
Switch(config)#interface f0/1                (进入端口1的配置模式)
Switch(config-if)switchport mode access      (设置端口为静态VLAN访问模式)
Switch(config-if)#switchport access vlan 3     (把端口1分配给相应的VLAN3)
Switch(config-if)#exit
Switch(config)#interface f0/7               (进入端口7的配置模式)
Switch(config-if)#switchport mode access      (设置端口为静态VLAN访问模式)
Switch(config-if)#switchport access vlan 3     (把端口7分配给相应的VLAN2)
Switch(config-if)#exit
Switch(config)#show vlan                   (查看VLAN配置信息)
(结果省略)
3.按照图1-4a中的设置各台计算机的IP地址
4.验证同一VLAN中两台计算机能否ping通,不同VLAN中两台计算机能否ping通。
(二)多交换机VLAN配置
已知实验环境:Catalyst 2950交换机 2台;PC 5台。
PC1连接在交换机S11#端口,PC2连接在S17#端口,PC3连接在S22#端口,PC4连接在S24#端口,PC5连接在S26#端口。S1S2之间用12#端口互连。
(1) 按图4.1所示连接网络;
(2) 配置PC机:PC1IP地址:192.168.0.41PC2IP地址:192.168.0.42PC3IP地址:192.168.0.43PC4IP地址:192.168.0.44PC5IP地址:192.168.0.45;子网掩码均为255.255.255.0
  用ping命令检查它们能否通讯。
(3) 配置交换机:设置交换机S1的管理IP192.168.0.11,子网掩码为255.255.255.0;交换机S2的管理IP192.168.0.21,子网掩码为255.255.255.0
  用ping命令检查交换机与各PC机的通讯情况。
(4) 在两台交换机上分别创建并划分VLAN:按图4.2所示划分VLAN
4.2
  用ping命令检查各PC机间的通讯情况。(注意检查此时是否能满足属于同一VLAN的计算机间可以通讯,属于不同VLAN的计算机间不能通讯这一特征。)
(5) 配置Trunk连接:把交换机S112#端口和交换机S212#端口设置为Trunk端口。多个交换机之间通过Trunk线路传送VLAN信息。跨交换机的同一VLAN内的数据也经过Trunk线路传送
Switch#config t
Switch(config)#interface f12/1                  (进入端口1配置模式)
Switch(config-t)#switchport mode trunk          (设置当前端口为Trunk模式)
Switch(config-t)#switchport trunk allowed vlan all (设置允许从端×××换数据的VLAN)
Switch(config-t)#exit
Switch(config)#exit
  再用ping命令检查各PC机间的通讯情况。(注意检查此时是否能满足属于同一VLAN的计算机间可以通讯,属于不同VLAN的计算机间不能通讯这一特征。)
(6) 配置Trunk参数:把交换机S112#Trunk端口设置成只允许VLAN2的信号通过。(注:此项配置Boson不支持)
  再用ping命令检查各PC机间的通讯情况。(注意检查此时S1上的VLAN1S2上的VLAN1是否还是属于同一VLAN。)
(7) 检查配置结果:用show命令查看配置情况。