很多学习网络技术的工程师普遍认为QOS技术很难学习,这主要是来自于内心的学习压力,其实这种技术并不难。举个例子说明,如北京的交通,为了防止交通堵车,对车辆进行限号,这其实就是QOS中的对流量进行分类、标记和监管。比如专用公交车道,这就是使用优先队列的技术。各个路口使用红绿灯,这其实就是对流量进行×××;对交通进行限行,这就是对流量进行尾丢弃等。下面我们通过实验实例来讲解决QOS技术。

当然在进行实验前,还是对理论知识进行理解和消化。

QoS(Qualit of Service)又名服务质量,是保证业务数据在互联网中传输的质量和可靠性的度量。也可以理解为在有限的网络环境(带宽)中为特定的业务数据流提供优质、可靠的服务。

QoS是一个端到端的行为,并不是点到点行为,如果一台计算机与远端的另一台计算机进行通信,为保障其服务的可靠性,需要在其数据经过的每个节点都部署QoS。如果只在某个了点节点部署Qos是不能保障其服务的质量。

QoS服务有二种服务模式,集成服务模式和区分服务模式,在网络中应用范围比较广泛的是区分服务模式,下面以区分模式为主阐述其在网络中的端到端的应用。

区分服务模式下实现QOS主要通过以下几个步骤:

数据分类:要提供区分服务的QOS,就必须先将数据分为不同的类别,或者将数据设置为不同的优先级。将数据分为不同的类别,称为分类(classification),分类并不修改原来的数据包。

clip_p_w_picpath002

数据标记:将数据设置为不同的优先级称为标记(marking),而标记会修改原来的数据包。分类和标记是实施QOS的前提,也是基础。

clip_p_w_picpath004

拥塞管理:当网络发生拥塞后,数据还是要被传递的,正因为接收到的数据远多于自身的传输能力,所以数据被传输时就出现了先后顺序,而依照什么样的方式来传数据,就需要队列的指导,QOS中的队列定义了数据包被传输的先后顺序。

clip_p_w_picpath006

拥塞避免:当网络发生拥塞后,超出的流量将采取其它方式处理,如果处理方式为管制,那么数据包就会被丢弃,通常情况下,网络设备默认丢弃后到的数据包而传输先到的数据包,这样的丢弃方式称为尾丢弃,但也可以让网络设备在发生拥塞时,先丢低优先级的数据包而传输高优先级的数据包。

clip_p_w_picpath008

流量监管:在实施QOS策略时,可以将用户的数据限制在特定的带宽,当用户的流量超过额定带宽时,超过的带宽将不能被传输,只能采取其它方式来处理,如果处理方式为丢弃超出带宽,那么这种行为称为管制(Policing)。

clip_p_w_picpath010

流量×××:在实施QOS策略时,如果是将超出的带宽缓存在内存中,等到下一秒再传递,这种行为称为×××(Shaping)。

clip_p_w_picpath012

链路层优化:

clip_p_w_picpath014

下面讲述如何进行分类和标记。

在网络环境中,如何对数据进行分类和标记呢,而且数据又分为二层的数据帧和三层的数据报,在二层数据帧中使用COS字段分类和标记数据,在三层数据报中使用TOS字段来分类和标记数据。

QOS技术不能在原始的以太网帧上标记数据,但可以使用ISL或802.1Q数据中的COS字段标记。下图为COS字段。

clip_p_w_picpath016

QOS就是使用最高3比特标记数据优先级的,共有7个级别

TOS字段是1B,RFC1122定义IP优先级使用最高3比特,可以定义8个服务等级。

clip_p_w_picpath018

l 111——网络控制 (network control)—保留给网络控制数据使用,如路由

l 110——网间控制 (internetwork control) —保留给网络控制数据使用,如路由

l 101——关键 (critic)—语音数据使用

l 100——疾速 (flash override)—视频会议和视频流使用

l 011——闪速 (flash)—语音控制数据使用

l 010——快速 (immediate)—数据业务使用

l 001——优先 (priority)—数据业务使用

l 000——普通 (routine)—默认标记值

IP优先级方案可以粗略地把数据分为8个等级/类别,但这种设计有其局限性,其最明显的缺点就是类别太少,另一个缺点就是没有定义丢弃级别,还有各个厂商对后4比特的定义也不一致,这些都影响了端到端的QOS的发展与应用。在这种情况下,IETF提出了一种通用的、取代IP优先级分类的方案RFC2474,即用6比特取代了原来的3比特,称这6比特为DSCP(区分服务编码点)

clip_p_w_picpath019

clip_p_w_picpath021

RFC2427定义最高3比特为级别/类别选择代码(class selector codepoints,CS)其意义与IPv4优先级的定义是相同的,CS0~CS7的级别相等于IP优先级0~7。

下面的表格内容很重要,需要理解。

DSCP使用6比特,十进制区间是0~63,可以定义64个级别,下表描述了IP优先级与DSCP值对应关系。

p_w_picpath

保证转发(Assured Forwarding,AF)由RFC2597对CS1~CS4进行进一步定义。其使用第4比特和第5比特做丢弃优先级标志。

l 01——低丢弃优先级

l 10——中丢弃优先级

l 11——高丢弃优先级

丢弃优先级

CS1

CS2

CS3

CS4

低丢弃优先级

AF11

001010

AF21

010010

AF31

011010

AF41

100010

中丢弃优先级

AF12

001100

AF22

010100

AF32

011100

AF42

100100

高丢弃优先级

AF13

001110

AF23

010110

AF33

011110

AF43

100110

快速转发(Expedited Forwarding,EF),由RFC2598定义,DSCP值为46,EF服务适用于低丢包率、低延迟、低抖动及保证带宽的业务,如VOIP。

可以使用命令对数据分类和标记,需要3个步骤:

1、class-map 数据分类

2、policy-map 数据标记

3、service-policy input 应用策略

RA(config)#class-map [match-all | match-any] class-map-name

RA(config-cmap)#match {match-criteria}

Match-all——当设定多个match条件时,满足所有条件的数据才是匹配的。

Match-any——当设定多个match条件时,满足一个条件即可。

match-criteria——设定的匹配条件,match可以设定的条件有:

l access-group ——访问控制列表

l class-map ——调用其它class-map

l cos——使用cos值,最多4个

l destination-address mac——目的MAC地址

l input-interface——入接口

l dscp—— 使用DSCP值,最多7个。

l Precedence——使用IP优先级,最多7个。

l ip rtp ——实时传输协议端口

l mpls experimental topmost——MPLS标签

l not——反向条件选择

l protocol——协议

l source-address mac——源MAC地址

l protocol RTP ——RTP协议

RA(config)#policy-map policy-name

RA(config-pmap)#class [class-deault|class-name]

RA(config-pmap-c)#set tag

RA(config-if)#service-policy input policy-name

Class-map嵌套,是由一个class-map语句调用另一个class-map语句,从而达到灵活分类数据的目的。在很多情况下,在一个class-map中不能同时使用match-all和match-any.

例如有两类数据class1和class2,如果class1调用了class2,则class2使用的是match-any关键,即匹配class2中任意一个条件的数据都是符合要求。Class1调用class2,并且使用的match-all关键字,这样的结果是匹配class2中任意一个条件并且同时匹配class1中其他条件的数据才是符合要求的。

Policy-map也可以嵌套,其是形成的具有分层结构的策略。

通过上面的命令可以对数据进行分类和标记,其主要目的是为特定的数据进行调整,QOS调整的数据流的手段通常有两种方式,流量监管和流量×××。

流量监管判断流量是否违规的工具就是令牌桶。令牌桶有3个参数,数据突发量(Burst size)、平均速率(mean rage)和一定的时间间隔(Tc)。

clip_p_w_picpath023

关于令牌桶的工作原理,我会在下篇博文详细讲述。

下面为实验实例,主要理解分类和标记。

clip_p_w_picpath025

1、192.168.100.0网段是语音数据流,标注为EF

2、172.16.10.0网段为TCP流量,标记为AF21

3、其它则为普通数据流量 ,标记为AF13。

RA#sh running-config

Building configuration...

Current configuration : 1824 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname RA

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

resource policy

!

ip cef

!

class-map match-all class-b

match access-group 101

class-map match-all class-a

match access-group 100

class-map match-all class-other

match dscp af13

class-map match-all class-voice

match dscp ef

class-map match-all class-date

match dscp af21

!

policy-map sample-policy1

class class-a

set dscp ef

class class-b

set dscp af21

class class-default

set dscp af13

policy-map traffic-policing

class class-voice

police 1000000 184000 368000 conform-action transmit exceed-action transmit

class class-date

police 5000000 936000 64000 conform-action transmit exceed-action drop

class class-other

police 3000000 562000 64000 conform-action transmit exceed-action set-dscp-transmit 0 violate-action drop

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface Ethernet1/0

ip address 10.1.1.2 255.255.255.252

duplex full

service-policy input sample-policy1

!

interface Ethernet1/1

ip address 10.1.1.5 255.255.255.252

duplex half

service-policy output traffic-policing

!

interface Ethernet1/2

no ip address

shutdown

duplex half

!

interface Ethernet1/3

no ip address

shutdown

duplex half

!

router ospf 10

router-id 2.2.2.2

log-adjacency-changes

network 10.1.1.0 0.0.0.3 area 0

network 10.1.1.4 0.0.0.3 area 0

!

no ip http server

no ip http secure-server

!

logging alarm informational

access-list 100 permit ip 192.168.100.0 0.0.0.255 any

access-list 101 permit tcp 172.16.10.0 0.0.0.255 any

!

control-plane

!

line con 0

exec-timeout 0 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

!

end

RA#

RB#sh running-config

Building configuration...

Current configuration : 1453 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname RB

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

resource policy

!

ip cef

!

class-map match-all class-other

match dscp af13

class-map match-all class-voice

match dscp ef

class-map match-all class-date

match dscp af21

!

policy-map traffic-policing

class class-voice

police 1000000 184000 368000 conform-action transmit exceed-action transmit

class class-date

police 5000000 936000 64000 conform-action transmit exceed-action drop

class class-other

police 3000000 562000 64000 conform-action transmit exceed-action set-dscp-transmit 0 violate-action drop

!

interface FastEthernet0/0

no ip address

shutdown

duplex half

!

interface Ethernet1/0

ip address 10.1.1.6 255.255.255.252

duplex half

!

interface Ethernet1/1

ip address 10.1.1.9 255.255.255.252

duplex half

service-policy output traffic-policing

!

interface Ethernet1/2

no ip address

shutdown

duplex half

!

interface Ethernet1/3

no ip address

shutdown

duplex half

!

router ospf 10

router-id 3.3.3.3

log-adjacency-changes

network 10.1.1.4 0.0.0.3 area 0

network 10.1.1.8 0.0.0.3 area 0

!

no ip http server

no ip http secure-server

!

logging alarm informational

!

control-plane

!

!

line con 0

exec-timeout 0 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

!

End

RC#sh running-config

Building configuration...

Current configuration : 1499 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname RC

!

boot-start-marker

boot-end-marker

!

enable password 123

!

no aaa new-model

!

resource policy

!

ip cef

!

class-map match-all class-other

match dscp af13

class-map match-all class-voice

match dscp ef

class-map match-all class-date

match dscp af21

!

policy-map traffic-policing

class class-voice

police 1000000 184000 368000 conform-action transmit exceed-action transmit

class class-date

police 5000000 936000 64000 conform-action transmit exceed-action drop

class class-other

police 3000000 562000 64000 conform-action transmit exceed-action set-dscp-transmit 0 violate-action drop

!

interface FastEthernet0/0

ip address 172.16.1.1 255.255.255.0

duplex half

service-policy output traffic-policing

!

interface Ethernet1/0

ip address 10.1.1.10 255.255.255.252

duplex half

!

interface Ethernet1/1

no ip address

shutdown

duplex half

!

interface Ethernet1/2

no ip address

shutdown

duplex half

!

interface Ethernet1/3

no ip address

shutdown

duplex half

!

router ospf 10

router-id 4.4.4.4

log-adjacency-changes

network 10.1.1.8 0.0.0.3 area 0

network 172.16.1.0 0.0.0.255 area 0

!

no ip http server

no ip http secure-server

!

logging alarm informational

!

control-plane

!

!

line con 0

exec-timeout 0 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

password 123

login

!

End

SW#sh running-config

Building configuration...

Current configuration : 1275 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SW

!

boot-start-marker

boot-end-marker

!

enable password 123

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

!

interface FastEthernet0/0

no switchport

ip address 10.1.1.1 255.255.255.252

!

interface FastEthernet0/1

no switchport

ip address 192.168.100.1 255.255.255.0

!

interface FastEthernet0/2

no switchport

ip address 172.16.10.1 255.255.255.0

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface Vlan1

no ip address

!

router ospf 10

router-id 1.1.1.1

log-adjacency-changes

network 10.1.1.0 0.0.0.3 area 0

network 172.16.10.0 0.0.0.255 area 0

network 192.168.100.0 0.0.0.255 area 0

!

ip http server

no ip http secure-server

!

control-plane

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password 123

login

!

!

end

RA#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 2 subnets

O 172.16.10.0 [110/11] via 10.1.1.1, 02:06:29, Ethernet1/0

O 172.16.1.0 [110/21] via 10.1.1.6, 02:06:29, Ethernet1/1

10.0.0.0/30 is subnetted, 3 subnets

O 10.1.1.8 [110/20] via 10.1.1.6, 02:06:29, Ethernet1/1

C 10.1.1.0 is directly connected, Ethernet1/0

C 10.1.1.4 is directly connected, Ethernet1/1

O 192.168.100.0/24 [110/11] via 10.1.1.1, 02:06:29, Ethernet1/0

SW#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 2 subnets

C 172.16.10.0 is directly connected, FastEthernet0/2

O 172.16.1.0 [110/22] via 10.1.1.2, 02:09:55, FastEthernet0/0

10.0.0.0/30 is subnetted, 3 subnets

O 10.1.1.8 [110/21] via 10.1.1.2, 02:09:55, FastEthernet0/0

C 10.1.1.0 is directly connected, FastEthernet0/0

O 10.1.1.4 [110/11] via 10.1.1.2, 02:09:55, FastEthernet0/0

C 192.168.100.0/24 is directly connected, FastEthernet0/1

RA#sh policy-map

Policy Map sample-policy1

Class class-a

set dscp ef

Class class-b

set dscp af21

Class class-default

set dscp af13

Policy Map traffic-policing

Class class-voice

police cir 1000000 bc 184000 be 368000

conform-action transmit

exceed-action transmit

Class class-date

police cir 5000000 bc 936000 be 64000

conform-action transmit

exceed-action drop

Class class-other

police cir 3000000 bc 562000 be 64000

conform-action transmit

exceed-action set-dscp-transmit default

violate-action drop

RB#show policy-map

Policy Map traffic-policing

Class class-voice

police cir 1000000 bc 184000 be 368000

conform-action transmit

exceed-action transmit

Class class-date

police cir 5000000 bc 936000 be 64000

conform-action transmit

exceed-action drop

Class class-other

police cir 3000000 bc 562000 be 64000

conform-action transmit

exceed-action set-dscp-transmit default

violate-action drop

RC#sh policy-map

Policy Map traffic-policing

Class class-voice

police cir 1000000 bc 184000 be 368000

conform-action transmit

exceed-action transmit

Class class-date

police cir 5000000 bc 936000 be 64000

conform-action transmit

exceed-action drop

Class class-other

police cir 3000000 bc 562000 be 64000

conform-action transmit

exceed-action set-dscp-transmit default

violate-action drop

测试一:

使用原地址为192.168.100.1,目标地址为172.16.1.10,这是一个语音数据流,进行测试,

SW#ping 172.16.1.10 source 192.168.100.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:

Packet sent with a source address of 192.168.100.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/41/96 ms

SW#ping 172.16.1.10 source 192.168.100.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:

Packet sent with a source address of 192.168.100.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/26/40 ms

SW#ping 172.16.1.10 source 192.168.100.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:

Packet sent with a source address of 192.168.100.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/51/88 ms

在172.16.1.10的Linux主机使用wireshark采集报文,如下图所示。

clip_p_w_picpath027

通过Wireshare可以看到数据包的DSCP值为0x2e,为Expedited Forwarding

测试二:

使用原地址为172.16.10.10主机去访问172.16.1.10的Linux主机的FTP服务,这是一个数据流量,如下图所示。

clip_p_w_picpath029

在172.16.1.10主机上使用wireshark采集数据报文,如下图所示。

clip_p_w_picpath031

通过Wireshare可以看到数据包的DSCP值为0x12,为Assured Forwarding 21.

测试三:

在交换上与远程Linux主机进行通信,这是一个其它数据流,如下所示。

SW#ping 172.16.1.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/43/88 ms

SW#ping 172.16.1.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/42/64 ms

SW#ping 172.16.1.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/33/48 ms

SW#ping 172.16.1.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 20/39/60 ms

在172.16.1.10主机上使用wireshark采集数据报文,如下图所示。

clip_p_w_picpath033

通过Wireshare可以看到数据包的DSCP值为0x0e,为Assured Forwarding 13.

测试四:

在路由器上使用show policy-map interface命令查看接口状态。

 

RA#sh policy-map interface

Ethernet1/0

Service-policy input: sample-policy1

Class-map: class-a (match-all)

35 packets, 3990 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 100

QoS Set

dscp ef

Packets marked 35

Class-map: class-b (match-all)

69 packets, 4295 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: access-group 101

QoS Set

dscp af21

Packets marked 69

Class-map: class-default (match-any)

1703 packets, 141652 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

QoS Set

dscp af13

Packets marked 1703

Ethernet1/1

Service-policy output: traffic-policing

Class-map: class-voice (match-all)

35 packets, 3990 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp ef (46)

police:

cir 1000000 bps, bc 184000 bytes

conformed 35 packets, 3990 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

transmit

conformed 0 bps, exceed 0 bps

Class-map: class-date (match-all)

69 packets, 4060 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp af21 (18)

police:

cir 5000000 bps, bc 936000 bytes

conformed 69 packets, 4060 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps

Class-map: class-other (match-all)

959 packets, 71399 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp af13 (14)

police:

cir 3000000 bps, bc 562000 bytes, be 64000 bytes

conformed 959 packets, 71399 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

set-dscp-transmit default

violated 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps, violate 0 bps

Class-map: class-default (match-any)

1582 packets, 154344 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

RB#sh policy-map interface

Ethernet1/1

Service-policy output: traffic-policing

Class-map: class-voice (match-all)

35 packets, 3990 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp ef (46)

police:

cir 1000000 bps, bc 184000 bytes

conformed 35 packets, 3990 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

transmit

conformed 0 bps, exceed 0 bps

Class-map: class-date (match-all)

69 packets, 4060 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp af21 (18)

police:

cir 5000000 bps, bc 936000 bytes

conformed 69 packets, 4060 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps

Class-map: class-other (match-all)

959 packets, 71399 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp af13 (14)

police:

cir 3000000 bps, bc 562000 bytes, be 64000 bytes

conformed 959 packets, 71399 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

set-dscp-transmit default

violated 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps, violate 0 bps

Class-map: class-default (match-any)

1530 packets, 149363 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

RC#sh policy-map interface

FastEthernet0/0

Service-policy output: traffic-policing

Class-map: class-voice (match-all)

25 packets, 2850 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp ef (46)

police:

cir 1000000 bps, bc 184000 bytes

conformed 25 packets, 2850 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

transmit

conformed 0 bps, exceed 0 bps

Class-map: class-date (match-all)

49 packets, 2927 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp af21 (18)

police:

cir 5000000 bps, bc 936000 bytes

conformed 49 packets, 2927 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps

Class-map: class-other (match-all)

882 packets, 66268 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: dscp af13 (14)

police:

cir 3000000 bps, bc 562000 bytes, be 64000 bytes

conformed 882 packets, 66268 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

set-dscp-transmit default

violated 0 packets, 0 bytes; actions:

drop

conformed 0 bps, exceed 0 bps, violate 0 bps

Class-map: class-default (match-any)

1589 packets, 150453 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

烦请各位工程师顺便给我投一票哟,先谢谢各位!