华为交换机端口基本配置指南

1.以太网端口的链路类型
S2000-HI系列以太网交换机支持的以太网端口链路类型有三种:
.. Access类型:端口只能属于1个VLAN,一般用于连接计算机;
.. Trunk类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,一般用于交换机之间连接;
.. Hybrid类型:端口可以属于多个VLAN,可以接收和发送多个VLAN的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。
说明:Hybrid端口可以允许多个VLAN的报文发送时不打标签,而Trunk端口只允许缺省VLAN的报文发送时不打标签
三种类型的端口可以共存在一台设备上,但Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其他类型端口。例如:Trunk端口不能直接被设置为Hybrid端口,只能先设为Access端口,再设置为Hybrid端口。
2.配置以太网端口的缺省VLAN ID
Access端口只能属于1个VLAN,所以它的缺省VLAN就是它所在的VLAN,不用设置;Hybrid端口和Trunk端口可以属于多个VLAN,所以需要设置端口的缺省VLAN ID。
配置了以太网端口的缺省VLAN ID后,端口对报文的接收和发送的处理有几种不同情况,具体描述请参见下示。
Access端口
当接收到的报文不带Tag时:接收该报文,并为报文添加缺省VLAN的Tag
当接收到的报文带有Tag时:
􀁺当VLAN ID与缺省VLAN ID相同时:接收该报文
􀁺当VLAN ID与缺省VLAN ID不同时:丢弃该报文
发送报文时的处理:由于VLAN ID就是缺省VLAN ID,不用设置,去掉Tag后发送
Trunk端口
当接收到的报文不带Tag时:接收该报文,并为报文添加缺省VLAN的Tag
当接收到的报文带有Tag时:
􀁺 当VLAN ID与缺省VLAN ID相同时:接收该报文
􀁺 当VLAN ID与缺省VLAN ID不同时,但VLAN ID是该端口允许通过的VLAN ID时:接收该报文
􀁺 当VLAN ID与缺省VLAN ID不同时,且VLAN ID是该端口不允许通过的VLAN ID时:丢弃该报文
发送报文时的处理:
.. 当VLAN ID与缺省VLAN ID相同时:去掉Tag,发送该报文
.. 当VLAN ID与缺省VLAN ID不同时:保持原有Tag,发送该报文
Hybrid端口
当接收到的报文不带Tag时:接收该报文,并为报文添加缺省VLAN的Tag
当接收到的报文带有Tag时:
􀁺 当VLAN ID与缺省VLAN ID相同时:接收该报文
􀁺 当VLAN ID与缺省VLAN ID不同时,但VLAN ID是该端口允许通过的VLAN ID时:接收该报文
􀁺 当VLAN ID与缺省VLAN ID不同时,且VLAN ID是该端口不允许通过的VLAN ID时:丢弃该报文
发送报文时的处理:
.. 当VLAN ID与缺省VLAN ID相同时:去掉Tag,发送该报文
.. 当VLAN ID与缺省VLAN ID不同时,可以通过命令port hybrid vlan vlan-id-list { tagged | untagged } 配置该端口是否带有Tag,发送该报文
注意:
本端Hybrid端口或Trunk端口的缺省VLAN ID和相连的对端交换机的Hybrid端口或Trunk端口的缺省VLAN ID必须一致,否则端口将不能正常转发报文。
3.将当前端口加入指定VLAN
用户可以将当前以太网端口加入到指定的VLAN中。执行该配置以后,以太网端口就可以转发指定VLAN的报文,从而实现本交换机上的VLAN与对端交换机上相同VLAN的互通。
Access端口只能加入到1个VLAN中,Hybrid端口和Trunk端口可以加入到多个VLAN中。
说明:
端口要加入的VLAN必须已经存在。执行了以上配置后,以太网端口就可以转发指定VLAN的报文,从而实现本交换机上的VLAN与对端交换机上相同VLAN的报文互通。
4.设置VLAN端口
配置Access端口相关属性
进入系统视图
system-view
进入以太网端口视图
interface interface-type interface-number
配置端口的链路类型为Access
port link-type access
缺省情况下,端口的链路类型为Access
将当前Access端口加入到指定VLAN
port access vlan vlan-id
配置Trunk端口相关属性
进入系统视图
system-view
进入以太网端口视图
interface interface-type interface-number
配置端口的链路类型为Trunk
port link-type trunk
设置Trunk端口的缺省VLAN ID
port trunk pvid vlan vlan-id
可选,Trunk端口的缺省VLAN就是系统的缺省VLAN
将当前Trunk端口加入到指定VLAN
port trunk permit vlan { vlan-id-list | all }
配置Hybrid端口相关属性
进入系统视图
system-view
进入以太网端口视图
interface interface-type interface-number
配置端口的链路类型为Hybrid
port link-type hybrid     必选
设置Hybrid端口的缺省VLAN ID
port hybrid pvid vlan vlan-id      
可选,Hybrid端口的缺省VLAN就是系统的缺省VLAN
将当前Hybrid端口加入到指定VLAN
port hybrid vlan vlan-id-list { tagged | untagged }
可选,Hybrid端口可以设置是否为指定VLAN的报文打上标签,为实现对不同VLAN报文执行不同处理流程打下基础
5.以太网端口的基本配置
进入系统视图
system-view
进入以太网端口视图
interface interface-type interface-number
打开以太网端口
undo shutdown
缺省情况下,端口处于打开状态,如果想关闭端口,可以使用shutdown命令
设置以太网端口描述字符串
description text
缺省情况下,端口的描述字符串为空字符串
设置以太网端口的双工模式
duplex { auto | full | half }
缺省情况下,端口的双工模式为auto(自协商)
设置以太网端口的速率
speed { 10 | 100 | 1000 | auto }
缺省情况下,端口的速率处于auto(自协商)状态
设置以太网端口的MDI属性
mdi { across | auto | normal }
缺省情况下,端口的MDI属性与端口类型相关
6.interface
【命令】
interface interface-type interface-number
【视图】
系统视图
【参数】
interface-type:端口类型,取值可以为Aux、Ethernet、GigabitEthernet、LoopBack、NULL 或Vlan-interface。
interface-number:端口编号,采用Unit ID/槽位编号/端口序号的格式,其中:
.. Unit ID 取值只能为1;
.. 如果端口类型为 Ethernet,则槽位编号为0,如果端口类型为GigabitEthernet,则槽位编号为1 或2;
.. 端口序号与设备支持的端口数量相关。
【描述】
interface 命令用来进入相应端口的视图。比如,用户要配置以太网端口的相关参数,必须先使用该命令进入以太网端口视图。
【举例】
# 进入Ethernet1/0/1 以太网端口视图。
<Sysname> system-view
System View: return to User View with Ctrl+Z.
[Sysname] interface ethernet 1/0/1
[Sysname-Ethernet1/0/1]
7.display interface
【命令】
display interface [ interface-type | interface-type interface-number ]
【视图】
任意视图
【参数】
interface-type:端口类型。
interface-number:端口编号。
参数的具体说明请参见 interface 命令中的参数解释。
【描述】
display interface 命令用来显示端口的配置信息。
在显示端口信息时,如果不指定端口类型和端口号,则显示交换机上所有的端口信息;如果仅指定端口类型,则显示该类型端口的所有端口信息;如果同时指定端口类型和端口号,则显示指定的端口信息。
8.duplex
【命令】
duplex { auto | full | half }
undo duplex
【视图】
以太网端口视图
【参数】
auto:端口处于自协商状态。
full:端口处于全双工状态。
half:端口处于半双工状态。
【描述】
duplex 命令用来设置以太网端口的双工属性。undo duplex 命令用来将端口的双工属性恢复为缺省的自协商状态。
缺省情况下,端口处于自协商状态。
【举例】
# 将以太网端口Ethernet1/0/1 端口的双工属性设置为自协商状态。
<Sysname> system-view
System View: return to User View with Ctrl+Z.
[Sysname] interface ethernet 1/0/1
[Sysname-Ethernet1/0/1] duplex auto
9.speed
【命令】
speed { 10 | 100 | 1000 | auto }
undo speed
【视图】
以太网端口视图
【参数】
第1 章端口基本配置命令
Quidway S2000-HI 系列以太网交换机命令手册
端口基本配置
1-26 华为所有和机密
版权所有 (c) 华为技术有限公司
10:指定端口速率为10 Mbps。
100:指定端口速率为100 Mbps。
1000:指定端口速率为1000 Mbps(该参数仅千兆端口支持)。
auto:指定端口的速率处于自协商状态。
【描述】
speed 命令用来设置端口的速率。undo speed 命令用来恢复端口的速率为缺省值。
缺省情况下,端口速率处于自协商状态。
需要注意的是,千兆端口只能将速率配置为 1000Mbps 或auto 状态。
相关配置可参考命令 duplex。
【举例】
# 设置以太网端口Ethernet1/0/1 的速率为10Mbps。
<Sysname> system-view
System View: return to User View with Ctrl+Z.
[Sysname] interface ethernet 1/0/1
[Sysname-Ethernet1/0/1] speed 10
10,vlan下hybrid端口配置
hybrid端口收报文:
收到一个报文,判断是否有VLAN信息:如果没有则打上端口的PVID,并进行交换转发,如果有则判断该hybrid端口是否允许该VLAN的数据进入:如果可以则转发,否则丢弃(此时端口上的untag配置是不用考虑的,untag配置只对发送报文时起作用)
注:默认的PVID VLAN是不打标签的!
hybrid端口发报文:
1、判断该VLAN在本端口的属性(disp interface 即可看到该端口对哪些VLAN是untag, 哪些VLAN是tag)
2、如果是untag则剥离VLAN信息,再发送,如果是tag则直接发送
以下案例可以帮助大家深入理解华为交换机的hybrid端口模式
[Switch-Ethernet0/1]int e0/1
[Switch-Ethernet0/1]port link-type hybrid
[Switch-Ethernet0/1]port hybrid pvid vlan 10
[Switch-Ethernet0/1]port hybrid vlan 10 20 untagged
[Switch-Ethernet0/1] int e0/2
[Switch-Ethernet0/2]port link-type hybrid
[Switch-Ethernet0/2]port hybrid pvid vlan 20
[Switch-Ethernet0/2]port hybrid vlan 10 20 untagged
此时inter e0/1和inter e0/2下的所接的PC是可以互通的,但互通时数据所走的往返vlan是不同的。
以下以inter e0/1下的所接的pc1访问inter e0/2下的所接的pc2为例进行说明pc1所发出的数据,由inter0/1所在的pvid vlan10封装vlan10的标记后送入交换机,交换机发现inter e0/2允许vlan 10的数据通过,于是数据被转发到inter e0/2上,由于inter e0/2上vlan 10是untagged的,于是交换机此时去除数据包上vlan10的标记,以普通包的形式发给pc2,此时pc1->p2走的是vlan10再来分析pc2给pc1回包的过程,pc2所发出的数据,由inter0/2所在的pvid vlan20封装vlan20的标记后送入交换机,交换机发现inter e0/1允许vlan 20的数据通过,于是数据被转发到inter e0/1上,由于inter e0/1上vlan 20是untagged的,于是交换机此时去除数据包上vlan20的标记,以普通包的形式发给pc1,此时pc2->pc1走的是vlan20