实验环境:Packet Tracer 5.0
 
实验拓扑:
 
实验配置:
 
一、路由器基本配置
 
1、配置主机名
R(config)#hostname ×××
 
2、配置使能加密密码(本实验中未配置)
R(config)#enable secret ×××
 
3、禁用DNS
R(config)#no ip domain-lookup
 
4、配置超时与显示同步
R(config)#line console 0
R(config-line)#exec-timeout 0 0
R(config-line)#logging synchronous
 
二、实验要求配置
 
R1
 
1、配置内部端口IP地址
R1(config)#interface f0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
 
2、配置外部端口IP地址
R1(config)#interface s1/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
 
3、配置内网访问外网的ACL
R1(config)#access-list 1 permit 10.1.1.0 0.0.0.255
 
4、创建NAT转换地址池
R1(config)#ip nat pool test 192.168.1.20 192.168.1.20 netmask 255.255.255.0
 
5、配置复用动态IP地址转换
R1(config)#ip nat inside source list 1 pool test overloads
 
6、在内部和外部端口上启用NAT
R1(config)#interface f0/0
R1(config-if)#ip nat inside
 
R1(config)#interface s1/0
R1(config-if)#ip nat outside
 
7、静态路由配置
R1(config)#ip route 172.16.1.0 255.255.255.0 192.168.1.2
 
R2
 
1、外部端口IP地址配置
R2(config)#interface s1/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
 
2、内部端口IP地址配置
R2(config)#interface f0/0
R2(config-if)#ip address 172.16.1.1 255.255.255.0
R2(config-if)#no shutdown
 
3、创建内部可以访问外部的ACL
R2(config)#access-list 1 permit 172.16.1.0 0.0.0.255

4、配置复用动态IP地址转换
R2(config)#ip nat inside soure list 1 interface s1/0 overload
 
5、在内部和外部端口上启用NAT
R2(config)#interface s1/0
R2(config-if)#no ip outside
 
R2(config)#interface f0/0
R2(config-if)#no ip inside
 
6、配置静态路由
R2(config)#ip route 10.1.1.0 255.255.255.0 192.168.1.1
 

实验用到的拓扑图、配置文档和Packet Tracer 5.0实验原文件都已上传,需要的网友,可以随时下载!