最近了解了下着双isp(internet server provider 服务提供商)
下面是一个典型的列子:
模仿着为南方企业做双isp
企业要求:在正常情况下,企业访问外网首选电信,网通用于故障接替(南电信,北网通;在南方电信较稳定较好做首选,网通在北方较好在此做备选)
       (各网段,ip地址,掩码,路由均在图中表明)
 
 
 
 
 
(连接console端口进行)配置:(配置那个路由,就接那个路由的console端口)
电信:
ena
config terminal(进入配置模式)
no ip domain lookup
line console 0
no exec-time(永不超时)
logging syn(同步日志)
exit
host dianxin
interface s0/0
ip add 202.101.224.1 255.255.255.252(配30位掩码是最大利用公网地址)
no sh
inter s0/1
ip add 202.101.225.1 255.255.255.252
no sh
inter lo0(进入回环口,配置回环地址)
ip add 2.2.2.2 255.255.255.0
no sh(此命令可不写,因为回环地址永不断开)
exit
router rip
ve 2(采用rip2协议)
net 202.101.224.0
net 202.101.225.0
net 2.2.2.0
no auto-summary
网通
ena
conf t
no ip do lo
line console 0
no exec-t
logg syn
host wangtong
inter s0/1
ip add 60.1.1.1 255.255.255.252
no sh
inter s0/0
ip add 202.101.226.1 255.255.255.252
no sh
inter l0
ip add 3.3.3.3 255.255.255.0
no sh
exit
router rip
ve 2
net 202.101.226.0
net 60.1.1.0
net 3.3.3.0
no auto-summary
外网
ena
conf t
no ip do lo
line console 0
no exec-t
logg syn
host internet
int s0./0
ip add 202.101.225.2 255.255.255.252
no sh
int s0/1
ip add 202.101.226.2 255.255.255.252
no sh
int l0
ip add 4.4.4.4 255.255.255.252
no sh
router rip
ve 2
net 202.101.225.0
net 202.101.226.0
net 4.4.4.0
no auto-summary
企业:
ena
conf t
no ip do lo
line console 0
no exec-t
logg syn
host qiye
inter s0/0
ip add 202.101.224.2 255.255.255.252
ip nat outside(在此接口做出站)
no sh
inter s0/1
ip add 60.1.1.2 255.255.255.252
ip nat outside(同样做出站)
no sh
inter f1/0(真机路由器中一般用e0/0代替)
ip add 192.168.1.2 255.255.255.0
ip nat inside(此处得做进站,进入内部私网)
no sh
int l0
ip add 1.1.1.1 255.255.255.0
no sh
exit
ip route 0.0.0.0 0.0.0.0 202.101.224.1(做静态路由,最后跟的是下一跳)
ip route 0.0.0.0 0.0.0.0 60.1.1.1 10(末尾10是配置优先级,以默认优先级1为最高)
ip route 3.3.3.0 255.255.255.0 60.1.1.1
access-list 1 permit 192.168.1.0 0.0.0.255(定义内部访问外部的acl访问控制列表,最后跟的是通配符掩码)
route-map dianxin permit 10(配置路由图)
match ip add 1(此处1指的是上面配的列表1)
match inter s0/0(将策略路由应用到接口)
route-map wangtong permit 20
match ip add 1
match inter s0/1
ip nat inside source route-map inter s0/0 overload(将内部地址转换成企业公网地址)
ip nat inside source route-map inter s0/1 overload
                                                         (over)
                                             
相关小知识:
show ip route(查看路由表信息)
show ip interface brief(查看所有接口信息)
show running (查看您在该路由上做的所有配置)
trac ~.~.~.~(所要ping的地址)source ~.~.~.~(源地址)
(跟踪ping所走的路径,在真机算计上用   tracert,当trac    不通数据包丢失时,会不停的出现*号,可用  ctrl+shfit+6  来停止)
小细节注意:
虚机配置:协议 telnet 主机名 127.0.0.1 端口 (路由)2001、2002......(交换机)3001、3002......
真机上登陆配置一般是:协议 选 serial 端口 COM1 波特率 9600
用 SecureCRT 软件;选择 在同一标签中打开 比较方便
 
       呵呵,能想起的差不多了,要睡了......