HSRPVRRP是最常用的网关冗余技术。 HSRPCisco专有协议。HSRP(Hot Standby Router Protocol)把多台路由器组成一个“热备份组”,组成一个虚拟路由器。这个组中只有一个路由器是Active的,而且由它来转发数据包。万一活动路由器发生了故障,备份路由器将成为活动路由器。从网内的主机来看,它们的网关依旧没有改变。从而实现整个网络的冗余,保证网络的不间断运行。下面,我们来做HSRP的实验。
实验拓扑:
 
配置步骤:
一:配置IP地址和路由协议:
R1:
Router>en
Router#conf t
Router(config)#hostname R1
R1(config)#interface f1/0
R1(config-if)#ip add 192.168.30.1 255.255.255
R1(config-if)#no shutdown
R1(config-if)#int s0/0
R1(config-if)#ip add 192.168.10.1 255.255.255
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router rip     //启用RIP路由协议
R1(config-router)#network 192.168.30.0   //宣告直连网段
R1(config-router)#network 192.168.10.0
R1(config-router)#passive-interface f1/0    //F1/0设定为被动接口
R2:
Router>en
Router#conf t
Router(config)#no ip domain lookup    //关闭域名查找功能
Router(config)#lin con 0
Router(config-line)#logg s     //设定输出信息同步,以免打扰操作
Router(config-line)#exit
Router(config)#hostname R2
R2(config)#interface f1/0
R2(config-if)#ip add 192.168.40.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface s0/0
R2(config-if)#ip add 192.168.10.2 255.255.255.0
R2(config-if)#clock rate 64000    //设定串口时钟
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface s0/1
R2(config-if)#ip add 192.168.20.1 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router rip    //启用RIP协议
R2(config-router)#network 192.168.10.0    //宣告直连网段
R2(config-router)#network 192.168.40.0
R2(config-router)#network 192.168.20.0
R2(config-router)#passive-interface f1/0    //设定F1/0为被动端口
R2(config-router)#^Z
R3:
Router>en
Router#conf t
Router(config)#hostname R3
R3(config)#no ip domain lookup     //关闭域名查找功能
R3(config)#lin con 0
R3(config-line)#logg s     //设定输出信息同步
R3(config-line)#exit
R3(config)#interface f1/0
R3(config-if)#ip add 192.168.30.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface s0/0
R3(config-if)#ip add 192.168.20.2 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router rip   //启用RIP路由协议
R3(config-router)#network 192.168.20.0    //宣告直连的网段
R3(config-router)#network 192.168.30.0
R3(config-router)#passive-interface f1/0    //设定F1/0为被动端口
R3(config-router)#exit
R3(config)#^Z
二:配置HSRP
R1:
R1(config)#interface f1/0
R1(config-if)#standby 100 ip 192.168.30.254   //启用HSRP.设置虚拟IP地址,100standby的组号。相同组号的路由属于同一个HSRP组。所有属于相同的HSRP组的路由器的虚拟地址必须一致。
R1(config-if)#standby 100 priority 180   //设定HSRP的优先级。默认为100.这个值越大,抢占为活动路由器的优先权就越高。
R1(config-if)#standby 100 preempt    //设置允许该路由器在优先级是最高时成为活动路由器。如果不设置,值再高它也不会自动成为活动路由器。
R1(config-if)#standby 100 timers 3 10   //3表示hello time,指路由器每间隔多长时间发送hello信息。10hold time,指在多长时间内同组其他路由器没有收到活动路由的信息,则认为活动路由死了。默认值就是3s10s。如果要更改的话,同HSRP的路由器必须一样。
R1(config-if)#standby 100 authentication md5 key-string ccxx   //配置认证密码,阻止非法设备加入到HSRP中来,同组的密码必须一致。
R1(config-if)#standby 100 track s0/0 80   //配置跟踪端口。设置跟踪S0/0口,如果该接口出现故障,自动将优先权降低80.降低的值应该选合适的值,便其他路由器能成为Active状态。
R1(config-if)#exit
 
R2:
R2(config)#interface f1/0 
R2(config-if)#standby 100 ip 192.168.30.254  //启用HSRP功能。设置虚拟IP地址,100standby的组号。相同的组号属于同一个HSRP。所有属于同一个HSRP组的虚拟地址必须一致。
R2(config-if)#standby 100 priority 120   //配置R2的优先级为120,默认为100.
R2(config-if)#standby 100 preempt     //设置允许该路由器在优先级是最高时成为活动路由器。如果不设置,值再高它也不会自动成为活动路由器。
R2(config-if)#standby 100 timers 3 10    //3表示hello time,指路由器每间隔多长时间发送hello信息。10hold time,指在多长时间内同组其他路由器没有收到活动路由的信息,则认为活动路由死了。默认值就是3s10s。如果要更改的话,同HSRP的路由器必须一样。
R2(config-if)#standby 100 authentication md5 key-string ccxx   //配置认证密码,阻止非法设备加入到HSRP中来,同组的密码必须一致。
R2(config-if)#^Z
三:检查,测试HSRP:
R1#show standby brief
 
//以上表明R1就是活动路由器,备份路由器为192.168.40.1
R2# show standby brief
 
 
//以上表明R2是备份路由器,活动路由器是192.168.30.1
 
注:
HSRP实际在局域网用得比较多,而且大多是在交换机上面配置的。
 
扩展实验:
  我们还可以再创建一个HSRP组,虚拟出另外一个网关地址。比如虚拟出网关192.168.30.252,这时,R3是活动路由器,使一部分PC指向此网关,这样可以做到负载均衡。