在CentOS下安装pip


Python和操作系统支持

Pip工作于CPython版本2.6,2.7,3.2,3.3,3.4以及pypy。

pip包含于Python

Python 2.7.9及之后(在python2系列),和Python 3.4和之后默认包含pip,因此你可能已经有了pip。


安装pip


  1. https://bootstrap.pypa.io/get-pip.py下载get-pip.py。

  2. 运行如下命令:

    python get-pip.py


如何setuptools还没有安装,get-pip.py将会安装setuptools。


为了升级已经存在的setuptools,运行pip install -U setuptools。


此外,get-pip.py支持使用pip安装选项普通选项。以下是一些示例:


从本地的pip和setuptools副本安装:

python get-pip.py --no-index --find-links=/local/copies


安装到用户目录:

python get-pip.py --user


从proxy后安装:

python get-pip.py --proxy=”[user:passwd@]proxy.server:port”


升级pip

pip install -U pip

 

原文地址:https://pip.pypa.io/en/latest/installing/