题目:


Last non-zero Digit in N!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 815 Accepted Submission(s): 344

 

Problem Description


The expression N!, read as "N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example, 
N N! 
0 1 
1 1 
2 2 
3 6 
4 24 
5 120 
10 3628800 

For this problem, you are to write a program that can compute the last non-zero digit of the factorial for N. For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and 2 is the last nonzero digit of 120. 


 

Input


Input to the program is a series of nonnegative integers, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.


 

Output


For each integer input, the program should print exactly one line of output containing the single last non-zero digit of N!.


 

Sample Input



1 2 26 125 3125 9999



 

Sample Output



124828



 

 

Source


South Central USA 1997


 

Recommend


JGShining



题目分析:

              求阶乘最后一位非零位。因为N很大,那种暴力的思想肯定是行不通的。这道题想了很久,到现在想的也还不是很明白。但是吉大的ACM模板有这个。所以就直接用了。暂时先放一放吧。


代码如下:


/*
 * e.cpp
 *
 *  Created on: 2015年2月5日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <string.h>
#include <cstdlib>

#define MAXN 10000


int lastdigit(char* buf) {
	const int mod[20] = { 1, 1, 2, 6, 4, 2, 2, 4, 2, 8, 4, 4, 8, 4, 6, 8, 8, 6,
			8, 2 };
	int len = strlen(buf), a[MAXN], i, c, ret = 1;
	if (len == 1){
		return mod[buf[0] - '0'];
	}
	for (i = 0; i < len; i++){
		a[i] = buf[len - 1 - i] - '0';
	}
	for (; len; len -= !a[len - 1]) {
		ret = ret * mod[a[1] % 2 * 10 + a[0]] % 5;
		for (c = 0, i = len - 1; i >= 0; i--){
			c = c * 10 + a[i];
			a[i] = c / 5;
			c %= 5;
		}
	}
	return ret + ret % 2 * 5;
}


int main(){
	char n[MAXN];
	while(scanf("%s",&n)!=EOF){
		printf("%d\n",lastdigit(n));
	}

	return 0;
}