最近抽空学习python,了解到python还可以gui开发。然后了解到了pyqt,功能比较强大支持webkit内核。因此想小试牛刀。

尝试的过程比较曲折,老是报加载dll出错,找不到指定模块。最后翻墙,知道是版本不对应的原因。因此给出一个尝试成功的版本如下图:

使用pyqt5  QWebEngineView开发浏览器_客户端

给出共享地址

​​

给出sourceforge下载地址

​​

自己的学习成长,来自于大家的无私共享,因此在共享里面也包含一本pyqt开发指导书籍。

贴出最简单的demo代码

from PyQt5.QtWidgets import QApplication
from PyQt5.QtWebEngineWidgets import QWebEngineView
from PyQt5.QtCore import QUrl

app = QApplication([])
view = QWebEngineView()
view.load(QUrl("http://www.baidu.com"))
view.show()
app.exec_()

之前使用pyqt5的版本的小伙伴们要注意了,pyqt4和5有一些区别,贴出官网文档的说明:

使用pyqt5  QWebEngineView开发浏览器_客户端_02

运行效果:

使用pyqt5  QWebEngineView开发浏览器_客户端_03

其他浏览器实现

【浏览器&exe桌面应用】用PyInstaller cefpython打包exe,制作自己的浏览器;查询机客户端,大屏展示客户端,大数据展示客户端