Two Rabbits

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 248    Accepted Submission(s): 108


Problem Description

Long long ago, there lived two rabbits Tom and Jerry in the forest. On a sunny afternoon, they planned to play a game with some stones. There were n stones on the ground and they were arranged as a clockwise ring. That is to say, the first stone was adjacent to the second stone and the n-th stone, and the second stone is adjacent to the first stone and the third stone, and so on. The weight of the i-th stone is ai.

The rabbits jumped from one stone to another. Tom always jumped clockwise, and Jerry always jumped anticlockwise.

At the beginning, the rabbits both choose a stone and stand on it. Then at each turn, Tom should choose a stone which have not been stepped by itself and then jumped to it, and Jerry should do the same thing as Tom, but the jumping direction is anti-clockwise.

For some unknown reason, at any time , the weight of the two stones on which the two rabbits stood should be equal. Besides, any rabbit couldn't jump over a stone which have been stepped by itself. In other words, if the Tom had stood on the second stone, it cannot jump from the first stone to the third stone or from the n-the stone to the 4-th stone.

Please note that during the whole process, it was OK for the two rabbits to stand on a same stone at the same time.

Now they want to find out the maximum turns they can play if they follow the optimal strategy.

 


Input

The input contains at most 20 test cases.
For each test cases, the first line contains a integer n denoting the number of stones.
The next line contains n integers separated by space, and the i-th integer ai denotes the weight of the i-th stone.(1 <= n <= 1000, 1 <= ai <= 1000)
The input ends with n = 0.

 


Output

For each test case, print a integer denoting the maximum turns.

 


Sample Input

1
1
4
1 1 2 1
6
2 1 1 2 1 3
0

 


Sample Output

Hint

 


Source

​2013 ACM/ICPC Asia Regional Hangzhou Online​

 


Recommend

liuyiding

 

经典的回文子序列,求法改自清华队的代码。

#include<cstdio>
#include<cstring>
#include<iostream>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
using namespace std;
const int mm=1010;
int dp[mm][mm],f[mm],n;
int next(int x)
{
x=(x+1)%n;
return x;
}
int pre(int x)
{
x=(n+x-1)%n;
return x;
}
int DP(int l,int r)
{
if(l==r)return 1;
if(next(l)==r)return 1+(f[l]==f[r]);
if(dp[l][r]!=-1)return dp[l][r];
if(f[l]==f[r])
return dp[l][r]=DP(next(l),pre(r))+2;
else return dp[l][r]=max(DP(next(l),r),DP(l,pre(r)));
}
int main()
{
while(~scanf("%d",&n))
{ if(n==0)break;
FOR(i,0,n-1)
scanf("%d",&f[i]);
int ans=0;
clr(dp,-1);
if(n==1)ans=1;
else
FOR(i,0,n-1)
{
ans=max(ans,DP(next(i),i));///以i左右边为起点
ans=max(ans,DP(next(i),pre(i))+1);///以i为起点
}
printf("%d\n",ans);
}
}