安卓安装提示:Android SDK requires Android Developer Toolkit version 21.1.0 or above.  (错误解决方法)


主要是由于版本不对,sdk和adt的版本。

解决思路:

打开​​Eclipse​​--帮助(help) -- Install Now Software -- Add按钮

 Name:随便输入

下面的文本框输入 :http://dl-ssl.google.com/android/eclipse/

在线更新就行了,超慢呀!

======================

另外,也可以下载下来安装包,然后不输入上面的网址,通过local选择下载的本地文件进行更新。

下载ADT地址:​​http://developer.android.com/tools/sdk/eclipse-adt.html​


====================== 总结说明

这里主要是安卓sdk 版本与ADT版本问题,下载一个与sdk版本对应的adt文件包,本地更新。