实验拓扑

OSPF路由重分发_静态路由

配置各路由器,以及OSPF协议,RIP协议,静态路由

配置各个路由器的ip地址及loopback 0地址

IOU1(config)#interface ethernet 0/1

IOU1(config-if)#ip address 192.168.13.1 255.255.255.0

IOU1(config-if)#no shutdown  

IOU1(config-if)#ex

IOU1(config)#interface ethernet 0/0

IOU1(config-if)#ip address 192.168.12.1 255.255.255.0

IOU1(config-if)#no shutdown  

IOU1(config-if)#ex

IOU1(config)#interface ethernet 0/2

IOU1(config-if)#ip address 100.0.0.1 255.255.255.0

IOU1(config-if)#no shutdown  

IOU1(config-if)#ex

IOU1(config)#interface loopback 0

IOU1(config-if)#ip address 1.1.1.1 255.255.255.255

IOU1(config-if)#exit

使用show ip interface brief查看各个接口

OSPF路由重分发_redis_02


配置ospf协议以及rip协议

IOU1(config)#router ospf 1

IOU1(config-router)#router-id 1.1.1.1

IOU1(config-router)#network 192.168.12.0 0.0.0.255 area 0

IOU1(config-router)#network 192.168.13.0 0.0.0.255 area 1

IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0

使用show ip ospf database查看

OSPF路由重分发_redis_03

配置IOU1域ISP连接处用默认路由

IOU1(config)#ip route 0.0.0.0 0.0.0.0 100.0.0.2

配置IOU2与IOU5连接用rip

IOU2(config)#router rip  

IOU2(config-router)#version 2                            \\用rip的2号版本

IOU2(config-router)#no auto-summary                \\关闭路由汇总

IOU2(config-router)#network 192.168.25.0  

IOU2(config-router)#exit

配置重分发ospf和rip

在IOU2上面配置

IOU2(config)#router ospf 1                

IOU2(config-router)#no redistribute rip subnets metric 5

IOU2(config-router)#redistribute rip metric 200 subnets  

IOU2(config-router)#exit

IOU2(config)#router rip

IOU2(config-router)#redistribute ospf 1 metric 5

IOU2(config-router)#exit

IOU1上配置

IOU1(config)#router ospf 1

IOU1(config-router)#default-information originate  

IOU1(config-router)#exit

使用show ip route命令查看

OSPF路由重分发_ip协议_04

在IOU3中重分发静态路由和直连路由

IOU3(config)#router ospf 1

IOU3(config-router)#redistribute static subnets  

IOU3(config-router)#redistribute connected subnets  

IOU3(config-router)#exit

使用ping命令进行互通

OSPF路由重分发_ip协议_05OSPF路由重分发_redis_06