实验环境

OSPF多区域间配置_路由器配置

实验需求:在不同的area之间互通,并且避免由于网段变更导致的重复配置

实验步骤:1,配置路由器接口和loopback接口。

    2,配置OSPF协议,实现内部全网络互通。

    3,验证网络访问是否正常。

1,配置路由器接口和loopback接口

R1路由器配置如下

IOU1(config)#interface ethernet 0/0

IOU1(config-if)#ip address 10.0.30.1 255.255.255.0

IOU1(config-if)#no shutdown  

IOU1(config-if)#ex  

IOU1(config)#interface loopback 0

IOU1(config-if)#ip address 1.1.1.1 255.255.255.255  

IOU1(config-if)#ex  

IOU1(config)#interface ethernet 0/1

IOU1(config-if)#ip address 10.0.20.1 255.255.255.0

IOU1(config-if)#no shutdown  

IOU1(config-if)#ex  

IOU1(config)#interface ethernet 0/2

IOU1(config-if)#ip address 10.0.10.1 255.255.255.0

IOU1(config-if)#no shutdown  

IOU1(config-if)#ex

R2配置如下

IOU2(config)#interface ethernet 0/0

IOU2(config-if)#ip address 10.0.10.2 255.255.255.0

IOU2(config-if)#no shutdown  

IOU2(config-if)#ex  

IOU2(config)#interface loopback 0

IOU2(config-if)#ip address 2.2.2.2 255.255.255.255  

IOU2(config-if)#ex  

R3配置如下

IOU3(config)#interface ethernet 0/0

IOU3(config-if)#ip address 10.0.20.2 255.255.255.0

IOU3(config-if)#no shutdown  

IOU3(config-if)#ex  

IOU3(config)#interface loopback 0

IOU3(config-if)#ip address 3.3.3.3 255.255.255.255  

IOU3(config-if)#ex  

R4配置如下

IOU4(config)#interface ethernet 0/0

IOU4(config-if)#ip address 10.0.30.2 255.255.255.0

IOU4(config-if)#no shutdown  

IOU4(config-if)#ex  

IOU4(config)#interface loopback 0

IOU4(config-if)#ip address 4.4.4.4 255.255.255.255  

IOU4(config-if)#ex  

使用show ip interface brief命令查看接口ip以及loopback地址

OSPF多区域间配置_配置信息_02

2,配置OSPF协议,实现内部全网络互通

R1配置如下

IOU1(config)#router ospf 1

IOU1(config-router)#router-id 1.1.1.1

IOU1(config-router)#network 10.0.20.0 0.0.0.255 area 0

IOU1(config-router)#network 1.1.1.1 0.0.0.0 area 0

IOU1(config-router)#network 10.0.30.0 0.0.0.255 area 2

IOU1(config-router)#network 10.0.10.0 0.0.0.255 area 1

R2配置如下

IOU2(config)#router ospf 1

IOU2(config-router)#router-id 2.2.2.2

IOU2(config-router)#network 2.2.2.2 0.0.0.0 area 1

IOU2(config-router)#network 10.0.10.0 0.0.0.255 area 1

R3配置如下

IOU3(config)#router ospf 1

IOU3(config-router)#router-id 3.3.3.3

IOU3(config-router)#network 3.3.3.3 0.0.0.0 area 0

IOU3(config-router)#network 10.0.20.0 0.0.0.255 area 0

R4配置如下

IOU1(config)#router ospf 1

IOU1(config-router)#router-id 4.4.4.4

IOU1(config-router)#network 4.4.4.4 0.0.0.0 area 2

IOU1(config-router)#network 10.0.30.0 0.0.0.255 area 2

使用show ip ospf database 查看ospf配置信息

OSPF多区域间配置_配置信息_03

OSPF多区域间配置_路由器配置_04

3,验证网络访问是否正常

使用ping命令进行查看

OSPF多区域间配置_配置信息_05